New installation of homegear for MAX! .. I am lost

Hi,

I installed homegear on a pi3; then started homegear (sudo homegear) when I do

families list

I obtain

families list
   ID │ Name
──────┼───────────────────────────────
    5 │ Philips hue
    6 │ Sonos
    9 │ Kodi
   10 │ IPCam
  254 │ Miscellaneous
──────┴───────────────────────────────

but no MAX!

Sorry newb here

This is the valve I bpought and installed (99017)

I receive this, but why does not load MAX???
02/02/17 15:32:44.177 Info: Not initializing device family MAX!, because no physical interface was found.
02/02/17 15:32:44.177 Info: Disposing family module mod_max.so

pi@raspberrypi:~ $ sudo homegear
02/02/17 15:32:43.921 Loading RPC server settings from /etc/homegear/rpcservers.conf
02/02/17 15:32:43.922 Loading RPC client settings from /etc/homegear/rpcclients.conf
02/02/17 15:32:43.924 Starting Homegear...
02/02/17 15:32:43.924 Homegear version 0.6.14-874
02/02/17 15:32:43.924 Git commit SHA of libhomegear-base: -
02/02/17 15:32:43.924 Git branch of libhomegear-base:     -
02/02/17 15:32:43.924 Git commit SHA of Homegear:         -
02/02/17 15:32:43.924 Git branch of Homegear:             -
02/02/17 15:32:43.925 Info: Setting allowed core file size to "4294967295" for user with id 0 and group with id 0.
02/02/17 15:32:43.926 Info: Core file size now is "4294967295".
02/02/17 15:32:43.926 Info: Setting maximum thread priority to "95" for user with id 0 and group with id 0.
02/02/17 15:32:43.926 Info: Maximum thread priority now is "95".
02/02/17 15:32:43.938 Info: Backing up database...
02/02/17 15:32:44.017 Initializing database...
02/02/17 15:32:44.024 Info: Loading family module mod_kodi.so
02/02/17 15:32:44.031 /etc/homegear/families/kodi.conf
02/02/17 15:32:44.033 Info: Loading family module mod_enocean.so
02/02/17 15:32:44.040 /etc/homegear/families/enocean.conf
02/02/17 15:32:44.042 Info: Loading family module mod_intertechno.so
02/02/17 15:32:44.050 /etc/homegear/families/intertechno.conf
02/02/17 15:32:44.052 Info: Loading family module mod_homematicwired.so
02/02/17 15:32:44.062 /etc/homegear/families/homematicwired.conf
02/02/17 15:32:44.064 Info: Loading family module mod_max.so
02/02/17 15:32:44.078 /etc/homegear/families/max.conf
02/02/17 15:32:44.079 Info: Loading family module mod_homematicbidcos.so
02/02/17 15:32:44.101 /etc/homegear/families/homematicbidcos.conf
02/02/17 15:32:44.102 Info: Loading family module mod_philipshue.so
02/02/17 15:32:44.107 /etc/homegear/families/philipshue.conf
02/02/17 15:32:44.108 Info: Loading family module mod_knx.so
02/02/17 15:32:44.114 /etc/homegear/families/knx.conf
02/02/17 15:32:44.115 Info: Loading family module mod_insteon.so
02/02/17 15:32:44.121 /etc/homegear/families/insteon.conf
02/02/17 15:32:44.122 Info: Loading family module mod_sonos.so
02/02/17 15:32:44.127 /etc/homegear/families/sonos.conf
02/02/17 15:32:44.129 Info: Loading family module mod_miscellaneous.so
02/02/17 15:32:44.132 /etc/homegear/families/miscellaneous.conf
02/02/17 15:32:44.133 Info: Loading family module mod_ipcam.so
02/02/17 15:32:44.138 /etc/homegear/families/ipcam.conf
02/02/17 15:32:44.139 Info: Loading family module mod_beckhoff.so
02/02/17 15:32:44.143 /etc/homegear/families/beckhoff.conf
02/02/17 15:32:44.144 Warning: Running as root. The authors of Homegear recommend running Homegear as user.
02/02/17 15:32:44.144 Warning: Running as root. The authors of Homegear recommend running Homegear as user.
02/02/17 15:32:44.144 Starting script engine server...
02/02/17 15:32:44.175 Initializing licensing controller...
02/02/17 15:32:44.176 Loading licensing controller data...
02/02/17 15:32:44.176 Loading devices...
02/02/17 15:32:44.176 Info: Not initializing device family HomeMatic BidCoS, because no physical interface was found.
02/02/17 15:32:44.176 Info: Disposing family module mod_homematicbidcos.so
02/02/17 15:32:44.176 Info: Not initializing device family HomeMatic Wired, because no physical interface was found.
02/02/17 15:32:44.176 Info: Disposing family module mod_homematicwired.so
02/02/17 15:32:44.176 Info: Not initializing device family Insteon, because no physical interface was found.
02/02/17 15:32:44.176 Info: Disposing family module mod_insteon.so
02/02/17 15:32:44.177 Info: Not initializing device family MAX!, because no physical interface was found.
02/02/17 15:32:44.177 Info: Disposing family module mod_max.so
02/02/17 15:32:44.177 Loading XML RPC devices...
02/02/17 15:32:44.183 Loading device 1
02/02/17 15:32:44.184 Loading XML RPC devices...
02/02/17 15:32:44.196 Loading device 2
02/02/17 15:32:44.197 Loading XML RPC devices...
02/02/17 15:32:44.199 Loading device 3
02/02/17 15:32:44.199 Loading XML RPC devices...
02/02/17 15:32:44.201 Loading device 4
02/02/17 15:32:44.201 Info: Not initializing device family Beckhoff, because no physical interface was found.
02/02/17 15:32:44.201 Info: Disposing family module mod_beckhoff.so
02/02/17 15:32:44.201 Info: Not initializing device family KNX, because no physical interface was found.
02/02/17 15:32:44.202 Info: Disposing family module mod_knx.so
02/02/17 15:32:44.202 Info: Not initializing device family EnOcean, because no physical interface was found.
02/02/17 15:32:44.202 Info: Disposing family module mod_enocean.so
02/02/17 15:32:44.202 Info: Not initializing device family Intertechno, because no physical interface was found.
02/02/17 15:32:44.202 Info: Disposing family module mod_intertechno.so
02/02/17 15:32:44.202 Loading XML RPC devices...
02/02/17 15:32:44.204 Loading device 5
02/02/17 15:32:44.205 Start listening for packets...
02/02/17 15:32:44.206 Initializing RPC client...
02/02/17 15:32:44.206 Starting XML RPC server RPCServer1 listening on 0.0.0.0:2001...
02/02/17 15:32:44.207 Module Sonos: Event server "My-Sonos-1234": Info: Started listening on address 192.168.1.239 and port 7373
02/02/17 15:32:44.208 Starting XML RPC server RPCServer2 listening on 0.0.0.0:2002, SSL enabled...
02/02/17 15:32:44.209 RPC Server (Port 2001): Info: RPC Server started listening on address 0.0.0.0 and port 2001
02/02/17 15:32:44.238 Starting XML RPC server RPCServer3 listening on 0.0.0.0:2003, SSL enabled, authentication enabled...
02/02/17 15:32:44.238 RPC Server (Port 2002): Info: RPC Server started listening on address 0.0.0.0 and port 2002
02/02/17 15:32:44.266 Starting CLI server...
02/02/17 15:32:44.267 Initializing event handler...
02/02/17 15:32:44.267 RPC Server (Port 2003): Info: RPC Server started listening on address 0.0.0.0 and port 2003
02/02/17 15:32:44.267 Loading events...
02/02/17 15:32:44.268 Starting flows server...
02/02/17 15:32:44.270 Startup complete. Waiting for physical interfaces to connect.
02/02/17 15:32:44.271 All physical interfaces are connected now.
02/02/17 15:32:44.271 Starting UPnP server...
02/02/17 15:32:44.272 Info: UPnP server: Binding to address: 192.168.1.239
02/02/17 15:32:44.272 Error: A core file exists in Homegear's working directory ("/var/lib/homegear/core"). Please send this file to the Homegear team including information about your system (Linux distribution, CPU architecture), the Homegear version, the current log files and information what might've caused the error.
02/02/17 15:32:44.272 Error: A core file exists in Homegear's working directory ("/var/lib/homegear/core"). Please send this file to the Homegear team including information about your system (Linux distribution, CPU architecture), the Homegear version, the current log files and information what might've caused the error.
02/02/17 15:32:44.272 UPnP Server: Info: Started listening.

Hi @claudioita,

is the MAX!-Module installed?
Check with dpkg -l | grep homegear and paste the output here.

Did you configure the MAX!-protocoll in /etc/homegear/families/max.conf?

Which communication device (CUL, CC1101, etc.) do you use?
You can simply adapt the configuration regarding your communication device from the homematic section of the documentation: https://doc.homegear.eu/data/homegear-homematicbidcos/configuration.html#communication-modules

so long,
p

I think that’s the problem.

I have Home Assistant on a pi3 that also has installed homegear. Somewhere I red that the dumb valve could connect with the pi3, but apparently not, since is not WiFi but RF868, correct?

My other option is to get this

this will connect to the dumb valve but not with WiFi either, correct? Do not want to buy any hub

pi@raspberrypi:~ $ dpkg -l | grep homegear
ii homegear 0.6.14-874 armhf Interface program to your smart home devices
ii homegear-beckhoff 0.6.14-874 armhf Beckhoff module for Homegear
ii homegear-enocean 0.6.14-874 armhf EnOcean module for Homegear
ii homegear-homematicbidcos 0.6.14-874 armhf HomeMatic BidCoS module for Homegear
ii homegear-homematicwired 0.6.14-874 armhf HomeMatic BidCoS module for Homegear
ii homegear-insteon 0.6.14-874 armhf HomeMatic BidCoS module for Homegear
ii homegear-intertechno 0.6.14-874 armhf Intertechno module for Homegear
ii homegear-ipcam 0.6.14-874 armhf IPCam module for Homegear
ii homegear-knx 0.6.14-874 armhf KNX module for Homegear
ii homegear-kodi 0.6.14-874 armhf Kodi module for Homegear
ii homegear-max 0.6.14-874 armhf HomeMatic BidCoS module for Homegear
ii homegear-philipshue 0.6.14-874 armhf Philips Hue module for Homegear
ii homegear-sonos 0.6.14-874 armhf HomeMatic BidCoS module for Homegear
ii libhomegear-base 0.6.14-874 armhf Base library for Homegear
pi@raspberrypi:~ $

how to do this?

I see the file, but I did not change it

which you recommend for a pi3?

That depends on you. In general the CC1101 attached directly to the SPI of the Pi3 is technically the best solution. See: https://doc.homegear.eu/data/homegear-homematicbidcos/configuration.html#config-ticc1101

The simplest way is the busware CUL: http://www.busware.de/tiki-index.php?page=CUL

Maybe this is a good starting point: http://www.ee.surrey.ac.uk/Teaching/Unix/
Basicly you edit the file on the command line (CLI) with an editor like nano or pico.

I know how to edit … I don’t know what to write in it :smile:

ohh but that’s 60 Euro … then I go for a MAX hub … no? What’s the point

A MAX Cube used is 30 EUro …

Well, the file is documented very well :wink:


It depends on the communication module you want to use to “communicate” with the thermostat.

I personally use a Max!-Cube flashed with CUL-FW which then act’s like a CUL. See https://github.com/heliflieger/a-culfw and https://github.com/heliflieger/a-culfw/tree/master/culfw/Devices/CUBe (maybe use google translate).

If you want to use the CUBe with it’s original software, which will be lost if you flash it with the a-cullfw, you can get it to work directly with your visualisation/automation.

For example there is a binding for openhab which communicates directly with the CUBe using the original software: https://github.com/openhab/openhab2-addons/tree/master/addons/binding/org.openhab.binding.max

But then you won’t need homegear for that :slight_smile:

Let me see if I understand.

I need 13 valves, I can get

  • 13 dumb valves 99017.
  • MAX Cube, to transmit/receive RF from/to the valves and connect to the LAN
  • change the MAX Cube firmware (I see original firmware is very buggy, look Amazon.de reviews)
  • connect MAX Cube to the LAN where my pi3 is

Like this with the new firmware, I can connect to homegear that is on my pi3, and then to Home Assistant and I can control all 13 thermostats.

Correct??

I use Home Assistant, which supports the homegear, but not the MAX! cube

nearly :smiley:
The CUBe flashed with a-culfw will act as a CUL and will be connected via USB to the pi where homegear is running. IIRC it is possible to use it via networtk, but I havent tried yet.

So:
Thermostat -> 868MHz -> Cube with CulFW -> USB -> homegear -> BinRPC -> home-assistant

Homegear will act as a CCU2 towards home assistant, so home-assistant will think it’s talking to a real CCU. Normally the CCU only handles homematic thermostats. So please check if the Max!-Thermostats are fully supported by home-assistant.

And please be aware of the 1%-rule: https://wiki.fhem.de/wiki/1%_Regel (use google translate again)

thanks, I could not write back, since I am new in the forum (strange limitation)

I understand now how it works (more or less :smile:)

WHich are my other option to control the valves from home assistant?

a) RF868 transceiver (cheap, but need an enclosure)
b) MAX Cube with modified firmware (good solution)
c) eQ-3 MAX! Wandthermostat+ could this also be used???
d) use the intelligent valve

d) other solutions?

means I can send signals only 36 times per hour, correct?

I’d go with the original homematic valves like HM-CC-RT-DN as these are the better supported by third party home automation software and they are “the better hardware”.

Use the CC1101 directly attached to homegear and connect homegear to home assistant as CCU2.

These are relatively cheap: http://www.ebay.de/itm/172116131449 - you only need someone who can solder some wires to it and plug it into your raspberry.

Not really. As far as I understand 36 Packets per 15min per device… but I’m not an expert on this.

This list is a little bit older, but yes, it should: https://www.homegear.eu/index.php/MAX!_Device_Support_List