CC1101 RPi SPI Adapter


#62

Moin, also wenn es noch ein Modul gibt, hätte ich auch Interesse :wink:


#63

So, es ist offiziell: Wir haben unsere WEEE-Registrierung und dürfen damit offiziell Elektronik in DE verkaufen :rocket: :tada:

Wer noch ein Modul und passenden Antennen braucht, kann es zukünftig hier bestellen: https://shop.codm.de/platinen/3/cc1101-raspberrypi-spi-modul-v0.3
Aktuell sind leider von den 18cm Antennen fast keine mehr da, ich habe aber schon neue bestellt.


#64

Kurzes Update wieder mal. Habe wieder Adapter und auch Antenne auf Lager. Wenn also jemand noch ein Modul mag, der Link zum Shop steht ja hier.

@wolutator hatte übrigens mittlerweile mal die Antennen vermessen und es sah gar nicht so schlecht aus:

Außerdem habe ich mittlerweile vom chinesischen Lieferanten die Datenblätter für die Antennen und die bestätigen @wolutator’s Messung:

18cm:

4cm:


#65

Ich habe mir mal den Spass gemacht, und das Modul aus dem ersten Beitrag nachgebaut. Im homegear.log finde ich keinen zugehörigen Fehler (“All physical interfaces are connected now.”), aber es lassen sich für MAX! keine Devices anlernen. Ich starte das im HomeMatic Manager, aber er findet keine Devices. Meine MAX! Config sieht so aus:

moduleEnabled = true

#######################################
########## TI CC1101 Module  ##########
#######################################

[TI CC1101 Module]
id = My-MAX-CC1101
default = true
deviceType = cc1100
device = /dev/spidev0.0
responseDelay = 100
interruptPin = 2
gpio1 = 25

Es kommt auch keine Fehlermeldung, wenn ich gpio1 auf 26 ändere, was aber falsch sein sollte. Fehler gibt es nur, wenn das Modul nicht angesteckt ist. Wie kann ich das am besten debuggen?


#66

Bei mir war das zu 99% ein defektes China-Modul.

Grundliegend brauchst du Debuglevel 5, dann siehst du ob der CC1101 überhaupt Nachrichten deiner Max!-Geräte empfängt. Einfach mal aufmachen und ein wenig warten oder an Gerät den Anlernmodus anschalten. Dann solltest du da was sehen.

Ich empfehle dir das Anlernen über die homegear Konsole zu machen, analog zu Homematic: https://doc.homegear.eu/data/homegear-homematicbidcos/adding_devices.html

Am besten machst du dir zwei Terminals auf, eins mit dem Log und eins mit der Konsole. Das Debuglevel kannst du auch zur Laufzeit mit dl 5 umstellen.


#67

Okay, mist, werde das mal prüfen. Mit dem Log meinst du die “homegear.log” in /var/log/homegear, oder? Da müssten dann auch Daten zu sehen sein, die das Ding empfängt?

Btw, ist das nicht merkwürdig, dass auch bei gpio1 = 26 kein Error fliegt? Das ist ja auf jeden Fall nicht korrekt.


#68

Genau.

“Jein”. Der GPIO wird nur zum Uumschalten der Senderichtung benötigt… also auch dann erst benutzt.


#69

Okay. Also ich sehe nichts auf der Konsole, was irgendwie dazu passen könnte. Bei den Errors habe ich nur:

11/03/16 17:16:51.035 Error in file PhysicalInterfaces/EventServer.cpp line 99 in function void IpCam::EventServer::setListenAddress(): No IP address could be found.
11/03/16 17:16:51.609 Module Beckhoff: Error in file Interfaces.cpp line 45 in function virtual void MyFamily::Interfaces::create(): The provided hostname is empty.
11/03/16 17:16:54.614 Warning: Unknown parameter property: label
11/03/16 17:16:54.795 Warning: variables with id "ZWaveVariables" does not exist.
11/03/16 17:16:54.822 RPC Server (Port 2001): Warning: SSL is not enabled for this RPC server. It is strongly recommended to disable all unencrypted RPC servers when the connected clien$
11/03/16 17:16:54.822 RPC Server (Port 2001): Warning: RPC server has no authorization enabled. Everybody on your local network can login into this installation. It is strongly recommen$

Hat meiner Ansicht nach alles damit nichts zutun, oder?
Wie hoch ist denn die Reichweite von diesen Dingern etwa? Eine Wand müsste gehen, oder? Direkt daneben geht’s aber auch nicht.


#70

Deinstallier bitte mal alle Module die du nicht benötigst.

dpkg -l | grep homegear
sudo apt remove homegear-beckhoff

etc…

Danach dann bitte mal homegear neu starten, debuglevel hochsetzen und das log prüfen.


#71

Hey @pmayer,

habe gerade das Modul von gestern verbaut und es arbeitet super!!! Danke dafür. Jetzt noch einige Hinweise, die ggf. helfen.

1.) Das Bild in der Beschreibung zeigt einen Raspberry Pi 2

2.) Wenn man wie ich DietPi als Distro nutzt, kann man SPI nicht so ohne weiteres einschalten. Hierzu muss man in der Datei /DietPi/config.txt ein bißchen editieren

nano /DietPi/config.txt

dtparam=spi=off auf on ändern

nach dem Speichern rebooten und mit

lsmod | grep spi

prüfen ob module geladen wurden

Ansonsten alles wie beschrieben.

Danke und Gruß
Thomas


#72

Die GPIO-Leiste ist ja gleich… oder warum hast du es erwähnt?


#73

Die Leiste ist beim Pi 1 kürzer, der CC1101 sitzt dann ganz am Ende.


#74

Ah, ja… das stimmt :slight_smile: