MAX thermostat parameters update

Hi @arkimede,

sorry for the late reply. It looks like the parameters are pushed correctly to the device. Maybe there is an error in the putParamset() that comes bofore the posted block. Could you please repost the log starting a little earlier with the putParamset().



Hi @sathya,
no problem, this issue fixed some times ago by you :slight_smile:
See other post…

If you want help, now… we have to fix another problem with setup of MAX thermostat parameters…
when you go in the admin ui, page “edit configuration parameters for thermostat…” you can see channel 0 (week program) and channel 2 (empty) but not channel 1/3 where are other useful parameters…
Moreover, will be more it would also be highly appreciated to be able to configure the coupling between a valve and a wall thermostat or a window switch through the user interface.
I asked both of these questions some time ago and someone replied (I don’t remember who) for the first problem (configuration channels) was a bug but the person who had to deal with it had no way or time; for the second, which was not implemented.
If this is so, I would like to ask you if you can tell me which project or file I should look at to try to fix the problem by myswlf; I would also really like to understand how to configure a development environment (what IDE? Compiler? etc.)
Thank you very much

Hi @arkimede,

The reason is that those parameters are variables and not configuration parameters. Variables are currently not settable in the admin UI.

I will talk to @Micha about it.




Hi there,

as mentioned somewhere before it’s not possible yet, but direct coupling is a point on my roadmap. It’s a very special Homematic-thing, so it wasn’t that hight prority so far.

@arkimede the Admin UI is based on symfony. You could have a look at Controller/Admin/Inventory/DeviceController.php and Model/Admin/HomegearDevice.php. I’m using plain VSCode, and a virtual machine with a homgear nightly installed :wink:

– Micha

I use
for the stuff which isn’t configurable by Homegear.

Thank you all for your kind answers!
I’ll see what I can do :slight_smile:
good job

HI @Larx, unfortunately my devices are MAX and not Homematic…

Hi @sathya, there are certainly configurable parameters in channels 1 and 3 - decalcification, vacancy time, night temperature, open window temperature … Things of this kind; always the person I spoke with some time ago, showed me the configuration page of the Homematic devices and these parameters, such as channels 1 and 3, were correctly displayed; I think it’s a bug on the MAX page…
– edit
this is reference to the thread

– second edit
the channel that should be viewed / edited is number 1 instead of 2 which is empty; that’s the bug …


Mine too. Doesn’t matter, Homegear exposes the devices like Homematic devices.

Hi @Larx,
let me better understand…
Do I have to configure Homematic-manager to connect to homegear? Do I have to specify the Homegear address (e.g. when it asks me for the configuration?
Thank you

For me, “Homematic Manager Address” is the IP of the device the software “Homematic Manager” is running on. “CCU address” is the hostname of the device Homegear is running on.
I have Homegear configured to have unsecured access on ports 2001 to 2003. This might be necessary, too.

Thanks @Larx,
that’s what I did, unfortunately it doesn’t work.
From the homegear log, when the link starts there is a data transmission, then everything stops :frowning:

04/12/20 15:15:46.491 Info: Client with IP ::ffff: is calling “init”.
04/12/20 15:15:46.491 Info: Adding server “”.
04/12/20 15:15:46.491 Info: Calling init methods on server “”.
04/12/20 15:15:46.996 Debug: Adding method system.multicall
04/12/20 15:15:46.996 Debug: Adding method event
04/12/20 15:15:46.996 Debug: Adding method newDevices
04/12/20 15:15:46.996 Debug: Adding method deleteDevices
04/12/20 15:15:46.996 Debug: Adding method replaceDevice
04/12/20 15:15:46.997 Debug: Adding method listDevices
04/12/20 15:15:46.997 Debug: Adding method system.listMethods

stop :frowning:

The homegear administration ui works fine and I can see the devices in both homegear and homeassistant …

I don’t know then. I access Homegear running on my Raspberry from my Laptop running Homematic Manager.
In rpcservers.conf for ports 2000 to 2003:

  • no SSL,
  • authtype none
  • interface for FamilyRPCServer ::1, all other ::
  • all server types except websocket, websocket only on port 2002

Hi @Larx,
thanks a lot for the help, there must be something wrong with my setup, i will try to find.

I found no Android Homematic app which could connect to Homegear, so there seems to be a difference between Homematic and Homegear for the clients trying to connect.
However, Homematic Manager (I run it using Ubuntu) flawlessly connects and makes my Max!-Devices configurable - however not very intuitive.
Unfortunately I played around so often with my setup that I can no longer reproduce any step. As far as I remember, it was not very difficult to connect Homematic Manager to Homegear. It was something like removing some access restrictions in Homegear, and voila…

Unfortunately, the admin UI of Homegear is not really usable. I need it to set thermostat programs, but for most other aspects (e.g. temperature correction, pairing/connecting devices) I mostly use Homematic Manager.

Hi @Larx,
I use a Raspberry as a homegear and homeassistant server; they work well and communicate well with each other after the latest homegear changes.
I tried to install Homematic-manager on a computer with Windows; as you could see from the log, a communication with homegear begins, then everything stops. I checked the windows firewall and it looks fine. I would like to ask you if it is possible to send me your homegear configuration files (of course you can obfuscate ip addresses or other sensitive data) so that I can compare with mine; eventually I will try to run homematic-manager on a computer with linux.
Thank you

I sent you my config files. No secrets here, should be mostly the defaults (and is only accessibly from within my net).

Thank you!

Hi @Larx,
for completeness…
I tried to install homematic-manager on a Linux virtual machine and it works perfectly without making any changes to the Homegear configuration; obviously there is a problem with windows … Too bad there is no english version …
I will translate the commands …
Thanks again for kindly cooperation!

Unfortunately, the program is not very intuitive. It closely mimics the Homematic internals, which are a bit confusing. Also, at least for me the “human readable” device names are not synced between Homegear and Homematic Manager, which adds another level of complexity, as you have either to deal with the cryptic device ids or enter the names in both softwares. Homematic Manager moreover seems to allow the change names not only per-device, but also per-channel.

On the first tab (“Geräte”) you have to expand the device lines and right click on the resulting lines (=channels) and then guess if the parameter you want to change is part of “MASTER” or “VALUES” paramset (and in which channel of your device you find it at all…).

The second tab (“Verknüpfungen”) is used to link channels of devices (usually a TRANSCEIVER channel to a RECEIVER channel). Not every RECEIVER can be linked to every TRANSCEIVER, but the program will only show allowed connections. Usually this is relatively straightforward, I had troubles with a wall-mounted thermostat until I found out that here the window open notification uses an other channel than the normal thermostats.

Tell me if you need help.

1 Like