MAX! devices an homgear gateway

#1

Servus,
ich versuche, MAX! devices mit einem Homegear-gatewayund USB CUL am
Rapberry zu betreiben.
CUL und homegear-gatewaylaufen auch,
homgear hat das gateway als homematicbidcos auch gefunden.
Die MAX! devices sind z.Zt. noch über einen CUN mit homematic verbunden.

Wie müssen die Konfigurationen für homemeatic und homematic-gateway aussehen?

Danke und Gruß
Connie

#2

Hey @clh27,

ich glaube das Gateway kann noch kein Max!
Habe @sathya aber gebeten dazu mal was zu sagen.

Gruß,
p

#3

Doch kann es. :wink:
Zumindest hat @sathya das letztens gepostet, dass es jetzt im nightly implementiert ist. Aber wohl noch ungetestet.

Leider hat @Flole sich nicht mehr gemeldet, er ist wohl noch nicht zum testen gekommen.

1 Like
#4

Da du das Gateway schon am laufen hast, fehlt wohl nur noch die Konfiguration von Max!.

Du musst deine Hardwarekonfiguration irgendwie in die gateway.conf einarbeiten:

Hier ist die Konfig für Max! (von GitHub)

#{{{ MAX COC/SCC example config

## The device family the gateway is for.
## Options:
#family = MaxCulfw

## The device to use
#device = /dev/ttyACM0

#gpio1 = 17
#gpio2 = 18

#}}}

#{{{ MAX TICC1101 example config

## The device family the gateway is for.
#family = HomeMaticCc1101

## The device to use
#device = /dev/spidev0.0

## The interrupt pin to use. "0" for GDO0 or "2" for GDO2.
## You only need to connect one of them. Specify the GPIO
## you connected the interrupt pin to below.
#interruptPin = 2

## The GPIO GDO0 or GDO2 is connected to. Specify which GDO to use above.
#gpio1 = 24

#}}}
#5

@clh27, welche Version hast du laufen?

#6

Hi, danke an alle.
@job: das ist die verwendete Konfiguration auf dem Gateway (RPi-3)

@pmayer: gateway version ist 0.7.39-2768, homegear (im container auf einer DS415+) ist 0.7.37-2722

Die Idee dahinter ist, den RPi als gateway zur Vermeidung der
Latenzzeiten zu verwenden. Von der DS zum CUNX (Cube mit aculfw firmware)
is die Latenz zu hoch für MAX!, sie liegt zwischen 50ms und 204ms

#7

Das kann dann nicht funktionieren, da alles auskommentiert ist . :wink:

Ich habe die Konfiguration aus dem github dev branch rausgenommen (=> nightly). Im github master branch (=> stable) gibt es kein Max!.

Achtung, das ist mein gefährliches Halbwissen, so habe ich mir das zusammengereimt. Das muss aber nicht die exakte Zuordnung von branch <=> release sein.

#8

Das ist korrekt, MAX! ist (bislang) nur im nightly (dev-branch) …

– Micha

#9

OK, vielen Dank.
das werde ich testen.

#10

Danke, ich habe jetzt das gateway aus dem nightly auf dem RPi installiert,
dort auch die Konfiguration für MAX! angepasst.
Gateway startet, läuft und wird auch von homegear gefunden.

Allerdings bietet homegear keine MAX! devices via gateway an,
brauche ich da auch die nightly- Version?

Danke und Gruß
Connie

#11

Gehe ich von aus.

#12

OK, danke. habe ich getan.
Allerdings sehe ich keine Option, ein MAX! device an dem homegear gateway hinzuzufügen,
nur homematicbidcos.
enabled sind MAX! und homematicbidcos, für MAX! existiert
ausserdem auch noch der erwähnte CUNX den ich aber ablösen möchte.

Sorry, aber ich stehe ich gerade voll auf dem Schlauch.

Ziel der Aktion soll es sein, mehrere gaetways im Haus auf den einzelnen Etagen zu haben
und darüber die MAX! devices anzubinden.

#13

Genau dafür ist das Gateway gedacht :slight_smile:
Hast du mal auf Github in den aktuellen Config-Dateien geschaut? Du hast ja die “alten” und in den neuen ist diese Option ja eventuell dazu gekommen.

#14

leider keine neuen Optionen bei MAX!

#15

Dann kann nur @sathya helfen… oder hast du noch eine Idee @job?
Das Feature ist halt knackfrisch…

#16

Hallo @clh27,

das war auch noch nicht in der max.conf. Kannst du dir hier abschreiben:

Die Einrichtung des Gateways ist die gleiche wie bei HomeMatic BidCoS oder EnOcean, du kannst also die Doku dieser Familien nehmen. Mit der Admin-UI sollte die Einrichtung ebenfalls ab dem nächsten Nightly funktionieren.

Viele Grüße

Sathya

1 Like
#17

OK, vielen Dank!

Ich werde auch auf die Admin-UI warten und am Wochenende weitermachen.

#18

hallo @sathya,
mit der nightly 0.8.0-2573 kann ich zwar das gateway for max! jetzt in der admin-gui finden,
einbinden sagt auch 1 gateway gefunden, aber es taucht leider nicht in der Liste der
gateways auf, auch ein löschen klappt dann nicht mehr.

#19

Hey @clh27,

was sagt denn

homegear -e rc ‘print_v($hg->listInterfaces());’

in der Console? Taucht das Gateway dort auf?

– Micha

#20

Hallo @Micha,
nein, es wird nicht aufgeli, auch dannnicht,
wenn ich es manuell via GUI hinzufüge.
Es kommt zwar die Meldung, dass 1 gateway hinzugefügt wurde,
aber das ist dann auch alles.