Link zwischen Max! Thermostat und Fensterkontakt via Homematic Konfigurator

Hi,

ich habe seit einem Jahr erfolgreich ein paar HomeMatic Heizkörperthermostate im Einsatz, läuft alles wunderbar.
Nun habe ich mir einen Fensterkontakt gekauft und habe auch diesen in Homegear angelernt.

Ich habe gelesen das man die via HomeMatic Konfigurator dann verknüpfen kann, somit spare ich mir extra Logik in meinen NodeRed Flows.
Leider scheint das aber nicht zu funktionieren, wenn ich im Konfigurator auf “Direkte Verknüpfung” klicke und dann auf “neue Verknüpfung” bekomme ich nur folgende Meldung:

Es sind keine verknüpfbaren Kanäle vorhanden.

Woran könnte das liegen? Mein Homegear habe ich eben mal geupdated auf die aktuelle Version.

Gruß
Tobias

edit: Habs auch grade mal via CLI probiert, da gehts auch nicht:

homegear -e rc '$hg->addLink(3,1,2,1)'
3= ID des Kontakts
1= Channel des Kontakts
2= Heizungsthermostat
1= Channel des Heizungsthermostats

homegear -e rc '$hg->addLink(3,1,2,1)'
PHP Fatal error:  Uncaught Homegear\HomegearException: Link not supported. in /var/lib/homegear/scripts/inline.php:7
Stack trace:
#0 /var/lib/homegear/scripts/inline.php(7): Homegear\Homegear->__call('addLink', Array)
#1 {main}
  thrown in /var/lib/homegear/scripts/inline.php on line 7root@raspberrypi:/home/pi#

Sers,

das sollte ansich ohne Problem funktionieren. Welche Version von Homegear setzt du ein?

Und: Im Topic schreibst du Max! Thermostat, im Post aber Homemeatic. Kannst du mal die genauen Typen von Thermostat und Fensterkontakt posten?

Gruß,
p

Upsi, nein sind Max! Thermostate. Zu viel über Homematic gelesen :wink:
Habs nun über die CLI hinbekommen, der Channel des Thermostats war falsch angegeben.
Es muss Channel 4 sein.

Der Kontakt ist ein:
BC-SC-Rd-WM-2

Der Thermostat:
BC-RT-TRX-CyN

Nach dem ich den Link via CLI nun erfolgreich hinzufügen konnte, wird der Link auch im Homemmatic Konfigurator korrekt angezeigt.

2 Likes

Hallo zusammen,

kann man die Links nun auch direkt mit dem Homematic Konfigurator erzeugen, oder geht das nicht für MAX! Geräte?
Habe aktuell das selbe Problem, dass “Es sind keine verknüpfbaren Kanäle vorhanden.” angezeigt wird.

Habe mir extra eine VM mit Windows 10 aufgesetzt, da es das Programm ja leider nur für Windows gibt… :wink:

Danke & Gruß
Alexander

Hey @Alexander060101,

es ist ja auch der Homematic-Konfigurator :wink: Mit Max! kann man natürlich genauso die Kanäle unterhalb von dazu fähigen Geräten verknüpfen.

Warum versuchst du es nicht über die CLI? Braucht auch keine VM.
Das Admin-UI kann das glaube noch nicht, oder @Micha?

Hier auch ein alter Post der das Thema behandelt:

1 Like

Danke @pmayer.

Da hast du natürlich Recht…
Dachte aber, es würde gehen, da ich das schon mehrfach gelesen hatte.

Werde es dann am Wochenende via CLI machen/versuchen.
Habe unter der Woche leider keinen Zugriff, da außer Haus.
Muss mich dringend um DynDNS/VPN kümmern! :sweat_smile:

Link-Parameter o.Ä. muss ich ja beim “einfachen” Link Fenstersensor zu Thermostat keine setzen, oder?
Ein addLink() sollte reichen?

AdminUI hat meine Version noch gar nicht, glaube ich.
Ich habe die 0.7 Stable und das gibts erst seit 0.8 Beta/Nightly oder so ähnlich, habe ich im Hinterkopf?
Wäre aber natürlich ein wünschenswertes Feature, sobald es die 0.8 mal ins Stable schafft! :slight_smile:

Danke soweit, ich melde mich dann am Wochenende nochmal.

PS: Hätte das Thema gerne schon am Sonntag angestoßen, aber der Link zum Account-Bestätigen nach der Registrierung hat tatsächlich fast 24h auf sich warten lassen. :open_mouth:

Gruß
Alexander

1 Like

Hallo nochmal,

wie erwartet, hat es über die CLI problemlos funktioniert. :slight_smile:
Kanal 1 des Fensterkontakts mit Kanal 4 des Heizkörper-Thermostats verbunden und schon dreht die Heizung ab, wenn das Fenster geöffnet wird.
Top.

Bin mit sudo homegear -r quasi in die Homegear-Konsole gewechselt und habe dann z.B. mit rc '$hg->addLink(2, 1, 1, 4)' meine Geräte verlinkt.

Die Direktverbindungen werden nun auch im Homematic Konfigurator angezeigt.
Also zumindest zur Kontrolle, ob ich nicht aus Versehen Küche mit Schlafzimmer verbunden habe, ist er nützlich. :wink:

Gruß
Alexander

1 Like

Huhu,

Direktverknuepfungen sind mit der Admin-UI (noch?) nicht moeglich. Ich habe das auf meinem Zettel, allerdings ist das sehr Familienspezifisch …

– Micha

2 Likes