LED1733G7 verbindet sich nicht mit CC2652

Ich habe mir den CC2652 (ZigBee CC2652P2 Raspberry Pi Module | ZigBee | Automation | cod.m GmbH Shop) geholt und lasse das ganze auf einem Pi laufen.
Soweit funktioniert auch alles und ich konnte mehrere Geräte anlernen.
Allerdings kann ich die LED1733G7 von IKEA nicht verbinden und ich weiß nicht wieso.
Trotz richtiem reset und >20 Versuchen, will es einfach nicht klappen.

Jemand eine Idee was ich falsch machen könnte oder wie ich überprüfen kann, ob es sich um einen Bug handelt?

Vielen Dank!

1 Like

Could you please obtain a log (preferably with a big level set for debug, like 7) for the pairing process and attach it here?

I tested several IKEA devices and they work…

One thing you could also try (if you didn’t already) is to reset the device to factory settings before trying to pair it. Check the manual on how to do it… typically for a lightbulb is to turn in on and off several times (as in 5 times or something like that), quite fast.

Thank you for your reply.

I also have several Ikea Devices and all the others pair without problems.
Just those LEDs seem to make problems.
I tried reseting, and it also did not help.

I attached the log.
I hope it will help solving this problem!

homegear.log (586,0 KB)

1 Like

The log contains some good info, thank you!

Apparently the pairing process is stopped after receiving this:

I’ll see if I can find out why it’s stopping.

I’ll look into it probably tomorrow, today I still need to do some other stuff.

By the way, what was the debug level set?

If I recall correctly, with a higher level the log should also show the packets sent for interrogations and I think I didn’t see such details in the log.

More details could help more in diagnosing it.

I set the level to 7.
But I could also increase it, you just have to tell me the level :slight_smile:.
Thank you for your help, I would be lost without you!

Here is a pairing try with log level 9:
homegear.log (577,7 KB)

1 Like

The logs show that interrogation stops just before interrogating a manufacturer specific cluster (which should not be interrogated, anyway, because some devices do not reply to such interrogations).

After that point the peers should be created, for some reason they aren’t. I’m still investigating.

If I won’t succeed to find the cause today, I already changed the code to log some more info around the place where it happens, so in the worse case scenario we’ll get more info on why and how it happens.

Thats awesome!
Just let me know how I can help :slight_smile: !


It looks like that issue was fixed for quite a while but for some reason it didn’t get it into the release version, it’s in the development source tree only.

Could you please install the nightly binaries and try again the pairing process?


well I tried to install the nightly version.
Everything seemed fine during the installation, but I can not go to the admin page anymore.
It seemes like the server is crashing and restarting after i try to login?
I get the “Page not found” error from Firefox (not the 404 page from homegear)

I attached to log with grep “RPC”.
Maybe I am just making a very stupid mistake I dont see yet.

homegear.log (24,8 KB)

I’ll try to see if the fixes can be propagated in the release.

There are other fixes in there besides for your issue (RSSI display, for example, if I recall correctly, also for some peculiarities of some particular ‘stick’ devices and so on).

Are there any news?