Installation auf Ubuntu 20.04 Focal Fossa schlägt fehl

Hallo,

ich bekomme folgenden Fehler am Ende der Installation:

Installing Homegear licensing module… x
xqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqx
x Selecting previously unselected package homegear-licensing. x
x (Reading database … 47414 files and directories currently installed.) x
x Preparing to unpack homegear-licensing_current_ubuntu_focal_armhf.deb … x
x Unpacking homegear-licensing (0.8.0-3064) … x
x dpkg: dependency problems prevent configuration of homegear-licensing: x
x homegear-licensing depends on libhomegear-base (= 0.8.0-3064); however: x
x Version of libhomegear-base on system is 0.8.0-3071. x
x homegear-licensing depends on homegear (= 0.8.0-3064); however: x
x Version of homegear on system is 0.8.0-3071. x
x x
x dpkg: error processing package homegear-licensing (–install): x
x dependency problems - leaving unconfigured x
x Errors were encountered while processing: x
x homegear-licensing x
x x
x

Gibt es da eine Lösung?

Viele Grüße

Elmar

paging @sathya :slight_smile:

@fishermans: Pack aber bitte noch mal ein paar Infos über die Zielplattform rein. x86, ARM?

Oh das ist ein Odroid C1 mit ARM Prozessor

Hmm… hier grab es ein ähnliches Problem, allerdings bei amd64.
Da muss @sathya glaub ich gucken.

Danke für den Hinweis. Mit der nächsten Autobuildrunde sollte es wieder passen.

Viele Grüße

Sathya

1 Like

@sathya Hätte es schon funktionieren müssen?
Der Fehler ist immer noch da :blush:

Mit “Autobuild” meint Sathya das automatische Kompilieren der aktuellen Version für die verschiedenen Plattformen:

https://homegear.eu/downloads.html?version=0.8

Distrubution Architecture Version Build Time
Ubuntu Focal Fossa armhf 0.8.0-3078 August 26, 2020 21:26:55
Ubuntu Focal Fossa arm64 0.8.0-3071 August 25, 2020 03:04:39

armhf und arm64 wurden zuletzt am 25.8./26.8. “gebaut”. Schau einfach unter dem Link nach, wann die Buildserver das nächste Mal vorbei kommen. Sollte in den nächsten Tagen soweit sein.
Die Info dort gilt für die nightly.

Ah so vielen Dank für die Info

Irgendetwas stimmt da auch nicht, vermutlich durch Änderungen an der UI. Wir schauen uns das gerade an.

@sathya - zeichnet sich denn eine Lösung ab? Oder besser wieder auf einen Raspberry zurück?

arm64 scheint wieder zu funktionieren. armhf kompiliert hoffentlich funktionierend gerade und ist fast fertig. Ich schaue morgen mal rein.

1 Like

Das hört sich gut an, vielen Dank!

Es gab noch ein Problem, jetzt funktioniert das Kompilieren aber wieder, wie es soll.

1 Like

Sollte der Fehler jetzt weg sein? Ich bekomme immer noch die gleiche Fehlermeldung.
Oder müssen die Buildserver erst noch vorbeikommen?

Die Buildserver kamen vorbei, jetzt funktioniert alles wieder :grinning:

2 Likes

Hallo,

Ich probiere auch gerade Homegear auf meinen Intel NUC mit Ubuntu 20.04 Focal zu installieren, leider komme ich nicht weiter, kann wer helfen? :confused:

homegear-nodes-core : Depends: python3-homegear but it is not going to be installed

# apt install homegear homegear-nodes-core homegear-management homegear-adminui homegear-ui
Reading package lists... Done
Building dependency tree       
Reading state information... Done
homegear is already the newest version (0.8.0-3064).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 homegear-nodes-core : Depends: python3-homegear but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I could fix the issue myself, I just downloaded an older nightly from https://downloads.homegear.eu/nightlies/

wget https://downloads.homegear.eu/nightlies/python3-homegear_20201103_ubuntu_focal_amd64.deb
dpkg -i python3-homegear_20201103_ubuntu_focal_amd64.deb

and again

apt install homegear homegear-nodes-core homegear-management homegear-adminui homegear-ui