Homematic-Geräte gesperrt trotz vorherigem "reset" und "remove" - Wie können die Geräte wieder genutzt werden?

Hallo,

ich wollte mein Smart Home neu aufsetzen und nutze Homegear für die Anbindung der Homematic-Geräte. Ich habe extra alle meine Geräte in Homegear zunächst mit reset auf Werkseinstellungen zurückgesetzt und dann per remove entfernt, da ich gelesen hatte, dass dies der saubere Weg ist und es sonst Probleme bei einem neuen Anlernen kann.

Allerdings kann ich jetzt keines meiner bisherigen Geräte mehr anlernen - dies klappt weder für meine immer noch aufgesetzte Homegear-Installation (pairing on und Gerät in Anlernmodus bringen führt zu keinem Effekt), noch an einer CCU, noch in einem aufgespielten Backup von openHAB+Homegear, das ich vor dem Ablernen angelegt hatte.

Hat jemand einen Tipp, was ich noch tun kann? Aktuell sind alle meine Geräte unbrauchbar.

Ich habe auch eigentlich alles noch zur Verfügung, was man für eine Reaktivierung der Geräte brauchen sollte:

  • die Homegear-Installation, an der ich die Geräte abgelernt habe
  • das Homegear-Backup zum Zeitpunkt vor dem Ablernen
  • den rfkey für die Verschlüsselung

Wenn ich auf dem gleichen RaspberryPi statt der homegear-Installation ein piVCCU-Image (auf einer anderen SD-Karte) einspiele, kann ich andere Geräte koppeln (z.B. ein Homematic IP-Gerät) - das zeigt für mich also an, dass auch mein HM-Funkmodul und mein Pi korrekt funktionieren - meine klassischen Homematic-bidCos-Geräte sind jedoch nicht anlernbar.

Ich bin für jeden Tipp dankbar, da meine Geräte aktuell unbrauchbar sind, obwohl ich extra versucht hatte, ein “sauberes” Ablernen inkl. Reset vorher vorzunehmen.

Vielen Dank für eure Hilfe!

Hi Ted,

hast du schon mal probiert an den Geräten selbst nochmal einen Werksreset zu machen? Ich hatte schon einige HomeMatic BidCos-Geräte die sich erst nach einem manuellen Werksreset wieder haben anlernen lassen.

Gruß Andreas

1 Like

Hi Andreas,

vielen Dank für den Tipp! Das hat tatsächlich bei fast allen HM-Gerätetypen, die ich habe geholfen!

Die letzte Ausnahme bilden meine HM-Wandtaster vom Typ HM-PB-2-WM55 bzw. HM-PB-2-WM55. Diese sind weiterhin gesperrt und ich bekomme sie weder an der alten Homegear-Installation (an der sie vorher funktionierten) noch an einer neuen Zentrale angelernt.

  • Wenn ich die Taster manuell in den Werkszustand zurücksetzen möchte, bekomme ich nach 5-sekündigem Drücken der Anlerntaste ein dauerhaftes rotes LED-Leuchten. Laut Bedienungsanleitung kann das Gerät bei diesem Fehlercode nicht zurückgesetzt werden, da “die Verschlüsselung mit einem vom Auslieferungsschlüssel verschiedenen System-Sicherheitsschlüssel aktiv” ist.
  • Ich hatte die Taster wie oben beschrieben per reset und remove in Homegear abgelernt. Jetzt kann ich die Taster aber auch mit der alten Homegear-Installation und auch einer Backup-Instanz, in denen jeweils der richtige rfkey hinterlegt ist, nicht mehr pairen o.ä., obwohl der Taster in der Vergangenheit mit diesen Installationen funktioniert hatte.

Habt ihr hier noch einen Tipp? Eigentlich müssten doch die Geräte, wenn sie verschlüsselt mit einer Homegear-Installation gekoppelt waren und scheinbar nicht vollständig in Werksreset versetzt wurden, wieder mit der gleichen Homegear-Installation, in der weiterhin der gleiche Schlüssel für die Verschlüsselung hinterlegt ist, wieder zu pairen sein, sodass ich sie dann nochmal sauber ablernen/resetten könnte?

Danke und beste Grüße,
Ted

Hallo Ted,

sorry für die späte Antwort.

Wenn die Taster noch gegen Werksreset geschützt sind, sind sie in der Tat nicht richtig abgelernt worden.

Ich würde sagen, dann bleibt dir nur noch zu versuchen die Taster manuell wieder über “peers add” bzw. “pa” zu Homegear hinzuzufügen. Anlernen geht ja leider nicht, weil der Aktor denkt er sei noch angelernt.

Aber da brauchst du einige Informationen wie Devicetype (der HM-PB-2-WM55 sollte eigentlich die 006B sein, zumindest ist er das bei mir), Address, Serialnumber und Firmwareversion. Die Seriennummer steht ja auf jedem Gehäuse, aber bei der (Funk-)Adresse und der Firmware-Version wird es schon schwerer. Die kannst du evtl. versuchen mit Homegear zu sniffen, wenn du den Taster drückst und die im Homegear-Log die empfangenen Funk-Pakete anschaust. Zumindest die Adresse bekommst du so raus, bei der Firmware-Version bin ich mir da nicht so ganz sicher. Evtl. musst du das Log-Level von Homegear anpassen um die Funkpakete im Log zu sehen.

Wie du die Funkpakete deuten kannst findest du z.B. unter https://www2.htw-dresden.de/~wiki_sn/index.php/HomeMatic im Kapitel “Protokoll”. Von Satya/Homegear gab es da auch mal irgendwo eine Doku, die finde ich aber gerade nicht.

Bei Anlernen solltest du immer nach dem Reset checken, ob das Device wirklich in den Werkszustand versetzt wurde, bevor du es mit Remove entfernst. Das Remove löscht die Geräte faktisch nur aus der Datenbank von Homegear. Das kannst du auch ganz zum Schluss machen. Ab einem erfolgreichen Reset ist das Gerät wieder “frei”.

Gruß Andreas

1 Like