Homegear Hilfe bei der Installation

hallo Leute, ich komme nicht weiter bei der Instillation von homegear
ich habe die Installations Anweisung durch geführt

https://doc.homegear.eu/homegear/configuration.html

habe aber das Problem das ich den Ordner nicht finde /etc/homegear
es kommt da nur

~# /etc/homegear
-bash: /etc/homegear: Is a directory

ubuntu server pi4 4gb

kann mir da jemand helfen

cd - change directory
Deine Meldung sagt, dass es sich um ein Verzeichnis handelt und nicht um einen Befehl.

vielen lieben dank ^^

1 Like

jetzt habe ich das nässte Problem, ich will ein cul einstellen, bei der seite unter Homegear konfigurieren

soll ich in die Einstellungen gehen vim /etc/homegear/families/homematicbidcos.conf
da kommen aber nur `
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
~
“/etc/homegear/families/homematicbidcos.conf” [New File] 0,0-1 All

kann mir da auch jemand helfen oder ein einfacheren weg ?

Hast du denn auch das Modul für homematicbidcos installiert?

sudo apt install homegear-homematicbidcos

Mit dpkg -l | grep homegear siehst du alle installierten Pakete, die ‚homegear‘ enthalten.

Benutze auf einem Pi am besten nano vom macht da manchmal blöde Sachen, zum Beispiel bei den Pfeiltasten.

jetzt habe ich es installiert danke, jetzt kommt das solte ich da was ändern ? oder solte jetzt alles gehen

___________________________________________________________________________

---------------------------- HomeMatic BidCoS  ----------------------------
___________________________________________________________________________

#######################################
########## General Settings  ##########
#######################################

[General]

moduleEnabled = true

## The BidCoS address of Homegear. It is recommended to change this to a random 3 byte hexadecimal
## value starting with 0xFD (e. g. 0xFD43AB). Only change this, when no HomeMatic BidCoS devices
## are paired to Homegear as existing pairings will not work anymore!
#centralAddress = 0xFD0001

## Specify a 16 byte (32 characters) long AES key here to protect your wireless communication
## It must only consist of the characters A to F and the numbers 0 to 9 as it is hexadecimal.
## !!! IMPORTANT: It is highly recommended to change this key before pairing the first device.
## !!! IMPORTANT: Never ever lose this key. That would render your devices useless.
## To remove the key from your devices, you need to factory reset them using Homegear. The factory
## reset on the device is not possible!!!
rfKey = 00112233445566778899AABBCCDDEEFF

## With each key change currentRFKeyIndex needs to be
## incremented by 1
currentRfKeyIndex = 1

## When you change rfKey, put the old key here. To change the key Homegear needs to know the
## old and the new one.
## !!! Do not set oldRFKey when you set rfKey for the first time !!!
##oldRfKey = 00112233445566778899AABBCCDDEEFF

habe ätwas angst was falch zu machen ich frage lieber ^^

Ok… bitte benutz die Formatierungsfunktionen des Forums:
grafik

Du kannst deinen Beitrag nachträglich bearbeiten.


Ließ außerdem den Starter-Guide. Dort findest du nen Haufen Informationen für den Anfang:


Grundliegend musst du deinen CUL passend konfigurieren, damit Homegear ihn zur Kommunikation mit Homematic-Geräten nutzen kann.
https://doc.homegear.eu/homegear-homematicbidcos/configuration.html#cul

Wichtige Unterscheidung: Homematic (BidCOS) ist nicht mit HomematicIP kompatibel.

die Formatierungsfunktionen habe ich eig gemacht

ich will die homematic hm-cc-rt-dn einbinden auch wenn der ccu2 nur 1 watt zieht will ich alles im einen machen habe dann nicht so viel rumstehen

ich bin jetzt bei der liste wie kann ich Änderungen speichern ?

Schau mal oben… so sieht es richtig formatiert aus.

Was meinst du mit Liste?

wie mache ich weiter oder kann ich es jetzt nutzen mit den homegear
die HomeMatic-Komponenten konfigurieren habe ich schon auf mein pc installiert und die HomeMatic WebUI

Servicemeldungen ist bei 0 und die anzeige ist grün

Sorry. Ich kann dir nicht folgen. Hast du die config entsprechend angepasst? CUL funktioniert? Das Thermostat angelernt? etc.

Was willst du denn erreichen? Wenn du die Geräte in Homegear hast gibt es unzählige wege… entsprechend eben deines Anwendungsfalls.

ich habe noch nix eingestellt, da sie Erfahrung damit haben nehme ich die Einstellungen die sie mir geben gerne an
ich will es mit iobroker auf einen pi 4 4gb laufen lassen, ich gebe gerne mehr infos wenn sie welche brauchen

Öhm, moment. Das ist hier kein kostenloser Einrichtservice :wink: Mein Setup hat zum Beispiel keinen CUL und ich habe aktuell noch nicht mal Homematic-Komponenten laufen.
Kann also nur mit Rat zur Seite stehen bei dem was du konfigurierst.

Hast du denn schon die verlinkte Doku gelesen?

Der erste Schritt ist, den CUL, wie oben verlinkt, in der Homegear-Config einzutragen. Danach den Anweisungen zum Anlernen von Geräte folgen. Danach verhällt sich Homegear gegenüber ioBroker wie eine CCU und kann auf die gleiche Weise angesprochen werden.

habe schon einiges gelesen, ich komme aber meist an Problemen die die anderen nicht haben, ich hatte es schon mal ausprobiert es zu installieren, nach 2 wochen und 7 Leuten hatte keiner mehr lust drauf
und haben mir gesagt ich soll eine ccu2 hollen, wass ich auch getan habe aber jetzt greift der ehrgeiz wieder und versuche es erneut, da es von homegear kein videos gipt, gestaltet sich das recht schwer bei mir und ich kann kein englisch was es richtig doff macht und meine Kenntnis von linux generell ist sehr begrenzt, iobroker war da recht einfach zu installieren aber homegear macht es nicht einfach ^^

bei Sachen wo ich keine Ahnung habe frage ich lieber nach befor nix mehr geht auf den pi4 wo homegear installiert ist lauft auch mein iobroker der schon knap 1 jahr läuft

  • sudo nano /etc/homegear/families/homematicbidcos.conf, Datei anpassen, STRG-X und den Dialog mit y bestätigen
  • homegear neu starten: sudo service homegear restart
  • sudo homegear -r um in die Homegear-Konsole zu gelangen
    • fs 0 HomematicBidcos-Familie auswählen
    • pon um das “Pairing” einzuschalten, dann Anlerntaste am Thermostat drücken
    • ls um eine Liste der Geräte anzuzeigen und nachschauen ob das Thermostat auftaucht

Das Thermostat muss vorher ordentlich von der CCU abgelernt werden, eventuell am Thermostat einen Werksreset machen.
Genaugenommen dann noch ioBroker konfigurieren, wie als wenn man eine CCU hätte.

ich danke dir sehr für deine hilfe

habe versucht das erste gerät zu verbinden aber es passiert nix woran kann das liegen ?

“passier nix” ist immer eine schlechte Fehlerbeschreibung.

  1. Was genau hast du gemacht?
  2. Was steht im Log (/var/log/homegear/homegear.log) beim Anlernversuch?
  3. Hast du im Forum schon mal gesucht?