Could not connect to socket

Hello I am using openhabian latest version on Raspberry Pi 3.

I have installed homegear according to official homegear website for Raspbian Jessie.

I have done all the configurations accordingly.

openhabian@openHABianPi:/ $ sudo dpkg -l | grep homegear
ii homegear 0.7.10-1397 armhf Interface program to your smart home devices
ii homegear-homematicbidcos 0.7.10-1397 armhf HomeMatic BidCoS module for Homegear
ii libhomegear-base 0.7.10-1397 armhf Base library for Homegear
ii libhomegear-node 0.1.5-16 armhf Node library for Homegear

When I run sudo homegear -r, it could not connect to the socket. I have tried reinstalling, rebooting etc., nothing is working.

I have attached the log. Kindly help.

homegear log.txt (4.9 KB)

Hi @sudarshangb,

welcome to the forum. Please use the formating options, that it provides:

Coul you make sure, that homegear is running? The error normaly only comes up, if the homegear console could not connect to the servive of homegear itself. Thus the error message…

What’s the output of sudo service homegear status?

so long,

Hello @pmayer,

Thank you.

I reinstalled homegear by removing everything (purge). Now it is working fine.


1 Like