Anlernen mit pon nicht erfolgreich - Im log wird wird jedoch ein Signal empfangen

#1

Hallo zusammen,

mein Setup:

  • Raspberry pi 3
  • OpenHab2 und
  • Homegear (jeweils in der aktuellen Version)
  • HM-MOD-RPI-PCB von ELV

Mein Problem:
Ich habe homegear installiert, die Config angepasst und versuche nun mit homegear -r, fs 0 und pon meine Fensterkontakte zu koppeln. Leider klappt dies nicht und ich finde im Log keine Informationen über einen Fehler. Dort sehe ich aber, dass mein Fensterkontakt Daten sendet und mein Modul diese empfängt.

mit ls sehe ich keine Geräte.

Lösungsversuche

  • reboot,

  • service neu starten

  • Fensterkontakt in Werkseinstellung
    Hat leider alles nicht geholfen. Habt ihr eine Idee, woran es liegen könnte? Sind Homematic Fensterkontakte in der family 0 richtig?

    `#######################################
    ########### HM-MOD-RPI-PCB ###########
    #######################################

The device family this interface is for

[HomeMatic Wireless Module for Raspberry Pi]

Specify an unique id here to identify this device in Homegear

id = My-HM-MOD-RPI-PCB

When default is set to “true” Homegear will assign this device

to new peers.

default = true

Options: cul, cc1100, coc, cunx, hmcfglan, hmlgw, hm-mod-rpi-pcb, homegeargateway

deviceType = hm-mod-rpi-pcb

device = /dev/ttyAMA0

Default: responseDelay = 95

Should be “95” for CUL or COC, “100” for TI CC1101 and “60” for HM-CFG-LAN or HM-LGW

responseDelay = 95

Default: gpio1 = 0

“18” for HM-MOD-RPI-PCB

gpio1 = 18`

Das log sieht wie folgt aus:

04/28/19 18:42:01.355 RPC Server (Port 2001): Info: Client number 109 is calling RPC method: listBidcosInterfaces (2) Parameters:

04/28/19 18:42:16.360 RPC Server (Port 2001): Info: Client number 109 is calling RPC method: ping (2) Parameters:

(String) eb5128e4

04/28/19 18:42:16.364 RPC Server (Port 2001): Info: Client number 109 is calling RPC method: listBidcosInterfaces (2) Parameters:

04/28/19 18:42:20.154 IPC Server: Info: Connection accepted. Client number: 169

04/28/19 18:42:20.156 IPC Server: Info: Client 1 successfully registered RPC method “cliOutput” (this method is registered by 1 client(s)).

04/28/19 18:42:20.157 IPC Server: Info: Client 1 successfully registered RPC method “cliOutput-1” (this method is registered by 1 client(s)).

04/28/19 18:42:24.867 IPC Server: Info: Client number 1 is calling RPC method: familyExists Parameters:

(Integer64) 0

04/28/19 18:42:29.685 HomeMatic BidCoS packet received (My-HM-MOD-RPI-PCB, RSSI: -64 dBm): 3101008F154688F00003103014F711A00000DA498BD1680001000001020110080403119C6288ADB7B98174F8845FF5712BBB

04/28/19 18:42:31.369 RPC Server (Port 2001): Info: Client number 109 is calling RPC method: ping (2) Parameters:

(String) eb5128e4

04/28/19 18:42:31.374 RPC Server (Port 2001): Info: Client number 109 is calling RPC method: listBidcosInterfaces (2) Parameters:

04/28/19 18:42:39.583 HomeMatic BidCoS packet received (My-HM-MOD-RPI-PCB, RSSI: -59 dBm): 3101008F154688F00003103014F711A00000DA498BD1680001000001020110080403119C6288ADB7B98174F8845FF5712BBB

04/28/19 18:42:40.872 HomeMatic BidCoS packet received (My-HM-MOD-RPI-PCB, RSSI: -59 dBm): 3101008F154688F00003103014F711A00000DA498BD1680001000001020110080403119C6288ADB7B98174F8845FF5712BBB

04/28/19 18:42:46.384 RPC Server (Port 2001): Info: Connection from ::ffff:127.0.0.1:44392 accepted. Client number: 171

04/28/19 18:42:46.384 RPC Server (Port 2001): Info: RPC server client id for client number 171 is: 29

04/28/19 18:42:46.386 RPC Server (Port 2001): Info: Client number 171 is calling RPC method: ping (2) Parameters:

(String) eb5128e4

04/28/19 18:42:46.391 RPC Server (Port 2001): Info: Client number 171 is calling RPC method: listBidcosInterfaces (2) Parameters:

04/28/19 18:42:50.710 HomeMatic BidCoS packet received (My-HM-MOD-RPI-PCB, RSSI: -68 dBm): 3101008F154xxxxxxxxxxxxxxx

Danke euch!

#2

Meine Config als (lesbaren) Code

########### HM-MOD-RPI-PCB ###########
#######################################

## The device family this interface is for

[HomeMatic Wireless Module for Raspberry Pi]

## Specify an unique id here to identify this device in Homegear

id = My-HM-MOD-RPI-PCB

## When default is set to "true" Homegear will assign this device

## to new peers.

default = true

## Options: cul, cc1100, coc, cunx, hmcfglan, hmlgw, hm-mod-rpi-pcb, homegeargateway

deviceType = hm-mod-rpi-pcb

device = /dev/ttyAMA0

## Default: responseDelay = 95

## Should be "95" for CUL or COC, "100" for TI CC1101 and "60" for HM-CFG-LAN or HM-LGW

responseDelay = 95

## Default: gpio1 = 0

## "18" for HM-MOD-RPI-PCB

gpio1 = 18

Hier mein Log file als Code formatiert:

04/28/19 18:42:01.355 RPC Server (Port 2001): Info: Client number 109 is calling RPC method: listBidcosInterfaces (2) Parameters:

04/28/19 18:42:16.360 RPC Server (Port 2001): Info: Client number 109 is calling RPC method: ping (2) Parameters:

(String) eb5128e4

04/28/19 18:42:16.364 RPC Server (Port 2001): Info: Client number 109 is calling RPC method: listBidcosInterfaces (2) Parameters:

04/28/19 18:42:20.154 IPC Server: Info: Connection accepted. Client number: 169

04/28/19 18:42:20.156 IPC Server: Info: Client 1 successfully registered RPC method "cliOutput" (this method is registered by 1 client(s)).

04/28/19 18:42:20.157 IPC Server: Info: Client 1 successfully registered RPC method "cliOutput-1" (this method is registered by 1 client(s)).

04/28/19 18:42:24.867 IPC Server: Info: Client number 1 is calling RPC method: familyExists Parameters:

(Integer64) 0

04/28/19 18:42:29.685 HomeMatic BidCoS packet received (My-HM-MOD-RPI-PCB, RSSI: -64 dBm): 3101008F154688F00003103014F711A00000DA498BD1680001000001020110080403119C6288ADB7B98174F8845FF5712BBB

04/28/19 18:42:31.369 RPC Server (Port 2001): Info: Client number 109 is calling RPC method: ping (2) Parameters:

(String) eb5128e4

04/28/19 18:42:31.374 RPC Server (Port 2001): Info: Client number 109 is calling RPC method: listBidcosInterfaces (2) Parameters:

04/28/19 18:42:39.583 HomeMatic BidCoS packet received (My-HM-MOD-RPI-PCB, RSSI: -59 dBm): 3101008F154688F00003103014F711A00000DA498BD1680001000001020110080403119C6288ADB7B98174F8845FF5712BBB

04/28/19 18:42:40.872 HomeMatic BidCoS packet received (My-HM-MOD-RPI-PCB, RSSI: -59 dBm): 3101008F154688F00003103014F711A00000DA498BD1680001000001020110080403119C6288ADB7B98174F8845FF5712BBB

04/28/19 18:42:46.384 RPC Server (Port 2001): Info: Connection from ::ffff:127.0.0.1:44392 accepted. Client number: 171

04/28/19 18:42:46.384 RPC Server (Port 2001): Info: RPC server client id for client number 171 is: 29

04/28/19 18:42:46.386 RPC Server (Port 2001): Info: Client number 171 is calling RPC method: ping (2) Parameters:

(String) eb5128e4

04/28/19 18:42:46.391 RPC Server (Port 2001): Info: Client number 171 is calling RPC method: listBidcosInterfaces (2) Parameters:

04/28/19 18:42:50.710 HomeMatic BidCoS packet received (My-HM-MOD-RPI-PCB, RSSI: -68 dBm): 3101008F154xxxxxxxxxxxxxxx

Danke euch!

Edit: jetzt als code formatiert

1 Like
#3

Hey @pinguin,

das HM-MOD-RPI-PCB ist etwas zickig… also vielmehr, der UART durch den Bluetooth-Port am RPi3. Hast du alles gemacht, wie hier beschrieben?

https://doc.homegear.eu/homegear-homematicbidcos/configuration.html#homematic-wireless-module-for-raspberry-pi-hm-mod-rpi-pcb

Gruß,
p

#4

Hi @pmayer,

meine /boot/cmdline.txt sieht wie folgt aus:

dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=c9ecd1c4-02 rootfstype=ext4 elevator=deadline elevator=deadline fsck.repair=yes rootwait

in /boot/config.txt habe ich folgendes hinzugefügt:

dtoverlay=pi3-miniuart-bt

enable_uart=1

dtparam=spi=on

dtparam=i2c_arm=on

Die drei Services habe ich auch deaktiviert:
(muss ich das bei jedem reboot machen?)

systemctl disable serial-getty@ttyAMA0.service
systemctl disable serial-getty@serial0.service
systemctl disable serial-getty@ttyS0.service

/etc/udev/rules.d/99-com.rules habe ich gelöscht

Damit sollte ich alles erledigt haben… klappt leider torotzdem nicht :-/

#5

Ich glaub das enable_uart=1 darf nicht rein… bin aber nicht sicher, da ich keine HM-MOD-RPI-PCB habe…

Du musst die Services nicht nach jedem reboot neu deaktivieren. Da reicht ein mal und dann ein reboot.

#6

Dank dir für die Idee. Auf der Webseite steht unter “5.2.6.1.3. All Raspberry Pis” das es rein soll. Die Reihenfolge innerhalb der Boot/config.txt sollte doch nicht relevant sein, oder?

Make sure enable_uart=1 is in /boot/config.txt .

Wenn ich die Zeile auskommentiere kommt nach “sudo homegear -r” folgender Fehler:

Could not connect to socket. Error: No such file or directory
#7

ich war nur zu schnell. Das System war wohl noch nicht zu 100% verfügbar. sudo homegear -r kann ich ausführen, jedoch weiterhin ohne erfolg beim pairing…

#8

Hmmm… Steht beim Starten “All physical devices are connected” oder so?

Du machst:

sudo homegear -r 
fs 4
pon

?

#9

ja, angeblich sind alle connected.

ich habe es mit fs 0 versucht. fs 4 kennt das system nicht.

#10

mein aktueller Status im Log sieht wie folgt aus.

pon sucht, das Gerät empfängt, aber es wird nichts gekoppelt. Zumindest kann ich mit ls keine Geräte angezeigt.

Kann hier jemand einen Fehler erkennen?

04/29/19 00:09:51.131 IPC Server: Info: Client number 2 is calling RPC method: cliFamilyCommand

(Integer64) 0

(String) pon

04/29/19 00:09:51.131 IPC Server: Debug: CLI client 2 is executing family command: pon

04/29/19 00:09:51.133 IPC Server: Response: 

(String) Pairing mode enabled for 60 seconds.

04/29/19 00:09:54.948 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Debug: Packet received. Raw data: FD0037012A050000

04/29/19 00:09:54.948 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Debug: Packet received. Raw data: 3201008F19DF58F0

04/29/19 00:09:54.949 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Debug: Packet received. Raw data: 0003103014F711A0

04/29/19 00:09:54.949 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Debug: Packet received. Raw data: 0000DA498BD16800

04/29/19 00:09:54.950 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Debug: Packet received. Raw data: 0100000102011008

04/29/19 00:09:54.951 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Debug: Packet received. Raw data: 0403D670A70FF3F9

04/29/19 00:09:54.952 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Debug: Packet received. Raw data: B1D870716518ABE0

04/29/19 00:09:54.952 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Debug: Packet received. Raw data: 1E4885DE

04/29/19 00:09:54.952 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Debug: Packet received from HM-MOD-RPI-PCB: FD0037012A0500003201008F19DF58F00003103014F711A00000DA498BD1680001000001020110080403D670A70FF3F9B1D870716518ABE01E4885DE

04/29/19 00:09:54.952 Debug (My-HM-MOD-RPI-PCB): Packet 3101008F19DF58F00003103014F711A00000DA498BD1680001000001020110080403D670A70FF3F9B1D870716518ABE01E48 enters raisePacketReceived.

04/29/19 00:09:54.953 Debug (My-HM-MOD-RPI-PCB): Packet 3101008F19DF58F00003103014F711A00000DA498BD1680001000001020110080403D670A70FF3F9B1D870716518ABE01E48 is now passed to the EventHandler.

04/29/19 00:09:54.952 HomeMatic BidCoS packet received (My-HM-MOD-RPI-PCB, RSSI: -50 dBm): 3101008F19DF58F00003103014F711A00000DA498BD1680001000001020110080403D670A70FF3F9B1D870716518ABE01E48

04/29/19 00:09:54.953 Debug (My-HM-MOD-RPI-PCB): Packet processing of packet 3101008F19DF58F00003103014F711A00000DA498BD1680001000001020110080403D670A70FF3F9B1D870716518ABE01E48 took 0 ms.
#11

Ach sorry, fs 0 ist homemeatic.

Was versuchst du denn genau anzulernen, den genauen typ?

#12

Homematic Fensterkontakte. Die aktuellen mit dem optischen Sensor statt Magnet.

#13

@pmayer
da es ein Homematic IP Gerät ist, benötige ich dazu noch eine CCU oder RaspberryMatic? habe die Information von dem alten Eintrag: Pairing problems

#14

Das von dir verlinkte Gerät ist normales Homematic, kein HmIP. Das hier wäre die HmIP-Variante:

#15

stimmt, mein Link war nicht richtig, sorry. War wohl etwas zu spät für mich.

Ich habe noch mal auf die Verpackung und meine Bestellung geschaut: es ist der HmIP. Den gab es am Samstag für ca 23€ bei Amazon mit same-day-delivery

Aber dieser sollte doch von Homegear und meinem Modul “Pi HM-MOD-RPI-PCB, für Smart Home / Hausautomation” unterstützt werden.

#16

Ja, aber nicht in Homegear.
Homegear kann HomematicIP nur über eine angebundene CCU… das kann allerdings eine oCCU (o.Ä.) sein die du auf deinem Pi installieren kannst.
Der Betrieb mit Homegear parallel auf dem selben Pi sollte aber ohne Probleme möglich sein.

1 Like
#17

DANKE!! Diese Information hat mir gefehlt.

Bedeutet für mich um meine HmIP Geräte in OpenHab2 einzubinden benötige ich zustäzlich oCCU (z.b. RaspberryMatic 3.45.5.20190330 (https://github.com/jens-maus/RaspberryMatic/releases/tag/3.45.5.20190330) und Homegear

Ich habe einen RB 3B und einen RB3B+. Was würdest du für eine Installation empfehlen?
-> RasbperryMatic und dazu Homegear auf dem Raspberry 3B+
-> OpenHab2 auf dem älteren RB3B

Oder lieber Homegear auf den mit OpenHab zusammen auf dem neueren Modell?

Dank dir! Danach kann ich erstmal wieder eine Runde basteln. :slight_smile:

#18

:+1:

Openhab würde ich immer auf die stärkere Hardware packen, da Java.
Homegear läuft schon ordentlich auf nem Pi1…

Meiner Meinung nach sollte alles zusammen auf einem RPI3B+ laufen können.