Nach Paket-Update: Error: Server could not start listening on port 2001: Success

#1

Hallo zusammen,

ich habe denselben Fehler wie bereits in diesem Thread beschrieben:

Der Fehler tritt nach einem apt-get update / apt-get upgrade auf. Bei dem Paketupdate wurde u.a. auch die homegear Version auf 0.6.19 aktualisiert (zuvor 0.6.7).
Leider hilft mir der Hinweise aus dem anderen Thread nicht weiter. Hat jemand eine Idee, wie man das Problem lösen könnte bzw. Anregungen zur Fehlersuche?

Vielen Dank!
Alex

Server could not start listening on port 2000
#2

Ich habe inzwischen die Lösung gefunden. Ich habe die Installation mehrfach komplett gelöscht inkl. Datenbank und Konfigurationen, das hat leider wenig gebracht (außer dass auch Reste von alten Versionen wirklich verschwunden sind).

Letztlich habe ich die gesicherten Konfigurationsdateien der 0.6.7 Installation schrittweise verglichen. Und siehe da, der Fehler war schnell gefunden in der Datei rpcservers.conf:

[RPCServer1]
# Interface to bind the RPC server to. By default IPv4 and IPv6 are
# enabled. If you want to only use IPv4 set "interface" to "0.0.0.0".
# Default: interface = ::
interface = 0.0.0.0

Hier war in der neuen Variante der Default aktiv, in der alten Variante wie abgebildet nur IPv4 über “0.0.0.0” gesetzt.
Das ganze habe ich für alle 3 RPCServer Einträge angepasst und nun geht alles wieder.

Ich finde es etwas ärgerlich, dass die Konfiguration ohne Vorwarnung überschrieben wird.

#3

Hallo @alexf2000,

Version 0.6.19 ist auch nicht mehr aktuell. Läuft bei dir noch Debian Wheezy? Das wird nicht weiter unterstützt. Die aktuelle Homegear-Version ist 0.7.8.

Viele Grüße

Sathya

#4

Hallo Sathya,

bei mir lief noch Wheezy. Die Version 0.6.19 war das neueste, was es für Wheezy gab, leider hat das Upgrade wie beschrieben meine Konfiguration zerschossen.

Nachdem ich den Fehler gefunden und behoben hatte bin ich inzwischen auch in mehreren Schritten auf “Stretch” hochmigriert. Entsprechend läuft nun auch Version 0.7.8 bei mir.

Gruß
Alex

#5

Ich grabe das mal aus, da der gleiche Fehler bei mir nach Update auf das aktuelle Nightly aufgetreten ist. Ich nutze das HomeGear Raspbian Stretch Image.

#6

Hallo @tringler,

magst du mir einmal ein Log auf Loglevel 4 posten?

Viele Grüße

Sathya