Triying change time zone error

Im triying change time zone using raspi-config and is raising a error about missing file or package.
Configuring other options (like locale) is doing fine, so seems a problem only with set time zone related.
My Hoemgear system is installed with the raspbian image version provided with only read mode: Current stable version: 0.7.40-2948.
Of course I set rw mount before trying to run raspi-config tool.

Will be fine know how to fix the issue or how to configure time zone settings and ntp settings to have the local time system propperly working.

Regards

Jose,

Hey,

that’s odd and should be fixed by @sathya.
You should be able to fix it with

sudo apt-get install --reinstall tzdata

https://www.raspberrypi.org/forums/viewtopic.php?t=145194

Hi Patrick,
Thanks for your reply.

Still error on raspi-config for time zone setup after try your purposse. Seems something more deep that only reinstall the package tzdata.
In the image I run > … --reinstall tzdata (not showing in that image), then I tray fix dependences as per message with > apt --fix-broken install, with raised a bounch of errors like shows in image and then again > … --reinstall tzdata with same result.

… but all with no luck.
Try raspi-config time-zone setup and now error message from raspi-config is “elevated” to I2…

Forget comment that can run any other setup from raspi-config (ex. install locale) without issues.

Best regards

Ok. I’m not sure where changes for the read-only image are done… so, the best bet is to wait for @sathya’s comment. Sorry.

Agree, @sathya is our best bet… nothing to sorry . thanks

Only a comment for a workarround purposses while @sathya fix raspbian image.
Change time zone without raspi-config it’s as eassy as this with cli:
Of course need first make mount system partition to rw.

pi@homegearpi-36-00-2a(rw):~$ sudo mount -o remount,rw /
pi@homegearpi-36-00-2a(rw):~$ sudo timedatectl set-timezone Europe/Madrid

Regards…

1 Like

Hello @jirm,

your installation seems to be broken - for what reason ever.

I just tested the current image and setting the time there works without problems.

You should execute

apt -f install

To fix the bootloader package as well.

Cheers,

Sathya