[solved] Sound HAT not working on RPi after HG Update

I was running a RPi4 with HG and a Suptronics X400 Audio HAT since 2016 without any problems.

But as I recently updated HG from 0.7.48-3324 to 0.7.51-3497 the audio output is completley gone when HG is started. I do not get any related error messages in HG-Log or syslog. When using aplay it pretends to play normally but one cannot hear anything.

Audio output is restored on system reboot as long as homegear is not started.

The HAT uses I2S audio and GPIO Ports 18, 19 and 21 (and probably 22) which should not collide with my CC1101 module from @pmayer .

I just use homaticbidcos module. I tried to uninstall/deactivate all unnassesary modules but whitout success. But probably I missed something.

ls /sys/class/gpio/ just shows GPIO25 (CC1101) in use.

Is there any interaction from HG with I2S audio or the GPIO listed above? Does anybody have a hint on what to check next or how to proceed?

Many thanks

Module: http://www.suptronics.com/xseries/x400.html
I am using openhabian but tested also with raspberrypios-lite

Have there been any major changes between these two versions which could help me find the root cause of these issues? I mean i could simply revert to the old version and stick with it. But this will be a dead end road some time.


I have no clue why, but my problems are gone…

I reverted to version 0.7.49-3411 as this was the closest available candidate to my old 0.7.48.
As I had it running I updated to 0.7.50-3478 and 0.7.51-3497.

I don’t now if the step-by-step updates are doing things diffently than the large step I took first. But nevermind its working.
This is just ftr if anybody is experiencing something similar.