RSSI_PEER immer 0

Hallo!

Ich habe aktuell zwei Rolladenaktoren an meinem HM-CFG-LAN hängen. Bei RSSI_DEVICE werden mir in openhab vernünftige Werte angezeigt, bei RSSI_PEER sind alle Werte aber immer 0.

Hat jemand eine Idee woran das liegen könnte?

Viele Grüße!

Hallo,

RSSI_PEER wird nur bei Direktverknüpfungen verwendet und stellt den RSSI zum Linkpartner dar (niemals den RSSI der Verbindung mit Homegear!). Das kann aber nur ein Teil der Geräte. Bisher ist RSSI_PEER etwas stiefmütterlich implementiert (auch seitens eQ-3). Man müsste sich mal ransetzen und die XML-Dateien anpassen, um den RSSI aus den Paketen auszulesen, in denen dieser drinsteht. Das ist nicht viel Arbeit, bisher war ich dazu aber etwas faul.

Wenn keine Direktverknüpfungen existieren, interessiert sowieso nur RSSI_DEVICE (also der RSSI zwischen Homegear und Gerät auf Homegearseite). Der RSSI zwischen Homegear und Gerät auf Geräteseite lässt sich leider nicht ermitteln. Er wird schlechter sein, als der RSSI auf Homegearseite.

Liebe Grüße

Sathya

Nachtrag: Ab dem aktuellen Nightly wird endlich die RSSI-abhängige Wahl der Kommunikationsschnittstelle unterstützt (“Roaming”).

Hallo!

Wieder vielen Dank für Dein schnelles Feedback.

Das macht so auch Sinn (RSSI_PEER==0), da ich gar keine Direktverknüpfungen habe. Ich war davon ausgegangen, dass RSSI_PEER einfach der RSSI in die andere Richtung ist…

Viele Grüße.

Sorry, für den Thread-Hijack.

Zuerst einmal, Sathya, Daumen hoch für ein super Stück Software. Ich habe mich knapp nen Jahr mit ner CCU2 rumgeschlagen und nach ein paar Stunden mit Homegear alle meine Baustellen gelöst und bin wieder super glücklich mit Homematic.

Ich habe hier aber noch ein paar Reichweiten Probleme und würde gerne weitere “physicalinterfaces” im Haus verteilen, um die entfernten Komponenten besser anzubinden. Ich habe hier noch 2 HM-CFG-LAN, die aber nicht funktionieren, weil ich keinen rfKey konfiguriert habe. Den möchte ich nicht eintragen, da danach mein RPi mit COC nicht mehr funktioniert oder irre ich mich hier?. Und ich hatte massiv Probleme mit der CCU2 in Verbindung mit dem “System-Sicherheitsschlüssel”.

Falls unbedingt notwendig - könnte ich nicht mittels HM-CFG-LAN einen neuen rfKey eintragen und den dann mittels COC verwenden? Dann wäre das Problem mit dem “nicht bekannten” default-AES Schlüssel keins mehr, oder?

Oder soll ich CUNOs im Haus verteilen und erstmal auf den AES Schlüssel verzichten? Wirklich sicherheitskritische Dinge habe ich hier eh nicht laufen.

WK

Hey WK,

AES kannst du auch in Kombination mit den HM-CFG-LAN vollständig deaktiviert bekommen und lassen, indem du in der physicalinterfaces.conf beim COC (und nur dort!) “default = true” setzt. Dann findet der Anlernvorgang über den COC statt und AES bleibt deaktiviert. Im Anschluss kannst du gefahrlos entweder mit dem RPC-Befehl “setInterface” oder indem du “ROAMING” auf “true” setzt (letzteres ist noch experimentell und funktioniert nur mit dem aktuellen Nightly-Build!) die Kommunikationsschnittstelle wechseln. AES wird so niemals automatisch aktiviert werden (nur wenn du es manuell einschaltest)! Entsprechend wirst du auch keine AES-spezifischen Probleme bekommen.
Der COC kann leider auch bei bekanntem Schlüssel noch keinen AES-Handshake, weil wir den Handshake noch nicht vollständig verstanden haben.

CUNOs werden zur Zeit noch nicht von Homegear unterstützt, wobei die Implementierung nicht viel Arbeit ist. Wird also bald unterstützt werden :wink:.

Liebe Grüße

Sathya

Vielen Dank für die Antwort. Werde ich gleich ausprobieren.

Hast Du ne Idee, wann der aktuelle Nighly als Paket erscheint? ich bin ein Freund von apt-get update/upgrade :slight_smile:

:smiley: Mal sehen wann das aktuelle Nightly als Stable erscheint. Vermutlich noch diese Woche. Ich warte noch auf Rückmeldungen :wink:.

Liebe Grüße

Sathya

kann ich das aktuelle Nightly per deb -i einspielen und beim nächsten apt-get update/upgrade wird es automatisch mit dem Stable überschrieben?

Jupp. Stable kommt aber auch heute :wink:.

12/10/14 18:34:08.947 Module HomeMatic BidCoS: LAN-Konfigurationsadapter “HM-CFG-LAN-Keller”: Error: No RF AES key specified in physicalinterfaces.conf on your HM-CFG-LAN for communication with your BidCoS devices.
12/10/14 18:34:08.951 Module HomeMatic BidCoS: LAN-Konfigurationsadapter “HM-CFG-LAN-Dachgeschoss”: Error: No RF AES key specified in physicalinterfaces.conf on your HM-CFG-LAN for communication with your BidCoS devices.
12/10/14 18:34:17.216 Module HomeMatic BidCoS: LAN-Konfigurationsadapter “HM-CFG-LAN-Dachgeschoss”: Error: Cannot start listening , because rfKey is not specified.
12/10/14 18:34:19.240 Module HomeMatic BidCoS: LAN-Konfigurationsadapter “HM-CFG-LAN-Keller”: Error: Cannot start listening , because rfKey is not specified.

Die Fehlermeldungen kann ich ignorieren? Sieht für mich doch sehr final aus “Cannot start listening, because rfKey is not specified”…

Ist auch final, die beiden HM-CFG-LAN funktionieren nicht :wink:.

In der physicalinterfaces.conf muss der Parameter “rfKey” für jeden HM-CFG-LAN gesetzt sein. Am besten bei allen der gleiche, damit es keine Probleme gibt :wink:.

Liebe Grüße

Sathya

Und dann kann ich trotzdem noch mit dem COC mit den Dingern kommunizieren, weil der nicht verwendet wird?
Sorry, wenn ich ein wenig auf dem Schlauch stehe.

Edit: Ich glaub ich hab es verstanden.

“On some devices you have to enable AES manually on some it is enabled by default. In either case, if a device requires AES handshakes, you can’t just switch communication to a CUL or COC, so you need to disable it on all channels, i. e. with the HomeMatic Configurator (column “Übertragungsmodus”).”

Solange der Übertragungsmodus also auf Standard steht und der COC default=true hat und alle anderen nicht bzw. default=false, dann ist alles gut.

Genau. Außer du hast mit “setInterface” die Kommunikationsschnittstelle eines Gerätes verändert.

Kann ich trotzdem ROAMING verwenden und je nach Entfernung (RSSI-Wert) wird automatisch der COC oder ein HM-CFG-LAN ohne AES verwendet?

Ja, so lange AES auf keinem Kanal aktiviert ist (wenn über den COC angelernt wurde ist das nie der Fall), kannst du ROAMING verwenden und Homegear bezieht sowohl den COC als auch den HM-CFG-LAN mit ein. Wenn du AES aktivierst hast, werden alle AES-unterstützenden Kommunikationsschnittstellen mit einbezogen. Gib mir auch eine kleine Rückmeldung (falls du es einschaltest), wie gut ROAMING bei dir funktioniert :stuck_out_tongue:. Wie gesagt, das ist noch experimentell.

Bin zufällig auf eine ähnliche Frage im Homematic Forum gestossen. Die dortige Qualität der Antworten und der Ton dabei unterscheiden sich doch um einiges. Ich hoffe er hat hierher gefunden :smile:

1 Like