Raspberry Pi 2 + busware CCD: no pairing


I have successfully installed homegear & openHAB on a Raspberry Pi 2 using the image provided. I am using the busware CCD with integrated CUL:


So far I got the CCD, the touchscreen and the CUL drivers loaded and homegear starts up using the tty of the CUL. However I cannot pair any homematic devices doing:

families select 0
devices select central
pairing on

All devices were previously paired to the CCD/CUL with a FHEM installation, so I did a factory reset on all homematic devices. Is there any way to further debug the pairing?

I also just updated the firmware on the CCD to CUL_VER_161. Still no luck.


Hi amsparen,

after a successful pairing you can see the new device with “ls”.
Also, on the CLI look into the file /var/log/homegear/homegear.log. If you need more information in the log file just change the logging level in the file /etc/homegear/main.conf at the line debugLevel = 6 (default is 4 and higher means more details)



Hi Steve,

thanks for your reply. I was not getting any devices with “ls” and not even loglevel 6 there was no sign of pairing…

I just found this post though:


And to get the CCD working I had to use these settings:

deviceType = coc
device = /dev/ttyAMA0
responseDelay = 95
gpio1 = 17
gpio2 = 22

Problem solved - all devices paired.