Paring device: Invalid device (HM-MOD-RPI-PCB with Hassbian)


#1

Hi everybody,

since a few days I’m trying to pair my heating thermostat (Homematic HmIP-eTRV-B1) with homegear.
For the german guys here a link:
https://www.lidl.de/de/silvercrest-heizkoerperthermostat-smart-home-hmip-etrv-b1/p290343

I am using the HM-MOD-RPI-PCB on a hassbian os.

First of all I updated the Firmware for the HM-MOD-RPI-PCB with these steps. (Worked out well after I checked the firmware on fhem:

sudo su
apt-get update && apt-get -y install libusb-1.0-0-dev build-essential git
systemctl stop fhem
git clone git://git.zerfleddert.de/hmcfgusb
cd hmcfgusb/
make
wget https://raw.githubusercontent.com/eq-3/occu/ee68faf77e42ed5e3641790b43a710a3301cea7e/firmware/HM-MOD-UART/coprocessor_update.eq3
./flash-hmmoduart -U /dev/ttyAMA0 coprocessor_update.eq3

After that I used the homegear installation setup for Raspbian 9:
https://doc.homegear.eu/data/homegear/installation.html

At the next step I configured the RPI-PCB like descriped in this guide:
https://doc.homegear.eu/data/homegear-homematicbidcos/configuration.html#config-hm-mod-rpi-pcb

Then I checked the logfiles (homegear.err and homegear.log) for errors. All seems to be running. There are no errors. (I’m using the debuglevel 10).

So I was ready to pair my first device by doing “homegear -r”, “families select 0” and “pairing on”. Then I pressed the Homematic button on my device and saw this message:

(String) paring on
12/08/18 11:02:26.036 IPC Server: Debug: CLI client 2 is executing family command: paring on
12/08/18 11:02:26.037 IPC Server: Response:
(String) Invalid device type. Device type has to be provided in hexadecimal format.

I tried to find something in the web but it seems to be that noone is facing this problem.
Someone got the same problem and already got a solution for this?

Thanks a lot :slight_smile:


#2

Homematic IP is not the same as Homematic (BidCos, family 0). It’s the same frequency but a different protocol. HmIP is not yet reverse engineered so you need a CCU (or Raspberrymatic) to connect it to Homegear.


#3

Oh okay. Thanks you a lot. Using it as a CCU isn’t my preferred way. Next time I will check the devices list first (https://ref.homegear.eu/devices/). I think I will switch to the MAX! basic Thermostat.


#4

I use the Homematic (no IP) devices.

After testing a single Max! wall mounted switch I will never buy Max! again. Max! is quite cheaper, but they also lack functions in comparison.