[Nightly 0.8.0 - 2898] UI-Elemente werden nicht mehr angezeigt

Hallo,

zunächst mal von meiner Seite ein großes Lob an alle, die an dem Homegear-UI mitarbeiten.
Es sind ja schon richtig viele Rollen für Variablen umgesetzt und man kann das UI ja bereits gut verwenden. Außerdem wird die Dokumentation jetzt auch immer besser !

Jetzt aber zu meiner Frage: Um in den Genuss der neusten Features zu kommen, habe ich von einem älteren Nightly auf das aktuelle Build 0.8.0-2898 upgedatet.
Leider werden jetzt bei mir alle UI-Elements, die eigentlich bereits funktioniert haben, nicht mehr in der Weboberfläche angezeigt. Es erscheint nur die Startseite (Häusersymbol mit blinkenden Funkwellen) und dann geht es nicht mehr weiter.

Mit getAllUiElements() kann ich aber sehen, dass die UI-Elements alle noch vorhanden sind und beim Update nicht gelöscht wurden.

Hier habe ich mal einen Auszug von homegear.log auf Debug-Level 4 beim Start des UI angehängt. Ich hoffe, das ist hilfreich. Sonst meldet Euch bitte, wenn Ihr noch mehr Details braucht.

homegear.log (21,0 KB)

Hat jemand dazu eine Idee ? Vielen Dank.

Viele Grüße

FiveEights

2 Likes

Hey 0,625‬

hast du schon versucht Cookies zu löschen/ die Visu in einem neuen privaten Fenster zu öffnen?
Räume und Stockwerke sind angelegt, nehme ich an?
Vielleicht einmal mit https://<Homegear-IP>:2002/ui versuchen.

Grüße, Sim

Hallo @FiveEights,

funktioniert der Zugriff über Port 2002? Du hast die UI über den Nightly-Installer mit installiert, richtig?

Viele Grüße

Sathya

Hallo,

vielen Dank für die schnelle Rückmeldung.

Räume und Stockwerke hatte ich über das Admin-UI schon lange benutzt d.h. hier ist alles eingerichtet und läuft.

Das Öffnen des Homegear-UI in einem privaten Fenster hat nicht geholfen und ich habe es mittlerweile mit verschiedenen Computern und auch mit dem Handy probiert - leider immer mit dem gleichen Ergebnis: Nach dem Login erscheint nur Startseite, aber kein UI.

Die ganze Installation habe ich mit dem Installations-Skript für die Nightlies von der Download-Seite durchgeführt. Das ist genau die gleiche Vorgehensweise, die bisher immer funktioniert hat.

Zugriff auf Port 2002 kann ich zur Zeit leider nicht testen, da ich nicht zuhause bin und nur eine Portweiterleitung auf Port 2001 habe.

Viele Grüße

FiveEights

Hallo @FiveEights,

hast du zugriff auf die Browser Console und kannst von dort einen Auszug posten?

Viele Grüße
Marwin

Hallo,

hier die Ausgabe der Console von Google Chrome, wenn die UI-Startseite erscheint:

DevTools failed to parse SourceMap: chrome-extension://gighmmpiobklfepjocnamgkkbiglidom/include.preload.js.map
script.min.js?revision=153:74 Homegear security issue!
script.min.js?revision=153:202 UI revision: 153
script.min.js?revision=153:220 Download the Vue Devtools extension for a better development experience:
https://github.com/vuejs/vue-devtools
script.min.js?revision=153:220 You are running Vue in development mode.
Make sure to turn on production mode when deploying for production.
See more tips at https://vuejs.org/guide/deployment.html
DevTools failed to parse SourceMap: chrome-extension://gighmmpiobklfepjocnamgkkbiglidom/include.postload.js.map
DevTools failed to parse SourceMap: http://[meine Homegear-Adresse]:2001/ui/iro.min.js.map

Ich hoffe, das ist hilfreich. Sonst melde Dich bitte, wenn Du noch mehr Infos brauchst.
Vielen Dank für die Unterstützung !

Viele Grüße

FiveEights

Hallo,

habe mittlerweile auf Version 0.8.0-2898 upgedatet und leider gibt es keine Verbesserung an diesem Issue. Das Homegear UI bleibt bei mir immer noch nach dem Login auf dem Startbildschirm stehen.

Auch das probeweise Löschen und erneutes Hinzufügen eines UI-Elements brachte keine Änderung.

Hat hierzu niemand eine Idee ? Ich kann das UI jetzt leider überhaupt nicht mehr nutzen, obwohl es schon mal wirklich gut funktioniert hat. Vielen Dank.

Viele Grüße

FiveEights

Hallo FiveEights,

die Ursache liegt an folgender Log Message:

script.min.js?revision=153:74 Homegear security issue!

Vermutlich ist in der Datei: “/var/lib/homegear/ui/interfacedata.custom.php”,
der Parameter: “settings.homegear.ssl” abweichend vom Aufruf der URL im Browser “http” oder “https”.

Die Ursache kann auch in der Datei: “/etc/homegear/rpcservers.conf” sein.

Viele Grüße
Marwin

Hallo Marwin,

vielen Dank, dass Du Dir das Issue angeschaut hast und für Deine Hinweise.
Um weiterarbeiten zu können, bräuchte ich jedoch bitte noch etwas Hilfestellung.

Der Zugriff auf das UI funktioniert bei mir leider nicht, egal ob über http oder https.

Ich habe gar keine Datei „/var/lib/homegear/ui/interfacedata.custom.php“ sondern nur „interfacedata.php“.
Ich dachte immer, die custom-Datei braucht man nur, wenn man individuelle Einstellungen vornehmen möchte.

Wie müsste „interfacedata.custom.php" denn aussehen?

Und wo könnte eine potentielle Fehlerursache in rpcservers.conf liegen ? Diese Datei ist bei mir schon lange unverändert.

Viele Grüße

FiveEights

Hallo FiveEights,

die Datei „/var/lib/homegear/ui/interfacedata.custom.php“ ist optional. Ohne sie ist es einfacher.

Welche Version des Interfaces hast du derzeit, immer noch 153?

Wie genau rufst du das Interface in der Browser Adressleiste auf?

Kannst du mir den Inhalt deiner rpcservers.conf schicken?

Dort ist für den entsprechenden Port u.a. der Teil:

# Set ssl to “true” to enable SSL support
ssl = true

relevant.

Viele Grüße
Marwin

1 Like

Hallo Marwin,

meine Homegear-Version ist das Nightly 0.8.0-2901.
Wo kann ich denn die Homegear-UI Version sehen? Dann kann ich diese gerne noch nachliefern.

Ich rufe das Homegear-UI aus meinem lokalen Netzwerk mit der URL
http://<Computername>:2001/ui/signin.php auf und dann erscheint die Login-Seite.

Die Startseite mit dem orangenen Haus-Symbol erscheint dann unter der URL http://<Computername>:2001/ui/index.php#nb

Beim Aufruf der Login-Seite mit https:// erhalte ich die Fehlermeldung „Die Website ist nicht erreichbar“.

Meine rpcservers.conf habe ich hier angehängt
rpcservers.txt (13,0 KB)

Die Datei ist meines Wissens nach unverändert d.h. ich kann mich zumindest nicht erinnern, hier etwas modifiziert zu haben.

Bitte melde Dich einfach, wenn Du noch mehr Details brauchst. Vielen Dank.

Viele Grüße

FiveEights

1 Like

Hi FiveEights,

deine rpcservers.conf schaut soweit gut aus.

Die UI Revision wird dir in der Browser Console angezeigt:

script.min.js?revision=153:202 UI revision: 153

Wir sind dran, zeitnah eine Update der UI fertigzustellen, in diesem habe ich die Prüfung auf eine valide ssl Konfiguration verfeinert. Ich bin zuversichtlich, dass wir dann in deinem Fall weiter kommen, oder der Fehler sogar weg ist :slight_smile:

Herzliche Grüße
Marwin

1 Like