Nach Update - Could not connect to socket. Error: No such file or directory

Hallo Forum,

homegear -v
Homegear version 0.7.39-2768
Copyright (c) 2013-2019 Homegear GmbH

Git commit SHA of libhomegear-base: -
Git branch of libhomegear-base:     -
Git commit SHA of Homegear:         -
Git branch of Homegear:             -

nach dem openHabian Homegear geupdatet hat erreiche ich nicht mehr homegear -r

Ich habe mal den Debug mode auf 5 gestellt:

[16:10:43] openhabian@openHABianPi:~$ sudo homegear -r
03/26/19 16:10:49.794 Debug: debugLevel set to 5
03/26/19 16:10:49.795 Debug: memoryDebugging set to 1
03/26/19 16:10:49.795 Debug: devLog set to 0
03/26/19 16:10:49.796 Debug: enableCoreDumps set to 1
03/26/19 16:10:49.796 Debug: setDevicePermissions set to 1
03/26/19 16:10:49.796 Debug: workingDirectory set to /var/lib/homegear/
03/26/19 16:10:49.797 Debug: socketPath set to /var/run/homegear/
03/26/19 16:10:49.797 Debug: dataPath set to /var/lib/homegear/
03/26/19 16:10:49.797 Debug: familyDataPath set to /var/lib/homegear/families/
03/26/19 16:10:49.798 Debug: databaseMemoryJournal set to 0
03/26/19 16:10:49.798 Debug: databaseWALJournal set to 1
03/26/19 16:10:49.798 Debug: databaseSynchronous set to 1
03/26/19 16:10:49.798 Debug: databaseMaxBackups set to 10
03/26/19 16:10:49.799 Debug: logfilePath set to /var/log/homegear/
03/26/19 16:10:49.799 Debug: enableUPnP set to 1
03/26/19 16:10:49.799 Debug: deviceDescriptionPath set to /etc/homegear/devices/
03/26/19 16:10:49.800 Debug: clientSettingsPath set to /etc/homegear/rpcclients.conf
03/26/19 16:10:49.800 Debug: serverSettingsPath set to /etc/homegear/rpcservers.conf
03/26/19 16:10:49.800 Debug: mqttSettingsPath set to /etc/homegear/mqtt.conf
03/26/19 16:10:49.800 Debug: familyConfigPath set to /etc/homegear/families/
03/26/19 16:10:49.801 Debug: phpIniPath set to /etc/homegear/php.ini
03/26/19 16:10:49.801 Debug: gpioPath set to /sys/class/gpio/
03/26/19 16:10:49.801 Debug: scriptPath set to /var/lib/homegear/scripts/
03/26/19 16:10:49.802 Debug: enableNodeBlue set to 1
03/26/19 16:10:49.802 Debug: nodeBluePath set to /var/lib/homegear/node-blue/
03/26/19 16:10:49.802 Debug: nodeBlueDataPath set to /var/lib/homegear/node-blue/data/
03/26/19 16:10:49.802 Debug: nodeBlueDebugOutput set to 1
03/26/19 16:10:49.803 Debug: adminUiPath set to /var/lib/homegear/admin-ui/public/
03/26/19 16:10:49.803 Debug: uiPath set to /var/lib/homegear/ui/
03/26/19 16:10:49.803 Debug: libraryPath set to /var/lib/homegear/modules/
03/26/19 16:10:49.804 Debug: firmwarePath set to /usr/share/homegear/firmware/
03/26/19 16:10:49.804 Debug: tempPath set to /var/lib/homegear/tmp/
03/26/19 16:10:49.804 Debug: lockFilePath set to /var/run/homegear/
03/26/19 16:10:49.804 Debug: lockFilePathPermissions set to 504
03/26/19 16:10:49.805 Debug: lockFilePathUser set to homegear
03/26/19 16:10:49.805 Debug: lockFilePathGroup set to homegear
03/26/19 16:10:49.805 Debug: oauthCertPath set to /etc/homegear/homegear.crt
03/26/19 16:10:49.806 Debug: oauthKeyPath set to /etc/homegear/homegear.key
03/26/19 16:10:49.806 Debug: oauthTokenLifetime set to 3600
03/26/19 16:10:49.806 Debug: oauthRefreshTokenLifetime set to 5184000
03/26/19 16:10:49.807 Debug: Added replaceClientServerAddress xmlrpc_bin://127.0.0.1:1999 xmlrpc_bin://$remoteip:1999
03/26/19 16:10:49.807 Debug: Added replaceClientServerAddress http://127.0.0.1:9292/bidcos http://$remoteip:9292/bidcos
03/26/19 16:10:49.807 Debug: waitForCorrectTime set to 1
03/26/19 16:10:49.808 Debug: prioritizeThreads set to 1
03/26/19 16:10:49.808 Debug: secureMemorySize set to 65536
03/26/19 16:10:49.808 Debug: workerThreadWindow set to 3000
03/26/19 16:10:49.809 Debug: scriptEngineMaxThreadsPerScript set to 4
03/26/19 16:10:49.809 Debug: scriptEngineMaxScriptsPerProcess set to 50
03/26/19 16:10:49.809 Debug: scriptEngineThreadCount set to 5
03/26/19 16:10:49.809 Debug: scriptEngineServerMaxConnections set to 10
03/26/19 16:10:49.810 Debug: scriptEngineWatchdogTimeout set to 60000
03/26/19 16:10:49.810 Debug: scriptEngineManualClientStart set to 0
03/26/19 16:10:49.810 Debug: nodeBlueProcessingThreadCountServer set to 5
03/26/19 16:10:49.811 Debug: nodeBlueProcessingThreadCountNodes set to 10
03/26/19 16:10:49.811 Debug: nodeBlueServerMaxConnections set to 50
03/26/19 16:10:49.811 Debug: maxNodeThreadsPerProcess set to 60
03/26/19 16:10:49.811 Debug: nodeBlueWatchdogTimeout set to 60000
03/26/19 16:10:49.812 Debug: nodeBlueManualClientStart set to 0
03/26/19 16:10:49.812 Debug: ipcThreadCount set to 5
03/26/19 16:10:49.812 Debug: ipsServerMaxConnections set to 20
03/26/19 16:10:49.812 Debug: cliServerMaxConnections set to 50
03/26/19 16:10:49.813 Debug: rpcServerMaxConnections set to 50
03/26/19 16:10:49.813 Debug: rpcServerThreadPriority set to 0
03/26/19 16:10:49.813 Debug: rpcServerThreadPolicy set to 0
03/26/19 16:10:49.814 Debug: rpcClientMaxThreads set to 50
03/26/19 16:10:49.814 Debug: rpcClientThreadPriority set to 0
03/26/19 16:10:49.814 Debug: rpcClientThreadPolicy set to 0
03/26/19 16:10:49.814 Debug: workerThreadPriority set to 0
03/26/19 16:10:49.815 Debug: workerThreadPolicy set to 0
03/26/19 16:10:49.815 Debug: physicalInterfaceThreadPriority set to 45
03/26/19 16:10:49.815 Debug: physicalInterfaceThreadPolicy set to 1
03/26/19 16:10:49.816 Debug: packetReceivedThreadPriority set to 0
03/26/19 16:10:49.816 Debug: packetReceivedThreadPolicy set to 0
03/26/19 16:10:49.816 Debug: eventThreadCount set to 5
03/26/19 16:10:49.816 Debug: eventThreadPriority set to 0
03/26/19 16:10:49.817 Debug: eventThreadPolicy set to 0
03/26/19 16:10:51.830 Could not connect to socket. Error: No such file or directory
03/26/19 16:10:51.830 Could not connect to socket. Error: No such file or directory
03/26/19 16:10:53.829 Could not connect to socket. Error: No such file or directory
03/26/19 16:10:53.830 Could not connect to socket. Error: No such file or directory
03/26/19 16:10:53.830 Could not connect to socket. Error: No such file or directory
03/26/19 16:10:53.830 Could not connect to socket. Error: No such file or directory

Jemand eine Idee?

LG

Update

Wenn ich

homegear -u homegear -g homegear -d

in die Console tippe startet es.

da kommt als Error nur:

03/26/19 18:43:51.303 Error: Could not redirect output to log file.
03/26/19 18:43:51.305 Error: Could not redirect output to log file.

LG

Sorry leute ich würde gerne meine Beiträge editieren. Aber er sagt “body is to similar”

Auch commands wie:

service homegear restart gehen nicht mehr

er hängt sich dann einfach auf.

Im Error Log entsteht jetzt:

03/26/19 18:31:28.194 RPC Server (Port 2000): Error: Server could not start listening on port 2000: Address already in use

03/26/19 18:31:28.194 RPC Server (Port 2001): Error: Server could not start listening on port 2001: Address already in use

Laeuft evtl. noch ein Homegear-Prozess?

– Micha

Moin zusammen,

ich habe nach einem Update ein ähnliches Problem.

Allerdings läuft der Homegear Prozess und die Kommunikation mit OpenHAB rennt auch. Allerdings kann ich mich nicht mehr mit der Console (homegear -r) verbinden.

09/08/19 08:06:52.649 Critical: Could not transmit PID to server: Requested method not found.
09/08/19 08:06:52.720 Could not connect to socket. Error: No such file or directory

Ich verwende aktuell:

root@homi:~# homegear -v
Homegear version 0.8.0-2576
Copyright © 2013-2019 Homegear GmbH

Es ist möglich sich mit der Konsole zu verbinden nach einem Downgrade auf die jeweilige Version von den folgenden Paketen: libhomegear-node:armhf=0.1.7-38 und libhomegear-ipc:armhf=0.1.2-26

Homegear arbeitet bei mir auf Raspian mit einem SCC Modul.

Linux homi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux

Nicht das die ARM CPU nun zu alt ist?!

Noch ein Nachtrag aus der homegear.err:

09/08/19 08:06:52.648 IPC Server: Warning: RPC method not found: setPid
09/08/19 08:06:53.197 IPC Server: Error: No or invalid response received to RPC request. Method: broadcastEvent
09/08/19 08:06:53.197 IPC Server: Error calling “broadcastEvent” on client 34: No response received.

Viele Grüße aus dem Norden.
Martin

Hallo @mburgholte,

deine CPU ist nicht zu alt. Hättest du mal ein komplettes homegear.log für mich? Welches Raspbian läuft bei dir (Jessie, Stretch, Buster)?

Viele Grüße

Sathya

Hi @sathya,

aktuell läuft Debian Stretch auf dem Raspi. Hier ein frisches Log vom Start. homegear.log (89.7 KB)

Ich muss zu meiner Schande gestehen, dass die Konfiguration eigentlich von einer uralten Homegear Version kommt. Getreu dem Motto “Never touch a running system.”

Vielleicht siehst du auf einen schnellen Blick schon das Problem.

Viele Grüße und vielen Dank!
Martin