Nach Umzug von Raspi 3 auf 3b+ können Stati nicht mehr gesetzt werden


#1

Hallo,
ich habe ein Problem mit meinem System.
Hatte NodeRed und Homegear auf einem Raspi 3 laufen. Da ich hier aber noch einen Raspi 3b+ liegen hatte dachte ich mir, dass ich doch lieber auf diesen wechsele. Habe vielleicht dran gedacht später mal einen Webserver drauf laufen zu lassen.
Jedoch habe ich jetzt das Problem, dass ich nach dem Umzug (SD Karte aus dem 3er raus und in den 3b+ rein), zwar eine Verbindung in Homegear zu meinen Homematic Heizkörperthermostaten (die werden mir im Terminal auch angezeigt), NodeRed zeigt mir auch eine Verbindung an, jedoch kann werden gar keine Veränderung mehr durchgeführt werden. Habe den Pfad meines CUL Sticks geprüft. Hier ist alles richtig eingestellt.
Habt jemand eventuell Erfahrung damit und weiß woran es liegen könnte?

Vielen Dank für die Hilfe.
Grüße
Miguel


#2

Was meinst du mit “werden gar keine Veränderung mehr durchgeführt”? Meinst du aus node-red heraus per MQTT? Falls ja, dann schau mal, wie in node-red dein MQTT Node eingestellt ist. Ggf. sendet du nicht auf die Loopback (127.0.0.1), sondern auf eine feste IP, die sich durch Tausch des RPi geändert haben könnte.


#3

Hey ich sende wie du richtig sagtest über MQTT. Habe aber die Localhost adresse angegeben.
Habe ein bisschen rumgespielt und die Geräte neu angelernt. Das ging dann 2 min gut. Konnte wieder die Thermostate ansteuern. Nach den 2 Minuten kam aber wieder nichts an.
Anbei sende ich mal den Fehler mit. Da steht mittendrin no answer from Device. Aber laut Homegear ist die Verbindung unter FS 0 und ls vorhanden

(Integer) 4 (String) BOOST_MODE (Boolean) 1 01/03/19 20:13:55.894 Module HomeMatic BidCoS: Debug: BOOST_MODE of peer 2 with serial number OEQ1877617:4 was set to 01. 01/03/19 20:13:55.895 Info: MQTT RPC call received. Method: setValue 01/03/19 20:13:55.896 RPC Server (Port 2001): Info: RPC Method called: setValue Parameters: (Integer) 1 (Integer) 4 (String) BOOST_MODE (Boolean) 1 01/03/19 20:13:55.896 Module HomeMatic BidCoS: CUL "My-CUL": Info: Sending (My-CUL): 0A04B011FD000163BC1C80 01/03/19 20:13:55.897 Module HomeMatic BidCoS: Debug: BOOST_MODE of peer 1 with serial number OEQ1877634:4 was set to 01. 01/03/19 20:13:55.898 Module HomeMatic BidCoS: CUL "My-CUL": Info: Sending (My-CUL): 0A0BB011FD000163BC0D80 01/03/19 20:13:56.456 Module HomeMatic BidCoS: CUL "My-CUL": Info: Sending (My-CUL): 0A04B011FD000163BC1C80 01/03/19 20:13:56.458 Module HomeMatic BidCoS: CUL "My-CUL": Info: Sending (My-CUL): 0A0BB011FD000163BC0D80 01/03/19 20:13:57.016 Module HomeMatic BidCoS: CUL "My-CUL": Info: Sending (My-CUL): 0A04B011FD000163BC1C80 01/03/19 20:13:57.018 Module HomeMatic BidCoS: CUL "My-CUL": Info: Sending (My-CUL): 0A0BB011FD000163BC0D80 01/03/19 20:13:58.450 RPC Server (Port 2001): Response: (Struct length=2) { [faultCode] { (Integer) -100 } [faultString] { (String) No answer from device. } } 01/03/19 20:13:58.452 RPC Server (Port 2001): Response: (Struct length=2) { [faultCode] { (Integer) -100 } [faultString] { (String) No answer from device. } } 01/03/19 20:13:58.900 Module HomeMatic BidCoS: Debug: Deleting queue 47 for BidCoS peer with address 0x63BC1C 01/03/19 20:13:58.901 Module HomeMatic BidCoS: Info: Setting peer to unreachable, because the queue processing was interrupted. 01/03/19 20:13:59.001 Module HomeMatic BidCoS: Debug: Deleting queue 48 for BidCoS peer with address 0x63BC0D 01/03/19 20:13:59.001 Module HomeMatic BidCoS: Info: Setting peer to unreachable, because the queue processing was interrupted.


#4

Kurze Frage: Du hast, bevor du “umgezogen” bist, das System komplett geupdatet?
Hast du evtl vergessen das homegear-Release von jessie auf stretch umzustellen?

Poste bitte mal die ausgaben von cat /etc/issue und cat /etc/apt/sources.list.d/homegear.list.

Hast du schon mal auf einer neuen SD-Karte eine neue Installation versucht? Einfach dort die homegear-Daten aus /etc/homegear/ udn /var/lib/homegear einspielen…


#5

Hey,
ich habe Stretch schon vorher installiert gehabt.

Unter etc/issue/ habe ich das stehen
Raspbian GNU/Linux 9 \n \l

Unter /etc/apt/sources.list.d/homegear.list
deb https://apt.homegear.eu/Raspbian/ stretch/ deb https://apt.homegear.eu/Raspbian/ stretch/

Neu aufgespielt habe ich es nicht. Wollte dies wirklich nur als letzte Möglichkeit machen.

Was mich halt wundert ist, dass wenn ich die neu anlerne es 2 Minuten gut geht und dann ist nichts mehr möglich und Homegear zeigt die trotzdem an.


#6

Mich auch…

apt update && apt full-upgrade hast du ja sicher gemacht. Führ außerdem mal rpi-update aus um die Firmware zu updaten: https://github.com/Hexxeh/rpi-update
Danach reboot und noch mal testen.


#7

Habs getestet
Hab auch nochmal geschaut. wenn ich den Pi neustarte kann ich direkt die Thermostate steuern aber nach weniger Zeit gehts dann halt nicht mehr. Das ist wie verhext.

Habe mal getrackt was in die Log geschrieben wird wenn ich ein Befehl ausführe. Das hier kommt da raus.

    01/04/19 20:57:38.613 Module HomeMatic BidCoS: Debug: BOOST_MODE of peer 1 with serial number OEQ1877634:4 was set to 01.
01/04/19 20:57:38.613 Module HomeMatic BidCoS: CUL "My-CUL": Warning: !!!Not!!! sending packet, because device is not connected or opened: 0A3BB011FD000163BC0D80
01/04/19 20:57:41.166 RPC Server (Port 2001): Response: 
(Struct length=2)
{
  [faultCode]
  {
    (Integer) -100
  }
  [faultString]
  {
    (String) No answer from device.
  }
}
01/04/19 20:57:41.167 RPC Server (Port 2001): Response: 
(Struct length=2)
{
  [faultCode]
  {
    (Integer) -100
  }
  [faultString]
  {
    (String) No answer from device.
  }
}
01/04/19 20:57:41.616 Module HomeMatic BidCoS: Debug: Deleting queue 2 for BidCoS peer with address 0x63BC1C
01/04/19 20:57:41.616 Module HomeMatic BidCoS: Info: Setting peer to unreachable, because the queue processing was interrupted.
01/04/19 20:57:41.716 Module HomeMatic BidCoS: Debug: Deleting queue 3 for BidCoS peer with address 0x63BC0D
01/04/19 20:57:41.716 Module HomeMatic BidCoS: Info: Setting peer to unreachable, because the queue processing was interrupted.
01/04/19 20:57:49.342 Debug: MQTT packet received: D000
01/04/19 20:57:49.342 MQTT Client: Debug: Packet received: D000
01/04/19 20:57:49.342 MQTT Client: Debug: Received ping response.

#8

Ok, wenn auch das rpi-update nichts bringt, muss @sathya helfen.


#10

Hast du mal versucht, die Karte nochmal im alten Raspberry Pi 3 zu benutzen? Ist der Effekt dann weg?


#11

Tatsächlich noch nicht.
Habe Homegear mal neuinstalliert und tada es funktioniert. Aber nur wenn ich ein Thermostat gekoppelt habe. Wenn das zweite dazu kommt ist der Fehler von oben wieder da :smiley:


#12

rpi-update gemacht?


#13

Könntest du das mal probieren? Es bringt ja nichts, in der Konfiguration rumzufummeln, wenn der Fehler ganz woanders liegt.