Missing channel 2 of HM-PB-2-WM55-2


#1

Hi everyone, I’m having trouble with my HM-PB-2-WM55-2, I am only able to receive commands from half of the switch.

First some of the backstory and setup, I was using FHEM untill now but decided to switch over to OpenHab2 (installed using Openhabian) and Homegear for various reasons. I am currently running both setups by changing the SD-card because I was not able to implement all functionality I need in OpenHab yet. Both FHEM and Homegear use the same rfKey and centralAddress and I am able to switch my devices using both setups. I use a HM-CFG-LAN for communication, and my lanKey is disabled (I think FHEM still has problems with that, I’ll probably activate it once I permanently switched to OpenHab).

For already paired devices to be recognized by Homegear I used the peers add ... command with the values from my FHEM setup and DEVICETYPE from the files under /etc/homegear/devices/0. So for example the command for the switch was this: peers add 00C2 25**** LEQ00***** 14
When looking at /var/log/homegear/homegear.log I am able to see the commands and the upper side/on side works as expected, but the lower side/off side produces this error:
02/15/19 14:46:57.398 Module HomeMatic BidCoS: Unknown channel in getParameterSet: 2

The channel 2 is also missing in OpenHab, generally there were a lot more Keys at some point (eg. the one for continual press or the long press release), but I don’t know why they went missing.

Here in the FHEM config there are also two channels, one for the upper and one for the lower side:

define Schalter1 CUL_HM 25****
attr Schalter1 .devInfo 020000
attr Schalter1 .stc 40
attr Schalter1 IODev HMLAN1
attr Schalter1 autoReadReg 4_reqStatus
attr Schalter1 expert 2_full
attr Schalter1 firmware 1.4
attr Schalter1 model HM-PB-2-WM55-2
attr Schalter1 room 11.0_System
attr Schalter1 serialNr LEQ00*****
attr Schalter1 subType pushButton
attr Schalter1 webCmd getConfig

define Schalter1_Btn_01 CUL_HM 25****01
attr Schalter1_Btn_01 expert 1
attr Schalter1_Btn_01 model HM-PB-2-WM55-2
attr Schalter1_Btn_01 peerIDs 00000000,
attr Schalter1_Btn_01 room 11.0_System

define Schalter1_Btn_02 CUL_HM 25****02
attr Schalter1_Btn_02 expert 1
attr Schalter1_Btn_02 model HM-PB-2-WM55-2
attr Schalter1_Btn_02 peerIDs 00000000,
attr Schalter1_Btn_02 room 11.0_System

I also looked at /etc/homegear/devices/0/rf_pb-2-wm55_ge_v1_4.xml where it is defined and in the file I wasn’t able to find anything regarding the channel 2, channel 0 and 1 are listed. Is it possible that I somehow got a wrong version of this file? Is there a way to check/update?

I don’t want to pair every device again if I don’t absolutely have to since that would mean a lot of work, I also wan’t to know where this problem came from and if other devices are affected as well and I just didn’t realize it yet.

I hope you are able to help me, thank you in advance! Also, I will only be able to respond after the weekend, sorry for that!


#2

First of all, you should check if Homegear receives the events of the second channel. If Homegear receives them, the problem is between Homegear and openHAB.

Then you should look into the openHAB log, if you find some “Channel not found for datapoint” messages. If that is the case, you should restart openHAB and perhaps remove the HM-PB-2 thing and let openHAB rediscover. Maybe try this: https://community.openhab.org/t/cleaning-up-the-startup-process-renaming-rules-windows-possible/38438

If Homegear does not receive the event, you need to look for something completely different.


#3

Does that answer your question? Looks like events are received by Homegear and not processed correctly, but I don’t know why.


#4

Dear Gurus, no ideas? I’m still having this problem.

Does anyone use this exact switch with homegear and can share how it looks for them?


#5

No, I have no idea. I use plenty of them with currently 0.8.8-2514 and everything is fine with both buttons.

Maybe you could re-pair the Pushbutton to Homegear in order to check if your adding process was wrong.


#6

Hi @job, thank you for your help! I tried to remove and pair it again but still have some problems. I did everything in the Homegear CLI.

I tried to remove it with pup 5 and prm 5 (I don’t know if unpair should remove it from the list, it didn’t for me). I then used pon and was able to pair it after some tries and a look in the manual (just pressing the pair-button unfortunately isn’t enough…).

Now it shows up in the list (pl) again, but it still has the Config Pendig flag set. In the log I’m also able to see the 2nd channel now, but I still get the INSTALL_TEST message on both channels, also the light quickly blinks in orange for a few times after I press any button with the followind log output:

02/25/19 15:05:01.268 HomeMatic BidCoS packet received (My-HM-CFG-LAN, RSSI: -70 dBm): 0B0AA24025EC2F26EAA*****
02/25/19 15:05:01.271 Module HomeMatic BidCoS: Info: INSTALL_TEST on channel 2 of HomeMatic BidCoS peer 7 with serial number LEQ00***** was set to 0x03.
02/25/19 15:05:01.272 Module HomeMatic BidCoS: Info: PRESS_SHORT on channel 2 of HomeMatic BidCoS peer 7 with serial number LEQ00***** was set to 0x03.
02/25/19 15:05:01.387 Module HomeMatic BidCoS: LAN-Konfigurationsadapter "My-HM-CFG-LAN": Info: Sending (My-HM-CFG-LAN): 0B03A00426EAA225EC2*****
02/25/19 15:05:02.230 Module HomeMatic BidCoS: LAN-Konfigurationsadapter "My-HM-CFG-LAN": Info: No response to packet after 3 tries: 1903A00426EAA225EC2F7E8C177C2E521F50CF8B50FB94F*****

I was able to add the switch to OpenHab, but I still have problems there too. The second channel and most of the keys still don’t show up and the device got the same ID as before when I added it again. I think this is caused by the pairing problems, so I’ll ignore it for now.

Edit: I tried to unpair and pair it a secound time an hour later (INSTALL_TEST flag was still set), same result.


#7

I’ve also compared the infos from the paired device with the ones from the peers add command that I used, the information is identical to the one I used, so I still have no idea why the 2nd channel works now but didn’t before. Some type of missing auto-discovery maybe?

It would be great if one of the devs that know the pairing more in depth could tell us what happens here.


#8

I am still having this problems, can anyone help?