Kein Signal vom nanoCUL an homegear - wie debuggen?

#1

Hallo zusammen,

um mein Smart Home etwas zu erweitern habe ich mir vor kurzem einen nanoCUL868 zugelegt, um damit im ersten Schritt über homegear MAX! Geräte zu steuern. Leider bin ich nach langem rumprobieren noch nicht so weit gekommen, dass in den Log-Files auch nur ein Pairing-Versuch meiner Testgeräte angezeigt wird.
log
04/29/19 04:44:33.522 Starting IPC server…
04/29/19 04:44:33.527 Startup complete. Waiting for physical interfaces to connect.
04/29/19 04:44:33.527 Info: Waiting for physical interfaces to connect (0 of 180s).
04/29/19 04:44:33.527 All physical interfaces are connected now.
04/29/19 04:44:33.527 Starting UPnP server…
04/29/19 04:44:33.528 Info: UPnP server: Binding to address: 192.168.178.20
04/29/19 04:44:33.528 UPnP Server: Info: Started listening.

cul.cfg

id = cul868
default = true
deviceType = cul
device = /dev/cul868
responseDelay = 40

Ich hoffe, ihr könnt mir helfen, die Situation zu debuggen, sodass ich meinen Raspberry dazu bekomme, mit meinem Thermostat zu reden. Habt ihr Ideen, wie man die Kommunikation über den nanoCUL am besten debuggt? Wie verifiziere ich am besten die grundsätzliche Funktionalität des Sticks?

Vielen Dank und viele Grüße
goddib

#2

Hey @goddib,

zeig mal bitte alle einkommentieren Zeilen deiner max.conf. Speziell den Teile mit [] am Beginn des Blocks für den CUL.
Hast du in der Homegear Konsole (sudo homegear -r) mit ls Max als Familie gelistet?

Zeig mal ein Foto deines CUL’s, welche Firmware ist da drauf?

Gruß,
p

#3

Heyho @pmayer,

Max ist als Familie gelistet - neben Miscellanous als einziges, da ich alles andere erst mal deaktiviert habe um zu testen.

max.cfg

___________________________________________________________________________

---------------------------------- MAX!  ----------------------------------
___________________________________________________________________________

#######################################
########## General Settings  ##########
#######################################

[General]

moduleEnabled = true

## The MAX! address of Homegear. It is recommended to change this to a random 3 byte hexadecimal
## value starting with 0xFD (e. g. 0xFD43AB). Only change this, when no MAX! devices
## are paired to Homegear as existing pairings will not work anymore!
#centralAddress = 0xFD0001
centralAddress = 0xFDF22E

#######################################
################# CUL #################
#######################################

## The device family this interface is for
#[CUL]

## Specify an unique id here to identify this device in Homegear
id = cul868

## When default is set to "true" Homegear will assign this device
## to new peers.
default = true

## Options: cul, coc, cc1100
deviceType = cul

device = /dev/cul868

## Should be "40" for MAX!
responseDelay = 40

Der Rest ist komplett auskommentiert. Mein CUL ist gekauft, das CC1101 Modul ist mi 868 Mhz beschriftet. Momentan habe ich culfw 1.67 drauf.

Zum Testen ist mir nur eingefallen, ein paar 433 Mhz Intertechno Steckdosen damit zu schalten, was funktioniert. Auch beim Empfang mit X zeigt minicom etwas an, aber nichts, was ich entschlüsseln kann.

Welche Tests kann ich hier noch machen?

Viele Grüße
goddib

#4

P.S.: Sehe ich das richtig, dass man “[CUL]” ebenfalls einkommentieren muss? Das habe ich jetzt geändert und nun scheine ich Geräte zu empfangen *facepalm* :roll_eyes:

Danke für deine Hilfe!

#5

Ja :wink: Deswegen hatte ich genau danach gefragt.

Aber super, dass es jetzt funktioniert :+1: