Installing Raspbian/buster 0.7 stable contains 0.8 alpha also


first of all many thanks to the homegear-project. What an amazing work. I use it for HUE and MAX!
Absolutely noncritical software, runs on low hardware, very very fast. I like it!
Here is my problem:
i tried(many times, maybe one week) to reinstall homegear with modules on my raspberrypiw.
Fresh install with raspberry Pi OS buster, updated everything with apt update/update dist-upgrade.

Next step was to install instructions as shown on

Install went trough, no problems at all, but version 08.3101 alpha was installed
Checked website:

yes, there are also the 08-alpha files
Is this normal or what can i do to install 07.48-3324(actual stable version)

I am a little bit lost

I tried to install Raspbian Image, but i cannot get WLAN to work and the raspberryw has no Ethernet.


Hey Andy,

welcome to the forum. This must be answered from @sathya or maybe @Sim can say something about this?


bavaria, are you german?
I don’t have a clue. If you reinstall todays nightly it should run quite nicely.
Could you give us a dpkg -l | grep homegear, just to check?

1 Like

If you try to install stable on rasbian buster via the apt repository, it installs 0.8.0-3101 and not 0.7.x.
Either this is intended, or somehow the nightly got pushed into the stable apt repository.

yes i am from bavaria.
Now i have installed the nightly and it works fine after the backup via admin-ui.
I do not know the reason why the nightly was pushed into the stable apt repository

The connection with openhab is also working fine, so no reason for me to dig deeper into this.

Have a good time and stay healthy!

1 Like

This issue should be fixed within the next nightly. It was caused by adding a nightly repository.
Andy, wenn dir englisch lieber ist, darfst du natürlich auch im englischen Forum schreiben :grin: