Homematic Pairing & Using


#1

Hi, I’m too new here and I want to use some homematic devices with opeanhab 2 and raspberry pi 3 model b+.

I installed openhabian to raspberry pi and I installed homematic bindings with homegear (homematic bidcos - homematic wired) to openhabian.

So, I want get help after this. What should I do for pairing with my homematic devices and how do I use them?
And my devices are HM-CFG-LAN, HM-Sec-MDIR-2, HM-Sec-SC-2.

Screenshot_2

Thanks.


#2

Have a look here:

https://doc.homegear.eu/data/homegear-homematicbidcos/adding_devices.html


#3

It doesn’t pairing. How do I fix?

Screenshot_5


#4

Hm. Did you configure the homematicbidcos.conf according to the documenation?
https://doc.homegear.eu/data/homegear-homematicbidcos/configuration.html

What communication module are you using?


#5

I changed centralAddress as 0xFDD394, #host as my device ip and #lanKey as my device aes key but I haven’t chanced rfKey. id = My-HM-CFG-LAN

I’m using HomeMatic LAN Configuration Adapter (HM-CFG-LAN) communication module.


#6

Have you checked the logs (/var/log/homegear/homegear.log) at startup of homegear? Is there All physical devices are connected now printed?

Could you show the relevant configuration file parts?


#7

Yes I checked logs and it printed and I sent my config.


#8

(from pm)

[General]
The BidCoS address of Homegear. It is recommended to change this to a random 3 byte hexadecimal
value starting with 0xFD (e. g. 0xFD43AB). Only change this, when no HomeMatic BidCoS devices
are paired to Homegear as existing pairings will not work anymore!

#centralAddress = 0xFDD394
Specify a 16 byte (32 characters) long AES key here to protect your wireless communication
!!! IMPORTANT: It is highly recommended to change this key before pairing the first device.
!!! IMPORTANT: Never ever lose this key. That would render your devices useless.
To remove the key from your devices, you need to factory reset them using Homegear. The factory
reset on the device is not possible!!!

rfKey = 00112233445566778899AABBCCDDEEFF

Please make yourself familar on how to edit config files. You have to “comment in” the centralAddress to make homegear recognize it - remove the # in front of the line.

ALSO please read the config. Don’t use the example rfKey as this has security liabilities.

This also applies for the communication module:

#######################################
############# HM-CFG-LAN #############
#######################################
The device family this interface is for

#[HM-CFG-LAN]
Specify an unique id here to identify this device in Homegear

#id = My-HM-CFG-LAN
When default is set to “true” Homegear will assign this device
to new peers.

#default = true
Options: cul, cc1100, coc, cunx, hmcfglan, hmlgw, hm-mod-rpi-pcb, homegeargateway

#deviceType = hmcfglan
IP address of your HM-CFG-LAN

#host = 192.168.1.222
Port number your HM-CFG-LAN listens on. Normally 1000.

#port = 1000
Put the AES key printed on your HM-CFG-LAN here

#lanKey = A[...]3
Default: responseDelay = 95
Should be “95” for CUL or COC, “100” for TI CC1101 and “60” for HM-CFG-LAN or HM-LGW

#responseDelay = 60

You have to comment in the corresponding lines. Currently you don’t have any device configured.
Don’t forget to comment in the section (#[HM-CFG-LAN]).
After that, restart homegear with sudo service homegear restart and check the logs afterwards.


#9





Hi again, I edited config files as you told.
And these my logs. What’s next :confused:


#10

Hey @Tiffl3r,

could you please post the homematicbidcos.conf after you edited ist? Please only the relevant parts via copy & paste.


#11
---------------------------- HomeMatic BidCoS  ----------------------------
___________________________________________________________________________

[General]

moduleEnabled = true

#######################################
########## General Settings  ##########
#######################################

[General]

The BidCoS address of Homegear. It is recommended to change this to a random 3 $
value starting with 0xFD (e. g. 0xFD43AB). Only change this, when no HomeMatic $
are paired to Homegear as existing pairings will not work anymore!

centralAddress = 0xFDD394
Specify a 16 byte (32 characters) long AES key here to protect your wireless communication
!!! IMPORTANT: It is highly recommended to change this key before pairing the first device.
!!! IMPORTANT: Never ever lose this key. That would render your devices useless.
To remove the key from your devices, you need to factory reset them using Homegear. The factory
reset on the device is not possible!!!
rfKey =11447788552233669900QWERTYUIOPAS

## With each key change currentRFKeyIndex needs to be
## incremented by 1
currentRfKeyIndex = 1

## When you change rfKey, put the old key here. To change the key Homegear needs to know the
## old and the new one.
## !!! Do not set oldRFKey when you set rfKey for the first time !!!
##oldRfKey = 00112233445566778899AABBCCDDEEFF

## When set to "true" unsigned broadcast packets are processed by Homegear. This could enable an
## attacker to make Homegear do things, you don't want. That means, this option is a security
## risk.
processBroadcastWithAesEnabled = false

...

#######################################
############# HM-CFG-LAN #############
#######################################
## The device family this interface is for

[HM-CFG-LAN]
## Specify an unique id here to identify this device in Homegear

id = L...0
## When default is set to “true” Homegear will assign this device
## to new peers.
#default = true

## Options: cul, cc1100, coc, cunx, hmcfglan, hmlgw, hm-mod-rpi-pcb, homegeargateway
deviceType = hmcfglan

## IP address of your HM-CFG-LAN
host = 192.168.1.222

## Port number your HM-CFG-LAN listens on. Normally 1000.
port = 1000

## Put the AES key printed on your HM-CFG-LAN here
lanKey = A...3

## Default: responseDelay = 95
## Should be “95” for CUL or COC, “100” for TI CC1101 and “60” for HM-CFG-LAN or HM-LGW
responseDelay = 60

#12

Looks good, have you tried pair a device again?

https://doc.homegear.eu/data/homegear-homematicbidcos/adding_devices.html


#13

Yeah, a couple of times but I don’t know why it doesn’t work.


#14

Hmm… All physicla devcies are connected now is still missing. Could you doublecheck your settings? (IP, etc.)

And maybe change the debuglevel to 4 in main.conf


#15

I checked but it’s look normal. And debuglevel already seem 4.
Maybe device was corrupt, who knows.

Thanks anyway.


#16

Hi @Tiffl3r

should be easy enough to solve. If it’s still relevant, could you post a log of the pairing process? (You can also copy the text content here - it’s easier to read than the screenshots.) Also is the rfKey your real one? Only letters from A to F and numbers from 0 to 9 are allowed (those are hexadecimal numbers). There should have been an error message in the log. I fixed that now.

Cheers,

Sathya