Homematic IP verbindet nicht

Hi an alle,

ich bin mal wieder ein neuer Nutzer, der zu doof ist, einen nano CUL USB Stick zum laufen zu bringen.
Wer kann mir weiter helfen? Googlen und Forum durchlesen bringt mich nicht mehr weiter.

Meine homematicbidcos.conf:
__________________________________________________________________________

---------------------------- HomeMatic BidCoS  ----------------------------
___________________________________________________________________________

#######################################
########## General Settings  ##########
#######################################

[General]

moduleEnabled = true

## The BidCoS address of Homegear. It is recommended to change this to a random 3 byte hexadecimal
## value starting with 0xFD (e. g. 0xFD43AB). Only change this, when no HomeMatic BidCoS devices
## are paired to Homegear as existing pairings will not work anymore!
centralAddress = 0xFDC0FE

## Specify a 16 byte (32 characters) long AES key here to protect your wireless communication
## It must only consist of the characters A to F and the numbers 0 to 9 as it is hexadecimal.
## !!! IMPORTANT: It is highly recommended to change this key before pairing the first device.
## !!! IMPORTANT: Never ever lose this key. That would render your devices useless.
## To remove the key from your devices, you need to factory reset them using Homegear. The factory
## reset on the device is not possible!!!
rfKey = 00112233445566778899AABBCCDDEEFF

## With each key change currentRFKeyIndex needs to be
## incremented by 1
currentRfKeyIndex = 1

## When you change rfKey, put the old key here. To change the key Homegear needs to know the
## old and the new one.
## !!! Do not set oldRFKey when you set rfKey for the first time !!!
##oldRfKey = 00112233445566778899AABBCCDDEEFF

## When set to "true" unsigned broadcast packets are processed by Homegear. This could enable an
## attacker to make Homegear do things, you don't want. That means, this option is a security
## risk.
processBroadcastWithAesEnabled = true

#######################################
################# CUL #################
#######################################

## The device family this interface is for
[CUL]

## Specify an unique id here to identify this device in Homegear
id = USB-CUL

## When default is set to "true" Homegear will assign this device
## to new peers.
default = true

## Options: cul, cc1100, coc, cunx, hmcfglan, hmlgw, hm-mod-rpi-pcb, homegeargateway
deviceType = cul

device = /dev/ttyUSB0

## Default: responseDelay = 95
## Should be "95" for CUL or COC, "100" for TI CC1101 and "60" for HM-CFG-LAN or HM-LGW
responseDelay = 95

Ich kann mich als root user auf dem Raspberry Pi 4 mit raspbian minimal durch “homegear -r” “verbinden”.
dl 10
fs 0
pon
ls

liefert auch nach öfteren Versuchen eine leere Liste. Ich versuche ein Homematic WTH-2 zu verbinden. Das Geräte habe ich gelötet und noch nicht gepaired bekommen. Auch Werkseinstellungen herstellen hilft nicht zum Erfolg.

Der Log vom Pairing:

01/08/21 07:17:24.094 IPC Server: Info: Client 1 successfully registered RPC method “cliOutput” (this > method is registered by 1 client(s)).
01/08/21 07:17:24.095 IPC Server: Info: Client 1 successfully registered RPC method “cliOutput-1” (this method is registered by 1 client(s)).
01/08/21 07:17:25.737 IPC Server: Response:
(String) Debug level set to 10.

01/08/21 07:17:28.928 IPC Server: Info: Client number 1 is calling RPC method: familyExists Parameters:
(Integer64) 0
01/08/21 07:17:28.928 IPC Server: Response:
(Boolean) 1
01/08/21 07:17:32.447 IPC Server: Info: Client number 1 is calling RPC method: cliFamilyCommand
(Integer64) 0
(String) pon
01/08/21 07:17:32.447 IPC Server: Debug: CLI client 1 is executing family command: pon
01/08/21 07:17:32.448 IPC Server: Response:
(String) Pairing mode enabled for 60 seconds.

01/08/21 07:17:39.429 Module HomeMatic BidCoS: Info: 01/08/21 07:17:39.429 Packet received (USB-CUL, RSSI: -73 dBm): 2001008F1C3848F0000140542CDB9C8A75F52A0001000001290206000300030702
01/08/21 07:17:44.384 IPC Server: Info: Client number 1 is calling RPC method: cliFamilyCommand
(Integer64) 0
(String) ls
01/08/21 07:17:44.384 IPC Server: Debug: CLI client 1 is executing family command: ls
01/08/21 07:17:44.385 IPC Server: Response:
(String) No peers are paired to this central.

01/08/21 07:17:57.888 IPC Server: Info: Client number 1 is calling RPC method: cliFamilyCommand
(Integer64) 0
(String) ls
01/08/21 07:17:57.888 IPC Server: Debug: CLI client 1 is executing family command: ls
01/08/21 07:17:57.889 IPC Server: Response:
(String) No peers are paired to this central.

01/08/21 07:18:05.792 IPC Server: Info: Client number 1 is calling RPC method: cliFamilyCommand
(Integer64) 0
(String) pof
01/08/21 07:18:05.793 IPC Server: Debug: CLI client 1 is executing family command: pof
01/08/21 07:18:05.960 IPC Server: Response:
(String) Pairing mode disabled.

01/08/21 07:18:07.704 IPC Server: Info: Client number 1 is calling RPC method: cliFamilyCommand
(Integer64) 0
(String) ls
01/08/21 07:18:07.704 IPC Server: Debug: CLI client 1 is executing family command: ls
01/08/21 07:18:07.704 IPC Server: Response:
(String) No peers are paired to this central.

01/08/21 07:18:09.608 IPC Server: Info: Client number 1 is calling RPC method: cliFamilyCommand
(Integer64) 0
(String) pon
01/08/21 07:18:09.608 IPC Server: Debug: CLI client 1 is executing family command: pon
01/08/21 07:18:09.609 IPC Server: Response:
(String) Pairing mode enabled for 60 seconds.

01/08/21 07:18:16.064 UPnP Server: Debug: Sending notify packets.
01/08/21 07:18:16.064 UPnP Server: Debug: Sending notify packets.
01/08/21 07:18:20.705 IPC Server: Info: Client number 0 is calling RPC method: lifetick Parameters:
01/08/21 07:18:20.705 IPC Server: Response:

Es scheint also eine Kommunikation möglich zu sein (Es wird mindestens etwas empfangen).
Die Geräte sind bei den Versuchen zwischen 20 cm und 1 Meter auseinander gewesen.

Sehr interessant ist, dass ich mit “minicom -b 38400 -D /dev/ttyUSB0” und einer Eingabe “V” kein Feedback erhalte.
Baudrate habe ich vom Modul beigelegten Zettel entnommen. Da wird auch behauptet, dass culfw V1.67 nanoCUL868 installiert ist.
Bei der Verbindung mit minicom leuchtet nur die Power LED des Arduino. Ist homegear am laufen, leuchtet LED4; TX und RX Led bleiben aus.
Wer kann mir weiter helfen. Ich frustriere.

Schon jetzt vielen Dank für das Erschaffen von Homegear, das Forum und den hier geleisteten Support.
Danke,

Fabian

Das liegt ganz einfach daran, dass HomematicIP kein BidCos ist und demzufolge nicht direkt mit Homegear funktioniert.

Da musst du dann über eine CCU gehen. Ich glaube auch, dass HmIP nur mit mit speziellen Funkmodulen von eq-3 geht.

2 Likes

Hey,

habe homeatic ip bei mir am laufen brauchst aber einen 2. Raspberry oder ähnliches der die ccu simuliert.

Raspberrymatic kannst dir mal anschauen. Dazu hab ich einen usb Stick von elv3 und dann lief es auch schon.

Gruß
Felix

Hallo zusammen,

auch mit Raspberrymatic wird es meines (aktuellen) Wissens nach aber auch nicht mit einem CUL funktionieren, man braucht (wie auch @job schon richtig angemerkt hat) den Funkchip von eQ-3.

– Micha

Ich mag die Firma immer mehr. Dieses “IP” eigenständig, als auch als Anhang ist einfach irritierend.
Danke für eure schnelle Hilfe. Dann installier ich mir mal oCCU oder CCU2 auf dem Raspbi und lass das mit dem HM-MOD-RPI-PCB laufen. In der Hoffnung, dass ich da was zum laufen bekomme. Homegear kann dann lediglich mit der CCU eine VErbindung aufbauen. Sehe ich das richtig?

Vll. wäre für Idioten wie mich ein fetter Hinweis in den docs toll, der explizit ansagt, dass kein Homematic IP unterstützt werden kann.

Hi @fabian727,

Homegear kann (derzeit) nur ueber den “Umweg” einer CCU (oder Derivat) Homematic IP Geraete steuern, das ist korrekt. Liegt einfach daran, dass das Protokoll nicht oeffentlich zugaenglich ist.

Von der “originalen” oCCU auf Github solltest du die Finger lassen … damit ist Frust vorprogrammiert. Nimm lieber Raspberrymatic, das funktioniert.

– Micha

1 Like