Homegear stopped working

#1

Hi
I have an installation of Homegear on Raspbian Stretch installation
It used to work fine but after a reboot, homegear is trying to start in a loop.
Here is the log:
03/19/19 22:24:40.115 Starting Homegear…

03/19/19 22:24:40.115 Homegear version 0.7.38-2757

03/19/19 22:24:40.115 Git commit SHA of libhomegear-base: -

03/19/19 22:24:40.116 Git branch of libhomegear-base: -

03/19/19 22:24:40.120 Git commit SHA of Homegear: -

03/19/19 22:24:40.121 Git branch of Homegear: -

03/19/19 22:24:40.130 Info: Setting allowed core file size to "4294967295" for user with id 0 and group with id 0.

03/19/19 22:24:40.130 Info: Core file size now is "4294967295".

03/19/19 22:24:40.130 Info: Setting maximum thread priority to "4294967295" for user with id 0 and group with id 0.

03/19/19 22:24:40.131 Info: Maximum thread priority now is "4294967295".

03/19/19 22:24:40.209 Info: Backing up database...

03/19/19 22:24:41.806 Initializing database...

03/19/19 22:24:41.877 Info: Loading family module (type 1) mod_max.so

03/19/19 22:24:42.015 Info: Loading settings from /etc/homegear/families/max.conf

03/19/19 22:24:42.031 Info: Loading family module (type 1) mod_miscellaneous.so

03/19/19 22:24:42.079 Info: Loading settings from /etc/homegear/families/miscellaneous.conf

03/19/19 22:24:42.081 Info: Setting up physical interfaces and GPIOs...

03/19/19 22:24:42.082 Info: Dropping privileges to user homegear (109) and group homegear (113)

03/19/19 22:24:42.090 Info: Homegear is (now) running as user with id 109 and group with id 113.

03/19/19 22:24:43.412 Starting script engine server...

03/19/19 22:24:44.074 Initializing licensing controller...

03/19/19 22:24:44.074 Loading licensing controller data...

03/19/19 22:24:44.075 Loading devices...

03/19/19 22:24:44.075 Loading XML RPC devices...

03/19/19 22:24:44.935 Loading device 1

03/19/19 22:24:44.936 Module MAX: Info: Central address set to 0xFD0E91.

03/19/19 22:24:44.951 Loading XML RPC devices...

03/19/19 22:24:44.983 Loading device 2

03/19/19 22:24:44.984 Initializing RPC client...

03/19/19 22:24:44.985 Starting MQTT client...

03/19/19 22:24:44.988 Starting XML RPC server FamilyRPCServer listening on ::1:2000...

03/19/19 22:24:45.090 MQTT Client: Info: Successfully connected to MQTT server using protocol version 4.

03/19/19 22:24:45.091 Info: Subscribing to topic homegear/climate/rpc/#

03/19/19 22:24:45.093 Info: Subscribing to topic homegear/climate/set/#

03/19/19 22:24:45.094 Info: Subscribing to topic homegear/climate/value/#

03/19/19 22:24:45.100 Info: MQTT RPC call received. Method: setValue

03/19/19 22:24:45.129 Info: MQTT RPC call received. Method: setValue

03/19/19 22:24:45.129 Info: MQTT RPC call received. Method: setValue

03/19/19 22:24:45.130 Info: MQTT RPC call received. Method: setValue

03/19/19 22:24:45.139 Info: MQTT RPC call received. Method: setValue

03/19/19 22:24:45.140 Info: Subscribing to topic homegear/climate/config/#

03/19/19 22:24:45.141 Signal 11 received.

03/19/19 22:24:52.743 Starting Homegear...

03/19/19 22:24:52.743 Homegear version 0.7.38-2757

03/19/19 22:24:52.743 Git commit SHA of libhomegear-base: -

03/19/19 22:24:52.744 Git branch of libhomegear-base: -

03/19/19 22:24:52.744 Git commit SHA of Homegear: -

03/19/19 22:24:52.744 Git branch of Homegear: -

03/19/19 22:24:52.751 Info: Setting allowed core file size to "4294967295" for user with id 0 and group with id 0.

03/19/19 22:24:52.752 Info: Core file size now is "4294967295".

03/19/19 22:24:52.752 Info: Setting maximum thread priority to "4294967295" for user with id 0 and group with id 0.

03/19/19 22:24:52.752 Info: Maximum thread priority now is "4294967295".

03/19/19 22:24:52.853 Info: Backing up database...

03/19/19 22:24:54.008 Initializing database...

03/19/19 22:24:54.081 Info: Loading family module (type 1) mod_max.so

03/19/19 22:24:54.186 Info: Loading settings from /etc/homegear/families/max.conf

03/19/19 22:24:54.199 Info: Loading family module (type 1) mod_miscellaneous.so

03/19/19 22:24:54.238 Info: Loading settings from /etc/homegear/families/miscellaneous.conf

03/19/19 22:24:54.246 Info: Setting up physical interfaces and GPIOs...

03/19/19 22:24:54.247 Info: Dropping privileges to user homegear (109) and group homegear (113)

03/19/19 22:24:54.249 Info: Homegear is (now) running as user with id 109 and group with id 113.

03/19/19 22:24:54.810 Starting script engine server...

03/19/19 22:24:55.096 Initializing licensing controller...

03/19/19 22:24:55.096 Loading licensing controller data...

03/19/19 22:24:55.096 Loading devices...

03/19/19 22:24:55.097 Loading XML RPC devices...

03/19/19 22:24:55.481 Loading device 1

03/19/19 22:24:55.482 Module MAX: Info: Central address set to 0xFD0E91.

03/19/19 22:24:55.486 Loading XML RPC devices...

03/19/19 22:24:55.496 Loading device 2

03/19/19 22:24:55.497 Initializing RPC client...

03/19/19 22:24:55.498 Starting MQTT client...

03/19/19 22:24:55.502 Starting XML RPC server FamilyRPCServer listening on ::1:2000...

03/19/19 22:24:55.610 MQTT Client: Info: Successfully connected to MQTT server using protocol version 4.

03/19/19 22:24:55.611 Info: Subscribing to topic homegear/climate/rpc/#

03/19/19 22:24:55.613 Info: Subscribing to topic homegear/climate/set/#

03/19/19 22:24:55.615 Info: Subscribing to topic homegear/climate/value/#

03/19/19 22:24:55.618 Info: MQTT RPC call received. Method: setValue

03/19/19 22:24:55.620 Info: MQTT RPC call received. Method: setValue

03/19/19 22:24:55.621 Info: MQTT RPC call received. Method: setValue

03/19/19 22:24:55.622 Info: MQTT RPC call received. Method: setValue

03/19/19 22:24:55.623 Info: MQTT RPC call received. Method: setValue

03/19/19 22:24:55.624 Info: Subscribing to topic homegear/climate/config/#

03/19/19 22:24:55.624 Signal 11 received.

I tried a brand new install and the same happens
But when I desactivate mqtt in the mqtt.conf file, it works
here is the mqtt.conf file:

# mqtt.conf
#
# MQTT settings.
#

# Set this to "true" to enable MQTT.
# Default: false
enabled = true

# Hostname or IP address of your MQTT message broker.
brokerHostname = 192.168.1.100

# Port of your MQTT message broker.
brokerPort = 1883

# Name of this client.
clientName = Homegear

# The prefix to use. Every topic starts with this prefix.
# Default: homegear
prefix = homegear

# Unique ID of this Homegear instance. Change this, have you have multiple
# Homegear installations.
# This is not used for IBM Bluemix Watson IOT platform
homegearId = climate

# Tells the MQTT server to retain received MQTT messages. New clients will then
# receive the last value of a topic on connection.
# Variables of type "Action" are not retained.
retain = true

# When authentication by username and password is enabled, uncomment the following two lines and fill in your username
# and password.
#username = myUser
#password = myPassword

# The number of parallel processing threads.
processingThreadCount = 5

### Topic payload encodings ###

# Enable topic: homegear/HOMEGEAR_ID/plain/PEERID/CHANNEL/VARIABLE_NAME
# Contains the value as is. E. g.: 43.7.
plainTopic = true

# Enable topic: homegear/HOMEGEAR_ID/json/PEERID/CHANNEL/VARIABLE_NAME
# Puts the value in a JSON array to be JSON-compliant: [43.7].
jsonTopic = false

# Enable topic: homegear/HOMEGEAR_ID/jsonobj/PEERID/CHANNEL/VARIABLE_NAME
# Puts the value into a JSON object. The key is value: { "value": 43.7 }.
jsonobjTopic = false


### TLS options ###

# Set to "true" to enable SSL encryption for MQTT.
enableSSL = false

# The path to the certificate authority's certificate
#caFile = /path/to/ca-certficate

# verifyCertificate checks if the server certificate received by the
# MQTT broker is signed by one of the root CAs in /etc/ssl/certs. If you use
# a self signed certificate, please put your root certificate in that
# directory. Only disable the verification for testing purposes. Without
# verification any attacker can pose as your MQTT broker.
# Default: verifyCertificate = true
#verifyCertificate = true

# The path to the PEM encoded client certificate.
#certPath = /etc/homegear/mqtt.crt

# The path to the PEM encoded client keyfile.
#keyPath = /etc/homegear/mqtt.key


### IBM Bluemix Watson IOT platform settings ###

# Uses bmx*, retain, processingThreadCount and TLS settings, all others are skipped. Please note that it was tested without TLS encryption only.
# bmxTopix enables IBM Bluemix adapter and blocks all other topic types as IBM Bluemix Watson IOT Platform disconnects when unsupported packet types appear
#bmxTopic = false

# For IBM Bluemix Watson IOT Platform use messaging.internetofthings.ibmcloud.com, do not add the <orgId> at the beginning
#bmxHostname=messaging.internetofthings.ibmcloud.com

# Port for MQTT broker
#bmxPort = 1883

# Set this to your orgId created in Bluemix
#bmxOrgId = orgId

# Set this to your gateway typeId created in Bluemix. This has to be created as "gateway type", not "device type"
#bmxGwTypeId = gwTypeId

# This sets the device ID for devices created by MQTT adapter in Bluemix. Requested device type is created automatically by IOT platform.
#bmxDevTypeId = devTypeId

# Should be set to "iot-2/type"
#bmxPrefix = iot-2/type

# Set to use-token-auth if using token authentication
#bmxUsername = use-token-auth

# Set to token generated for this gateway
#bmxToken = myBluemixToken

any idea? thanks!

MQTT commands not received
#2

also I notice that I can’t connect to my (flashed) Max! cube, where it was working perfectly before, without any change having been made? I don’t know what to do since the cube is reachable on the network, and I don’t see any error message in homegear??