Homegear admin kann m-bus Modul nicht permanent disablen

Hi

im admin interface:

|UI-Version|0.1.0-617-dev|
|Version|0.7.45-3101|

möchte ich das m-bus Modul disablen. im laufenden Betrieb funktioniert dies. Nach einem Reboot ist es wieder enabled.

Das homegear-management.err zeigt folgenden Error.

04/24/20 14:03:22.713 Could not connect to socket. Error: No such file or directory
sed: can't read /etc/homegear/families/mbus.conf: No such file or directory

Das m-bus File ist im Ordner wie folgt:

-rw-r--r-- 1 root root 829 Apr 24 13:30 m-bus.conf

cheers

paging @Micha

Hach, wieder ein config-File mit Bindestrich. Wird gefixt, danke für die Info!

– Micha

1 Like

Hi

da wir gerade dabei sind. Ich sehe den gleichen Effekt bei folgenden Files/Modulen:

-rw-r--r-- 1 root root      0 Apr 24 13:56 miscellaneous.conf
-rw-r--r-- 1 root root   2739 Apr 24 13:56 rs2w.conf
-rw-r--r-- 1 root root   1532 Apr 24 13:56 rsl.conf
-rw-r--r-- 1 root root    884 Apr 24 13:57 z-wave.conf
-rw-r--r-- 1 root root   1575 Apr 24 13:57 zigbee.conf

Ich erhalte keine log-error Meldungen beim disablen, denke aber, dass diese Files keinen Eintrag für moduleEnabled = false besitzen, der auf true oder false gesetzt werden kann und deshalb nur temporär disabled werden können.

danke

Hi @jipp,

fuer m-bus.conf hab ich eben die Aenderungen gepushed, die sollten im kommenden nightly dann drin sein. Wichtig ist, dass dafuer auch folgendes in der management.conf steht (PR hab ich eben auch schon erstellt):

settingsWhitelist = ^families/m\-bus.conf$ moduleEnabled

Auf die anderen von dir aufgefuehrten Module hab ich leider keinen (Source-)Zugriff, ich klaer das direkt mit Sathya :wink:

Miscellaneous sollte eigentlich auch nicht entladen werden (zumindest hat das bei mir immer massiv Probleme gemacht wenn das Modul nicht geladen war), daher muss ich erst noch mal testen ob das funktioniert.

– Micha