HM-SEC-SC-2 stopped working


I have a rpi with homegear 0.6.7 running, 9x HM-CC-RT-DN, 1x HM-LC-Sw4-WM, 1x HM-TC-IT-WM-W-EU, 1x HM-WDS30-OT2-SM-2 and 2x HM-Sec-SC-2. I have set an unique centralAddress (0xFD1337) and a rfKey from day one and have not changed it since; I’ve reset/unpaired thermostats in the past with no issue. Everything worked great for the last few months, up until earlier this week when one of the HM-Sec-SC-2 would not communicate its state any longer. I tried to remove its batteries but that didn’t help.

So I’ve tried to unpair (pup) and reset it (prs) - didn’t work. Then I removed it (prm) and hard-reset it (5 seconds + 5 seconds).

Now, when I remove and reinsert the batteries, I see:

01/12/17 11:40:39.979 HomeMatic BidCoS packet received (rpi-homematic-pcb, RSSI: -55 dBm): 0C008441404E420000000101C8
01/12/17 11:40:41.191 HomeMatic BidCoS packet received (rpi-homematic-pcb, RSSI: -53 dBm): 0D018610404E420000000601C80E

When I issue pon and push the learning button, I see:

01/12/17 11:41:58.560 HomeMatic BidCoS packet received (rpi-homematic-pcb, RSSI: -62 dBm): 1A028400404E420000002400B14D45513135393338303780810101
01/12/17 11:41:58.561 Module HomeMatic BidCoS: Info: Pushing pending queues.
01/12/17 11:41:58.655 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "rpi-homematic-pcb": Info: Sending (rpi-homematic-pcb): 1018A001FD1337404E4200050000000000
01/12/17 11:41:59.469 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "rpi-homematic-pcb": Info: No answer to packet 1018A001FD1337404E4200050000000000

It never pairs. When I pull the batteries and reinsert, this is shown when closing the window contact:

01/12/17 11:51:32.265 HomeMatic BidCoS packet received (rpi-homematic-pcb, RSSI: -65 dBm): 0C048441404E42000000010400

And this shows when opening:

01/12/17 11:51:37.013 HomeMatic BidCoS packet received (rpi-homematic-pcb, RSSI: -67 dBm): 0C058441404E420000000105C8

Is there some way to get this device to pair again?

Hi @infernix,

I had a similar issue with a HM-Sec-SCo of mine. After factory resetting the window contact, I could pair it again.
First pup, prs, prm as you did, then reset the device itself. See page 43 here:

If this won’t help, maybe @sathya could jump in.

As you don’t change the rfKey and the centrallAdress a repairing should be possible in any way.

For further information on pairing/unpairing AES-devices have a look at (sadly german). But the google translation seems viable:

so long,

That unfortunately doesn’t seem to work for me. To clarify my initial post, when I say i hard-reset it, I do mean hard resetting the window contact following the procedure outlined in the manual. So hold 5s > red flashes > release and hold 5s > rapid red flashes > 3s red light on release.

Und Deutsch ist kein problem, ich verstehe es meistens aber bin kein native speaker :slight_smile:

Das ist super!

But as we are in the english part of the forum and I’m happy to practice, let’s stay with that :slight_smile:

Hmm… that’s not good. I had to do it two or three times till it worked again. Of course this is not the answer you want to hear :wink:


Hello @infernix,

that only works if the default AES key is being used. That’s not the case here and is also indicated by the red light on release. You can only pair the window contact if you still know the AES key the device was paired with. If that’s the case,

  • stop Homegear,
  • move your databases (.sql.) away from /var/lib/homegear/,
  • set the AES key in homematicbidcos.conf.
  • You also need to set the old central address there, if you don’t know it, we can figure that one out.
  • Start Homegear,
  • pair the device - it should work now,
  • reset the device:
    • homegear -r
    • fs 0
    • ls
    • prs PEERID
  • Stop Homegear,
  • Restore your settings and databases.



Edit: Sorry, I haven’t read your complete post. Forget what I wrote as you didn’t change rfKey and centralAddress indeed the repairing should work. The reset on the device won’t work though. The device is not responding to packets from Homegear. Have you tried getting it close to your communication module? Did you try changing the batteries? If both doesn’t work, it seems the window contact is broken.

I just wanted to retry and it doesn’t even turn on anymore after pulling batteries, so I think it was on its deathbed and is now deceased. I guess I will have to try new batteries and if still dead, RMA it

It did reset correctly though:

Hold the teach button down for at least 5 seconds.
The sensor LED starts to flash slowly in
red. (If you want to abort the reset procedure at
this time, you can press the teach button briefly
again or wait 15 seconds. In either case, the
flashing red will stop.)
• To reset the sensor, press the teach button again
for at least 5 seconds. The LED starts to flash in
red faster while the button is held down.
• Releasing the button completes the reset
procedure. The LED is illuminated for approx. 3
seconds to confirm the reset operation.

Manual says this about the key:

If the LED does not start flashing after holding the button
down for 5 seconds but is illuminated continuously,
the sensor cannot be reset! In this case, the encoding
is active using a system security key that differs from
the key delivered with the system. In order to reset the
sensor, you must use the configuration software of the
center for resetting! The procedure is described in the
center software instructions.

That’s interesting though, because I do set a different AES key in Homegear, so I would assume that it would not follow the reset procedure - and yet it does, as it is not lit continuously. So doesn’t that imply that it does in fact not have my configured AES key active? And if that is true, shouldn’t it just pair then as if it were a new device?

I don’t think this information is correct. Most device LED flash red then green then yellow after a reset. If the red LED is lit for 3 seconds, it normally means the reset was not successful.