HM-LC-Bl1PBU-FM - Laufzeiten Fehlerhaft

Hallo,

aus interesse habe ich vor kurzen mal die Homegear Admin-UI ausprobiert, und gesehen das die Werte für REFERENCE_RUNNING_TIME_BOTTOM_TOP und REFERENCE_RUNNING_TIME_TOP_BOTTOM auf dem default von 50s stehen, was jedoch nicht stimmen konnte.
Die Rolladen benötigen hoch wie runter 25s, was ich auch vor langem über den Homematic Manager eingestellt hatte.
Kurzerhand habe ich bei zwei Aktoren die Werte wieder auf 25s geändert und gespeichert. Jetzt fahren die Rolladen aber immer wieder vollständig auf und zu, auch wenn ich nur 50% anfahren möchte.

Über das CLI bekomme ich die richtigen Werte ausgegeben, also sind sie offenbar im Aktor gespeichert worden:

indent preformatted text by 4 spaces
homegear -e rc 'var_dump($hg->getParamset(29,1))'
07/31/20 12:15:10.630 Warning: Setting not found: loadDHParamsFromFile
07/31/20 12:15:10.630 Warning: Setting not found: loadDHParamsFromFile
07/31/20 12:15:10.630 Warning: The setting dhParamPath has been moved from "main.conf" to "rpcservers.conf".
07/31/20 12:15:10.630 Warning: The setting dhParamPath has been moved from "main.conf" to "rpcservers.conf".
array(8) {
  ["AES_ACTIVE"]=>
  bool(false)
  ["CHANGE_OVER_DELAY"]=>
  float(0.5)
  ["REFERENCE_RUNNING_TIME_BOTTOM_TOP"]=>
  float(25)
  ["REFERENCE_RUNNING_TIME_TOP_BOTTOM"]=>
  float(25)
  ["REFERENCE_RUN_COUNTER"]=>
  int(0)
  ["STATUSINFO_MINDELAY"]=>
  float(2)
  ["STATUSINFO_RANDOM"]=>
  float(1)
  ["TRANSMIT_TRY_MAX"]=>
  int(6)
}

Interessant ist noch, das für andere identische Rolladen, die korrekt fahren, über die CLI und auch die Admin-UI jeweils 50s Fahrzeit für beide Richtungen angezeigt wird.

Mir wäre ja an und für sich egal was angezeigt wird, aber eine berechnete Position anzufahren ist für mein Beschattungsprogramm recht wichtig.
Hat jemand eine Idee was ich machen sollte?

Homegear läuft in Version 0.8.0-2837 auf einem Ubuntu.
Angesteuert wird über openhab 2.4

Danke für eure Ideen!

Hi @Schwarzer_Adler,

nutzt du das CCU-Modul oder BidCos direkt?
Du kannst mal

homegear -e rc ‘print_v($hg->forceConfigUpdate(29));’

vor dem getParamset() machen. Damit wird sichergestellt, dass die Daten definitiv neu vom Geraet geladen werden (das ist bei Homematic nicht immer der Fall wg. DutyCycle).

– Micha

1 Like

Hi,
sorry für die lange Leitung, ich bin erst heute dazu gekommen das zu testen. Das Ergebnis ist allerdings ernüchternd:

 homegear -e rc 'print_v($hg->forceConfigUpdate(29,1))'
 08/02/20 13:10:10.684 Warning: Setting not found: loadDHParamsFromFile
 08/02/20 13:10:10.685 Warning: Setting not found: loadDHParamsFromFile
 08/02/20 13:10:10.685 Warning: The setting dhParamPath has been moved from "main.conf" to "rpcservers.conf".
 08/02/20 13:10:10.685 Warning: The setting dhParamPath has been moved from "main.conf" to "rpcservers.conf".
 PHP Fatal error:  Uncaught Homegear\HomegearException: Wrong parameter count. in      /var/lib/homegear/scripts/inline.php:7
 Stack trace:
 #0 /var/lib/homegear/scripts/inline.php(7): Homegear\Homegear->__call('forceConfigUpda...', Array)
 #1 {main}
   thrown in /var/lib/homegear/scripts/inline.php on line 7

Ich nutze das BidCos Modul das dann mit einem Lan-Gateway spricht.

Ist diese Version von Homegear vielleicht etwas buggy (wegen dem php Error)?

Hi @Schwarzer_Adler,

der “Fehler” ist eine Exception von Homegear die besagt, dass die Anzahl der Parameter fuer die Funktion forceConfigUpdate() falsch ist. Lass einfach den 2. Parameter weg und versuch es noch einmal mit

homegear -e rc ‘print_v($hg->forceConfigUpdate(29));’

– Micha

Hi @Micha,

vielen Dank für deine Unterstützung!
Der Befehl von dir führte nur zu Fehlermeldungen, daher habe ich jetzt auf das neueste Nightly 0.8 geupdated.
Jetzt habe ich folgendes:

 homegear -e rc 'print_v($hg->forceConfigUpdate(29))'
 (void)

Wie kann ich denn die Laufzeiten nochmal neu setzen, obwohl sie schon im System sind?