Heizkörperthermostat mit Fensterkontakt koppeln


#1

Hallo zusammen!

Eigentlich habe ich die Geräte schon ziemlich lange, aber erst jetzt bin auch mal auf die Idee gekommen, ein Heizkörperthermostat HM-CC-RT-DN mit einem Fensterkontakt HM-Sec-SCo zu verbinden.

Das wollte ich über addLink() machen:

homegear -e 'rc $hg->addLink(22,1,8,3);'

wobei ID 22 der Fensterkontakt ist und 8 das Thermostat. Allerdings bricht der Befehlt nach ca. 60 Sekunden ab und meldet:

PHP Fatal error:  Uncaught Homegear\HomegearException: No response received. in /var/lib/homegear/scripts/inline.php:7
Stack trace:                                                                  
#0 /var/lib/homegear/scripts/inline.php(7): Homegear\Homegear->__call('addLink', Array)
#1 {main}                                                        
  thrown in /var/lib/homegear/scripts/inline.php on line 7

Logfile:

Marker 1 Start
11/03/18 12:31:23.885 HomeMatic BidCoS packet received (ch-cul-0, RSSI: -67 dBm): 0CEA86702841D000000000BB3A
11/03/18 12:31:23.887 Module HomeMatic BidCoS: Info: HUMIDITY on channel 1 of HomeMatic BidCoS peer 3 with serial number LEQ0121598 was set to 0x3A.
11/03/18 12:31:23.887 Module HomeMatic BidCoS: Info: TEMPERATURE on channel 1 of HomeMatic BidCoS peer 3 with serial number LEQ0121598 was set to 0x00BB.
11/03/18 12:31:25.630 IPC Server: Info: Connection accepted. Client number: 24007
11/03/18 12:31:25.631 IPC Server: Info: Client 18 successfully registered RPC method "cliOutput" (this method is registered by 1 client(s)).
11/03/18 12:31:25.634 IPC Server: Info: Client 18 successfully registered RPC method "cliOutput-18" (this method is registered by 1 client(s)).
11/03/18 12:31:25.636 Script Engine Server: Info: Starting script "/var/lib/homegear/scripts/inline.php" with id 29.
11/03/18 12:31:25.643 Script Engine Server: Info: Client number 0 is calling RPC method: addLink
11/03/18 12:31:43.282 HomeMatic BidCoS packet received (ch-cul-0, RSSI: -73 dBm): 0FE9861028BD450000000A88C1080000
11/03/18 12:31:43.285 Module HomeMatic BidCoS: Info: ACTUAL_TEMPERATURE on channel 4 of HomeMatic BidCoS peer 5 with serial number LEQ0402333 was set to 0x00C1.
11/03/18 12:31:43.286 Module HomeMatic BidCoS: Info: BATTERY_STATE on channel 4 of HomeMatic BidCoS peer 5 with serial number LEQ0402333 was set to 0x08.
11/03/18 12:31:43.286 Module HomeMatic BidCoS: Info: BOOST_STATE on channel 4 of HomeMatic BidCoS peer 5 with serial number LEQ0402333 was set to 0x00.
11/03/18 12:31:43.287 Module HomeMatic BidCoS: Info: CONTROL_MODE on channel 4 of HomeMatic BidCoS peer 5 with serial number LEQ0402333 was set to 0x00.
11/03/18 12:31:43.287 Module HomeMatic BidCoS: Info: FAULT_REPORTING on channel 4 of HomeMatic BidCoS peer 5 with serial number LEQ0402333 was set to 0x00.
11/03/18 12:31:43.287 Module HomeMatic BidCoS: Info: PARTY_START_TIME on channel 4 of HomeMatic BidCoS peer 5 with serial number LEQ0402333 was set to 0x00.
11/03/18 12:31:43.288 Module HomeMatic BidCoS: Info: SET_TEMPERATURE on channel 4 of HomeMatic BidCoS peer 5 with serial number LEQ0402333 was set to 0x22.
11/03/18 12:31:43.288 Module HomeMatic BidCoS: Info: VALVE_STATE on channel 4 of HomeMatic BidCoS peer 5 with serial number LEQ0402333 was set to 0x00.
11/03/18 12:32:12.057 HomeMatic BidCoS packet received (ch-cul-0, RSSI: -57 dBm): 0FF6861028B8190000000AA0C70C2D00
11/03/18 12:32:12.060 Module HomeMatic BidCoS: Info: ACTUAL_TEMPERATURE on channel 4 of HomeMatic BidCoS peer 2 with serial number LEQ0401039 was set to 0x00C7.
11/03/18 12:32:12.060 Module HomeMatic BidCoS: Info: BATTERY_STATE on channel 4 of HomeMatic BidCoS peer 2 with serial number LEQ0401039 was set to 0x0C.
11/03/18 12:32:12.060 Module HomeMatic BidCoS: Info: BOOST_STATE on channel 4 of HomeMatic BidCoS peer 2 with serial number LEQ0401039 was set to 0x00.
11/03/18 12:32:12.061 Module HomeMatic BidCoS: Info: CONTROL_MODE on channel 4 of HomeMatic BidCoS peer 2 with serial number LEQ0401039 was set to 0x00.
11/03/18 12:32:12.061 Module HomeMatic BidCoS: Info: FAULT_REPORTING on channel 4 of HomeMatic BidCoS peer 2 with serial number LEQ0401039 was set to 0x00.
11/03/18 12:32:12.061 Module HomeMatic BidCoS: Info: PARTY_START_TIME on channel 4 of HomeMatic BidCoS peer 2 with serial number LEQ0401039 was set to 0x00.
11/03/18 12:32:12.062 Module HomeMatic BidCoS: Info: SET_TEMPERATURE on channel 4 of HomeMatic BidCoS peer 2 with serial number LEQ0401039 was set to 0x28.
11/03/18 12:32:12.062 Module HomeMatic BidCoS: Info: VALVE_STATE on channel 4 of HomeMatic BidCoS peer 2 with serial number LEQ0401039 was set to 0x2D.
11/03/18 12:32:25.657 Script Engine Server: Info: Client number 0 is calling RPC method: scriptOutput
11/03/18 12:32:25.671 Info: Script with id 29 finished with exit code 255
11/03/18 12:32:25.707 IPC Server: Info: Connection to IPC server's client number 24007 closed.
11/03/18 12:32:29.362 HomeMatic BidCoS packet received (ch-cul-0, RSSI: -73 dBm): 0C99867027068900000000594F
11/03/18 12:32:29.364 Module HomeMatic BidCoS: Info: HUMIDITY on channel 1 of HomeMatic BidCoS peer 7 with serial number LEQ0098575 was set to 0x4F.
11/03/18 12:32:29.365 Module HomeMatic BidCoS: Info: TEMPERATURE on channel 1 of HomeMatic BidCoS peer 7 with serial number LEQ0098575 was set to 0x0059.
11/03/18 12:32:38.145 IPC Server: Info: IPC client 18 removed.
Marker 1 Ende

Ich habe auch probiert, erst die Anlern-Taste des Fensterkontaktes zu drücken, bevor ich das Verbinden starte, was aber auch nichts gebracht hat.
Hat jemand vielleicht einen Tipp, was ich falsch mache?

Gruß
cheuel


#2

homegear -e rc 'PHP'

Das rc gehört nicht in den PHP-String. https://ref.homegear.eu/php.html#affixSection1


#3

Und wesentlich komfortabler geht das über Homematics WebUI …


#4

@pmayer: Danke für den Tipp. Allerdings gab es nach der Abänderung den gleichen Fehler. Da mir das ganze dann spanisch vor kam, habe ich es doch mal mit einem reboot probiert und danach lies sich der Link dann erstellen.

@m0wlheld: Komfortabler mag sein, aber dazu muss man erstmal die Homematics WebUI haben. Die benutze ich nicht.


#5

Hallo @cheuel,

prinzipiell sieht der addLink()-Aufruf korrekt aus. Vom Ablauf her speichert Homegear die Informationen des addLink()-Aufrufs und sendet diese beim nächsten Aufwachen an die beiden Geräte. Bei einigen Geräten muss der Anlernmodus gestartet werden. Mach noch einmal ein $hg->removeLink(22,1,8,3);, bringe danach beide Geräte einmal in den Anlernmodus und poste im Anschluss das Log vom addLink() und anschließendem Anlernmodus beider Geräte. Vielleicht gibt das Aufschluss. In deinem Logausschnitt wird das addLink() ignoriert. Vermutlich, weil Homegear glaubt, der Link existiert bereits. Daher zuerst das removeLink().

Viele Grüße

Sathya


#6

Hallo @sathya,

danke für die Mühe! Ich habe mal das ganze System neu gestartet. Danach konnte ich die Links anlegen ohne Fehlermeldung. Vielleicht hätte ich das mal machen sollen, bevor ich hier poste.

Viele Grüße
cheuel


#7