Firmware Update for HM-MOD-RPI-PCB

I’m using the HM-MOD-RPI-PCB Raspberry Pi Adapter for Homegear on Raspbian. Please, can someone explain to me how to update the firmware. I only find solutions for FHEM, YAHM, OOCU, but I don’t have these software installed. I only use Homegear and OpenHAB2. Thanks a lot.

Hello @yoshi,

I was facing the same problem. The manual FHEM guide worked for me though:

as copied from
*translated and changed to homegear:

sudo su
apt-get update && apt-get -y install libusb-1.0-0-dev build-essential git
systemctl stop homegear
git clone git://
cd hmcfgusb/

Download firmware


Actual flashing - ensure that the device is running on /dev/ttyAMA0, depending on your configuration

./flash-hmmoduart -U /dev/ttyAMA0 coprocessor_update.eq3

One thing though: it was loading and loading and didnt do anything when flashing, as access was blocked somehow. I then disabled homegear from system startup. Shutdown the raspberry, removed the HM-MOD-RPI-PCB, attached it again, started up and then proceeded with the actual flashing. Afterwards activate homegear at system startup again.


thanks for the possibility to do the update in homegear. Can you please give me a hint how I can disable the system startup for homegear?

The flashing is currently stuck at:
Initializing HM-MOD-UART…


I suggest to install rcconf for startup management. You can simply activate and deactivate starting programs in the interface.

sudo apt-get install rcconf

Then use with:

sudo rcconf

1 Like

perfect. This worked. Thanks for the (extremely) fast reply!

1 Like