Fehler in Admin-UI auf Raspberry Pi4

Hallo,

ich Homegear (nightly) auf einem frisch aufgesetzten Raspberry Pi 4 installiert und die Einstellungen erfolgreich von meiner älteren Installation übernehmen können. Per Admin-UI-Login-Seite konnte man sich jedoch nicht einloggen (die Login-Seite kam immer sofort wieder, in den log-Files war kein entsprechender Fehler zu finden).

Nach einigem Suchen habe ich den Fehler gefunden: das Symfony-Framework erwartet Schreibrechte auf einem Verzeichnis /var/lib/php/sessions, wenn man nun aber kein php installiert hat, fehlen die Verzeichnisse /var/lib/php und /var/lib/php/sessions

Ich habe diese nun als root angelegt und für das Verzeichnis sessions zusätzlich die Rechte für alle anderen gesetzt

sudo chmod o+wx sessions

Damit funktioniert es nun.

Vielleicht hat ja noch jemand anderes dieses Problem…

Liebe Grüße,
Holger

2 Likes

Hi Holger,

was fuer eine Distribution bzw. welche Homegear-Version hast du auf deinem Pi? Weil eigentlich sollte das Homegear-eigene PHP den session.save_path im temporaeren Homegear-Verzeichniss “ablegen”, und Symfony nutzt die globalen Settings vom Homegear-PHP.
Hab hier eben ein frisches Raspbian Buster installiert, und da funktionierts problemlos :thinking:

– Micha

Hallo Micha,

ich habe zuerst die aktuellste openhabian-Version und anschließend die Nightly-Version von Homegear (vom Wochenende) installiert. Zusätzlich noch Homebridge und zigbee2mqtt, aber die beiden sollten darauf eigentlich keinen Einfluss haben. Ich habe die Einstellungen von einer älteren Installation (auf stretch basierend) übernommen, vielleicht liegt es daran?
lg Holger

Hi Holger,

hm, sollte eigentlich keinen Einfluss haben. Schau doch mal, was in deiner /etc/homegear/php.ini als session.save_path angegeben ist …

– Micha

Hi Micha,
mache ich nächste Woche, bin gerade unterwegs…
lg Holger

Hi Holger,

alles klaro … ich bin hier :wink:

– Micha