Failed to set GPIO with index "1": Device not open


#1

Hello,

I try to use that HASS.IO addon https://github.com/kreativmonkey/hassio-addons - I am able to receive states like switch state and climate states, but I’m unable to send anything. I get these errors:

12/24/18 01:16:08.292 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Error: No init packet received.
12/24/18 01:16:14.220 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Warning: Connection closed (1). Trying to reconnect...
12/24/18 01:16:16.221 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Connected to HM-MOD-RPI-PCB.
12/24/18 01:16:16.222 Error in file Systems/IPhysicalInterface.cpp line 332 in function virtual void BaseLib::Systems::IPhysicalInterface::openGPIO(uint32_t, bool): Failed to open value file for GPIO with index 1 and device "hm-mod-rpi-pcb": Unable to retrieve path.
12/24/18 01:16:16.222 Failed to set GPIO with index "1": Device not open.
12/24/18 01:16:16.323 Failed to set GPIO with index "1": Device not open.

Who can help me out?

Thanks, Thomas


#2

Have tried updating the HM-MOD-RPI-PCB? What firmware is it on?


#3

I’m pretty sure, thats not the problem. The device is running without any problems on a homegear installation outside of that hass.io plugin.


#4

Ok… I just gave that a try. Had no hands-on with hass.io, yet…


#5

Hello @tringler,

What computer are you running Homegear on? It seems the GPIO settings for the HM-MOD-RPI-PCB in homematicbidcos.conf are not correct. The default settings are for the Raspberry Pi.

Cheers,

Sathya