CPU at 100% if SPI Permission denied

Hello sathya,
I tried to set up MAX! with a CC1101 connected to a RASPI B+ V1.2 with Jessie 4.4.11. and homegear 0.6.0-1327
When starting homegear the cpu usage of homegear increased to 99% and the pi was allmost not addressable any more. As I’m not that Linux pro, it took me some time to find out. The log was full and with:
Could not write to direction file (/sys/class/gpio/gpio25/direction) of GPIO with index 1: Permission denied
homegear tried to communicate with the CC1101 all the time and sucked the cpu time.
I found somewhere that I have to comment out some lines in the file:
It is said, that this should not happen any more in this version of homegear. The problem is/was, that the pi wasn’t aaccessible any more. Can you code something that homegear will stop in such an event after some trials and write a note in the log??? That would help linux beginners like me to debug what’s going on.
Thanks, Ingo

Hey Ingo,

what should not happen anymore is the CC1101 being opened before opening the GPIO and setting it’s direction. Let me see, if I can do something about your problem, too.