Anmeldung UI

Hallo,
ich versuche gerade eine Minimalinstallation mit den nightly zu machen.
Ich habe dann versucht über server:2001 auf das Admin-UI zuzugreifen.
Da kommt dann der Login-Screen und die PW-Abfrage scheint zu klappen und danach erhalte ich eine nette Grafik und nix passiert mehr.
In den Logs habe ich dann folgendes stehen:

10/09/19 22:51:42.976 RPC Server (Port 2001): Error: Uninterpretable packet received. 
Closing connection. Packet was: <nette binärdaten>

Irgendwelche Ideen was ich verkehrt mache?
Ich habe dann mal alle Families in den Konfigdateien auf deaktiviert gesetzt (außer Misc) aber das hat leider nix gebracht.

Hi @FrankW,

was kommt denn nach der Abfrage fuer ein Bild? Und eigentlich hatte ganz zuerst die Aufforderung kommen sollen das Passwort neu zu setzen …

– Micha

Es kommt (so interpretier ich es) das Ladebild, soweit ich mich erinnern kann von gestern Abend is das ein Pfeil nach oben mit Wellen drüber?
Da kam keine Aufforderung zum Passwort setzen. Ich habe homegear als Nutzer und das PW aus der defaultPasswort.txt genommen.

Also es kommt als erstes natürlich der Screen zur PW Eingabe (Homegear-Logo, 2 Textfelder).
Wenn man das PW falsch eingibt gibt es auch ne Fehlermeldung, also scheint das ja irgnedwie zu funktionieren. Erst nach korrektem Login bleibt es hängen.

Fall es eine Rolle spielt: Es war mit einem aktuellen Chrome auf Linux.

Für mich sah es so aus als wollte die GUI irgendwas laden und der Server im Hintergrund kappt die Verbindung.

@Micha
Ich konnte es jetzt nochmal testen. Es ist wirklich ein Pfeil der nach oben zeigt (sieht wie ein Haus aus) und darüber so Wellen. In der Titelzeile steht “Shif - Haus”
Ich hab nochmal die aktuelle nightly installiert. Das Verhalten bleibt gleich.
Wie gesagt. Ich habe noch gar nix konfiguriert, einfach nur homegear installiert.
Ich will halt ungern jetzt alles einrichten und koppeln und fang dann nochmal neu an :slight_smile:

Hmm… Wer lesen kann ist scheinbar wirklich im Vorteil.
Ich nehme alles zurück. Es ist nicht das Admin UI, sondern das “normale” UI. Gibt man den richtigen Pfad /admin/ an kommt man dann auch dorthin wo man hin wollte.
@Micha Er hat mich trotzdem nicht gefragt ob ich einen Nutzer erstellen will.

Und es bleibt nun die Frage warum ich außer dem Ladebildschirm nix sehe beim normalen UI.

sudo apt install homegear-ui ?

homegear-ui ist schon die neueste Version (0.1.0-114).

Wird doch mit im nightly Script installiert.

War nur ne Idee… dann muss @Micha was dazu sagen :slight_smile:

gelöscht. gelöscht. gelöscht.

@FrankW das klingt eher nach der Anmeldeseite der Frontend-UI …

Hallo zusammen,

noch mal schnell zum Verstaendniss: es gibt 2 UIs … einmal die Admin-UI (/admin-ui) und einmal die Frontend-UI (/ui). Beide sind unabhaengig voneinander … die Admin-UI ist von mir, die Frontend-UI nicht … deswegen kann ich zu der nur begrenzt Auskunft geben :wink:

– Micha

1 Like

Hallo @Micha
Ich hab ja meinen Fehler schon eingesehen. Die Admin UI läuft jetzt super.
Womit ich Probleme habe is die Frontend UI (ich hatte halt zuerst den falschen Pfad :/)
Wer macht die Frontend-UI? Das hat jetzt nicht so die Priorität weil ich homegear zusammen mit homeassistent nutzen will, aber es wär schonmal nett zu sehen wie die UI aussieht.

So wirklich fertig ist es das frontend-ui noch nicht. Ich betreibe mein homegear z.b. komplett ohne und wenn du sowieso home assistant einsetzen willst, brauchst du es erst mal nicht.

Joah, hab ich ja geschrieben, dass es nur reines Interesse ist.
In welcher Konfiguration habt ihr Homegear? Bin halt grad dabei mir home-assistent anzuschaun und weiß nicht obs dabei bleiben wird.
Bin auch gern für Alternativen offen.

Ich fahre aktuell homegear + mqtt + node-red: https://allgeek.de/2017/07/09/homematic-mit-node-red-ueber-homegear/

Zukünftig bin ich aber dabei immer mehr Logik in node-blue abzubilden: https://allgeek.de/2019/07/30/node-blue-und-die-evolution-von-homegear/

Im neuen Haus habe ich mich aber aktuell noch nicht abschließend für eine Visu entschieden. Vielleicht wirds sogar homegear-ui… auf jeden Fall unabhängig von der Automation.

Eine Alternative wäre ioBroker. Das läuft bei mir und damit bin ich sehr zufrieden. Allerdings läuft das bei mir ohne Visu. Ich steuere das meiste über nen Telegram Adapter, das reicht bisher für meine Zwecke völlig aus - und das sage ich als Visuentwickler.