Admin UI Passwort unbekannt

#1

Hallo,

ich habe in eine neue Installation meine DB importiert, aber leider weiß ich mein Admin UI Passwort nicht. Wie könnte ich vorgehen?

Vielen Dank, Thomas

#2

Hi Thomas,

die Admin-UI nutzt die ganz normalen Homegear-User, da kannst Du das Passwort per CLI neu setzen:

homegear -e rc '$hg->updateUser("admin", "MeinGanzGeheimesPassword");'

– Micha

#3

Danke - Hat leider nicht geklappt :frowning:

#4

Achso, wenn es der default-Username ist, dann lautet der natuerlich “Homegear” und nicht “admin”.

– Micha

#5

Login scheint zu klappen, aber irgendwie bekomm ich jetzt nur irgendwelches binäres(?) Zeug zurück - So etwas wie:
‹������]»Â0Ew¾Âd/aD"ÉÂc¡20†ÆHi ©‹ÄßšB¥z±-û^‹ùö°)/ÇXª½š‰œ …°¨M.û¶FÒPY[$ÉÎå¾X1àÓKô(ðÙ¹—do[Ë jaHªåº‹^rmjx¯åäÈ£:¡q+ráÔÀ°*xžf0>’‰kcÞ#ÃD-O‚ìwQýý´ZfÙ!™~?ÿ�ÓèéH��

#6

Hm, welche Homegear-Version hast du?

– Micha

#7

Hallo @tringler

hattest du das Nightly? Falls ja, probier es mit der aktuellen Version noch einmal.

Viele Grüße

Sathya

#8

Ich habe jetzt auf das aktuelle Nightly gewechselt und habe leider immer noch den gleichen Fehler :frowning:

#9

Log 05/10/19 00:22:15.631 Script Engine Server: Error: Could not get ACLs for user "Homegear".

#10

Könnte es sein, dass meine DB, die ich importiert habe einfach nicht die admin-ui Tabellen im Bauch hat?

#11

Hi @tringler,

wie “alt” ist die DB denn? Bzw. von welcher Version?

– Micha

#12

Keine Ahnung - Aber ich denke mal so um die 3 Jahre.

#13

Du kannst über das CLI einen neuen Benutzer anlegen. Schau mal, ob es dann klappt:

homegear -r
users create benutzername "kennwort" "1"

Viele Grüße

Sathya