Admin-ui in latest nightly not reachable

Hello, I also wrote about my problem in the german forum, but now I “think” it is aproblem of the build.
I updated for version 0.7.48-3324 to the latest nightly via:

wget -O /tmp/ && bash /tmp/

In the 0.8 version the admin-ui (ip:2001/admin) is not reachable. I also tied to set



but still there is now output in the browser. I tried this on two RPIs on Buster. The images are no copies of each, but were created separately.
What I tried to achiv is to create an CA-authority, which is not working as well.
Is this problem known? Or am I this problem?
Any help appreciated,

I installed different nightly versions (20210201 & 20210307) all with the same result. So I assume it is not a problem of the nightlys but of me.
To clarfy what I wanna do:
I have a homegear-gateway with max!, to have the max! running I need to use the nightly (0.8, as far as I understand). So on the other (master) Pi I need to run the nightly as well. When I try to reach the admin-ui or to install the CA-Authority homegear doesn’t do that.

Any help apprechiated,

I don’t know what I have tried the last days…
I set up a new buster on RPi4 and installed the nightly (0.8). I also installed the admin-ui and homegear-management via dpkg. HG-management tells me, that the management.config is missing. I found it somewhere on the HG-page. that is the same on my productive 0.7. when inserting the conf in the productive, i can reach the admin-ui via Browser. In the productive the created cerificate don’t show up as in the config-command needed:

homegear -e rc ‘$hg->configureGateway("", 2018, file_get_contents("/etc/homegear/ca/cacert.pem"), file_get_contents("/etc/homegear/ca/certs/.crt"), file_get_contents("/etc/homegear/ca/private/.key"), “”);’

After generating the CA-Authority and the certificates, the is only something insid /etc/homegear/ca/privat
I presume that is bcause it is version 0.7 and the description is for version 0.8
O.K., so I trie to do that with 0.8 freshley set up. But here the management doen’t word because of missing config. The one I used for the productive is not working here.
All in all I don’t get it working. Is there anybody out there who has goten a gomegear-gateway with max! and a cc1101 to work and willing to help out?

Hi @elipsoid,

Please try http://ip/admin, the webserver on port 2001 is disabled since end of 2020 (see /etc/homegear/rpcservers.conf) :wink:

– Micha

1 Like