Repairing removed devices


I’ve got half a dozen HM-Sec-SC-2 sensors which I deleted (prm) without unpairing or resetting.

I use a custom AES key and a custom centralAddress

Now, I am trying to reconnect some of these, but I cannot hard-reset them (because of the AES key) and activating pairing mode + pusing the button does not lead to a repairing. I see the following packets:


I tried to manually add it by using pa 00B1 53CD89 NEQ1680251 2.4 but that returns Device type not supported.

The AES key and the centraladdress are with 100% certainty the same now as when they were still paired.

Is there another method to reconnect these? Or is it a lost cause?


paging @sathya

Figured it out. The firmware version needs to be specified in byte form, not float.

So I did a pa 00B1 53CD89 NEQ1680251 24 and pulled the batteries a few times, and it’s working now.

Sorry for the noise :slight_smile:


No noise to see here :wink:
Thank you for documenting.

Hi @infernix,

nevertheless the repairing should’ve worked.


This is no pairing packet though. Did you activate the pairing mode on the window contact?



Neither pairing nor reset worked. I suppose it can’t enter pairing mode if it was already paired and i only did a peer delete; the sensor isn’t aware of any unpair or reset.

The pairing packet is also sent to request configuration updates. So it should definitely have been sent. No idea why it wasn’t.