Inbetriebnahme HM-MOD-RPI-PCB


#5

Hi @pmayer,

vielleicht kannst du mir nochmals die richtigen Schritte aufzählen?

Ich habe als erstes openhabian als Image über eine SD Karte auf dem RPi3 installiert. Anschließend habe ich Homegear installiert über den Befehl “sudo openhabian-config”. Danach habe ich die einzelnen Konfigurationsdateien angepasst.

  • /boot/cmdline.txt

  • /boot/config.txt

  • Befehle ausgeführt
    systemctl disable serial-getty@ttyAMA0.service
    systemctl disable serial-getty@serial0.service
    systemctl disable serial-getty@ttyS0.service

  • Raspberry Pi reboot durchgeführt

  • /etc/udev/rules.d/99-com.rules ==> gelöscht

Konfiguration der Datei: homematicbidcos.conf

Zum Schluss über die Befehle:

  • sudo homegear -r
  • fs 0
  • pon

versucht ein Gerät (HomeMatic Funk Schaltaktor) versucht anzulernen.

PS: Über raspberrymatic bekomme ich eine Verbindung hin.

Wie kann ich die Homegear log Datei in das Forum hochladen?

Gruß,
Eric


#6

Danke für die die ausführliche Beschreibung.

Was steht in deiner homematicbidcos.conf?
Ein entsprechender Ausschnit aus dem Log vom Start von Homegear sollte fürs erste genügen.


#7


#8

Das sieht gut aus. Und der Log-Ausschnitt vom Start von homegear?


#9

Ich habe jetzt hier nochmals alles zusammengefasst:

boot/config.txt

boot/cmdline.txt

homematicbidcos.config


Homegear logfile

Homegear error

/etc/udev/rules.d/99-com.rules


#10

Du kannst aus dem Terminal auch einfach copy&pasten… so muss ich alles abtippen…

“not loading homematicbidcos, beacuse no physical device was found” - das ist dein Fehler.
Lies bitte mal den Starter-Guide hier im Forum. Du hast keine centralAddress gesetzt und du solltest dich schlau machen wozu der rfKey da ist.


#11

kann ich die centralAddress selbst festlegen (Bsp: 0xFD1990) ? Und muss ich den rfKey ändern oder kann ich den beibehalten?

und funktioniert es mit folgendem Image überhaupt?

Image_Datei


#12

Sollte, ich kenne mich mit OpenHabian aber nicht aus…

Leß bitte den Starterguide, da sollte alles drin stehen. Die centralAddress ist frei wählbar (HEX).


#13

Habe den Starter Guide gelesen. Leider immer noch kein Pairing möglich.
Habe auch eine eigene centralAddress (8Zeichen in HEX) vergeben sowie einen rfkey vergeben (32 Zeichen in HEX).
Hast du noch weitere Tipps ich weiß so langsam nicht mehr weiter.

hier nochmals die logfile…

03/27/18 01:31:31.419 Starting Homegear…
03/27/18 01:31:31.419 Homegear version 0.7.15-1580
03/27/18 01:31:31.419 Git commit SHA of libhomegear-base: -
03/27/18 01:31:31.419 Git branch of libhomegear-base: -
03/27/18 01:31:31.419 Git commit SHA of Homegear: -
03/27/18 01:31:31.419 Git branch of Homegear: -
03/27/18 01:31:31.421 Info: Setting allowed core file size to “4294967295” for user with id 0 and group with id 0.
03/27/18 01:31:31.421 Info: Core file size now is “4294967295”.
03/27/18 01:31:31.421 Info: Setting maximum thread priority to “4294967295” for user with id 0 and group with id 0.
03/27/18 01:31:31.421 Info: Maximum thread priority now is “4294967295”.
03/27/18 01:31:31.433 Info: Backing up database…
03/27/18 01:31:31.528 Initializing database…
03/27/18 01:31:31.535 Info: Loading family module mod_homematicbidcos.so
03/27/18 01:31:31.552 /etc/homegear/families/homematicbidcos.conf
03/27/18 01:31:31.553 Info: Loading family module mod_miscellaneous.so
03/27/18 01:31:31.556 /etc/homegear/families/miscellaneous.conf
03/27/18 01:31:31.557 Info: Loading family module mod_homematicwired.so
03/27/18 01:31:31.562 /etc/homegear/families/homematicwired.conf
03/27/18 01:31:31.563 Info: Setting up physical interfaces and GPIOs…
03/27/18 01:31:31.564 Info: Dropping privileges to user homegear (111) and group homegear (116)
03/27/18 01:31:31.565 Info: Homegear is (now) running as user with id 111 and group with id 116.
03/27/18 01:31:31.571 Starting script engine server…
03/27/18 01:31:31.579 Initializing licensing controller…
03/27/18 01:31:31.579 Loading licensing controller data…
03/27/18 01:31:31.579 Loading devices…
03/27/18 01:31:31.579 Loading XML RPC devices…
03/27/18 01:31:32.458 Loading device 2
03/27/18 01:31:32.459 Module HomeMatic BidCoS: Info: Central address set to 0x001C08.
03/27/18 01:31:32.460 Info: Not initializing device family HomeMatic Wired, because no physical interface was found.
03/27/18 01:31:32.460 Info: Disposing family module mod_homematicwired.so
03/27/18 01:31:32.460 Loading XML RPC devices…
03/27/18 01:31:32.462 Loading device 1
03/27/18 01:31:32.462 Initializing RPC client…
03/27/18 01:31:32.462 Starting XML RPC server RPCServer1 listening on :::2001…
03/27/18 01:31:32.465 Starting XML RPC server RPCServer2 listening on :::2002, SSL enabled…
03/27/18 01:31:32.465 RPC Server (Port 2001): Info: RPC Server started listening on address :: and port 2001
03/27/18 01:31:32.503 Starting XML RPC server RPCServer3 listening on :::2003, SSL enabled, authentication enabled…
03/27/18 01:31:32.504 RPC Server (Port 2002): Info: RPC Server started listening on address :: and port 2002
03/27/18 01:31:32.537 Starting CLI server…
03/27/18 01:31:32.537 RPC Server (Port 2003): Info: RPC Server started listening on address :: and port 2003
03/27/18 01:31:32.537 Initializing event handler…
03/27/18 01:31:32.537 Loading events…
03/27/18 01:31:32.538 Starting flows server…
03/27/18 01:31:32.543 Starting IPC server…
03/27/18 01:31:32.547 Start listening for packets…
03/27/18 01:31:34.549 Startup complete. Waiting for physical interfaces to connect.
03/27/18 01:31:34.549 All physical interfaces are connected now.
03/27/18 01:31:34.549 Starting UPnP server…
03/27/18 01:31:34.550 Info: UPnP server: Binding to address: 192.168.178.122
03/27/18 01:31:34.550 UPnP Server: Info: Started listening.
03/27/18 01:31:35.427 RPC Server (Port 2001): Info: Connection from ::ffff:192.168.178.23:64460 accepted. Client number: 13
03/27/18 01:31:35.428 RPC Server (Port 2001): Info: RPC server client id for client number 13 is: 0
03/27/18 01:31:35.527 RPC Server (Port 2001): Info: Connection from ::ffff:192.168.178.23:64461 accepted. Client number: 14
03/27/18 01:31:35.528 RPC Server (Port 2001): Info: RPC server client id for client number 14 is: 1
03/27/18 01:31:41.549 Module HomeMatic BidCoS: HM-MOD-RPI-PCB “My-HM-MOD-RPI-PCB”: Error: No response received to packet: FD0003000003180A
03/27/18 01:31:41.549 Module HomeMatic BidCoS: HM-MOD-RPI-PCB “My-HM-MOD-RPI-PCB”: Error: Unknown packet received in response to init packet. Reconnecting…
03/27/18 01:31:41.858 RPC Server (Port 2001): Info: Connection from ::ffff:192.168.178.122:47218 accepted. Client number: 15


#14

Das sieht aber schon besser aus:

03/27/18 01:31:32.459 Module HomeMatic BidCoS: Info: Central address set to 0x001C08.
...
03/27/18 01:31:34.549 Startup complete. Waiting for physical interfaces to connect.
03/27/18 01:31:34.549 All physical interfaces are connected now.

Ich glaube fast, dass du die Firmware des HM-MOD-RPI-PCB updaten musst. Ich habe leider kein solches Modul, aber such mal im Forum… irgendwo war das schon beschrieben.


#15

Leider bekomme ich das Funkmodul nicht upgedated. Kann man den irgendwo die aktuelle Firmware auslesen lassen?

Was könnten noch weitere Gründe sein, weshalb kein Pairing meiner Geräte mit Homegear möglich ist?

Was für Informationen sind noch notwendig um eine konkrete Fehleranalyse vornehmen zu können?


#16

Das Update wäre das nächste was ich probieren würde. Hast du im Forum mal gesucht?




#17

Leider alles bereits versucht. Leider bekomme ich das update nicht hin.


#18

Auch das probiert? Letzter Absatz ist das Relevante.

Falls ja, teile mal mit wo was passiert. Einfach nur “geht nicht” und “alles gemacht” hilft nicht bei der Problemlösung.


#19

Also ich fange mal von Beginn an:

  1. Image Datei openhabian über SD-Karte auf RPi 3 Model B Rev 1.2 installiert (Version: openhabian Image-Datei
  2. über den Befehl sudo openhabian-config
  • 01 | Update
  • 02 | Upgrade System
    durchgeführt
  1. über den Befehl sudo openhabian-config
  • 20 | Optional Components ==> 26 | Homegear ==> installiert
  1. /boot/cmdline.txt ==> angepasst
  2. /boot/config.txt ==> angepasst
  3. /etc/homegear/families/homematicbidcos.conf ==> angepasst
  4. Geräte anlernen über die Befehle
  • sudo homegear -r
  • fs 0
  • pon

==> keine Geräte können angelernt werden.

Daraufhin habe ich versucht über das Homegear logfile mögliche Ursachen zu finden, leider ohne Erfolg.

Nun versuche ich die Firmware von meinem Funkmodul (HM-MOD-RPI-PCB) zu aktualisieren. Wenn ich versuche die Firmware über die Anleitung ohne Installation von FHEM zu machen bleibt ich immer nach dem flashen hängen (INITIALIZING …). Über die Variante mit …HM-MOD-UART-141.eq3 bekomme ich die Meldung "Can’t stat HM-MOD-UART-141.eq3. No such file or directory

Mache ich hierbei was falsch oder was könnte mein Fehler sein?

Kann ich das Funkmodul bereits bei der Installation der openhabian Image-Datei über die serielle Schnittstelle aufstecken?
Inwieweit muss ich in der homematicbidcos.conf die centraladress und de rfkey ändern?
Ist die Funk-Schaltaktor 1-fach mit Leistungsmessung (HM-ES-PMSw1-PI-DN-R1, 868,3 MHz) mit meinem Funkmodul kompatibel?

Danke mal soweit…


#20

Das Modul solltest du aufstecken, bevor du den Pi mit Strom versorgst, sollte aber keinen Unterschied machen.

Das steht im Starterguide :wink:
rfKey ist dein AES-key und centralAddress ist die Adresse an die die Geräte angelernt werden.

Jedes Homematic-Gerät ist mit dem Funkmodul kompatibel, da es erstens von eq3 ist und zweitens die Geräte ja an Homegear angelernt werden und nicht an das Modul.

Alle Geräte die hier aufgeführt sind, sind kompatibel: https://ref.homegear.eu/family.html?familyLink=homematicbidcos&familyName=HomeMatic+BidCoS

Ich habe zwar kein HM-MOD-RPI-PCB, behaupte aber, dass es bei dir am Firmware-Update liegt. Ich empfehle dir also das als erstes, wie in den anderen Threads beschrieben, zu machen.
Von Homegear-Seite aus, sofern die Änderungen in der cmdline.txt und boot.txt richtig sind, fällt mir nichts auf was falsch sein könnte.


#21

Das Firmware Upgrade läuft definitiv falsch.

Hier ist schon einmal ein Fehler. Poste mal deine Schritte zum Firmware Upgrade.

Das ist auch falsch und deutet, ohne die Anleitung zu kennen, auf eine Fehlkonfiguration der seriellen Schnittstelle hin. Poste mal config.txt, cmdline.txt. Hast du die 3 “serial”-services" disabled?


#22

Hier mal meine Infos…


#23

Kannst du bitte code fences verwenden. Bitte editiere deinen Beitrag. Ansonsten ist der sehr schwer zu lesen. Danke!


#24

grafik