"homegear: symbol lookup error: homegear: undefined symbol:" - after update?


I updated my Homegear setup (via OpenHabian) yesterday evening from 0.7.27-1824 to version 0.7.38-2757.

After that homegear -r does not work any more? I get the following error:
homegear: symbol lookup error: homegear: undefined symbol: _ZN3Ipc8VariableC1EPKc

Any idea how this can be fixed?


This is strange. Did something go wrong during upgrade? Did you try to reinstall again?

Nothing went wrong during the update at least I could not see anything. Also homegear service is starting like normal, nothing suspicious in the log.

Reinstall via sudo apt install --reinstall homegear homegear-homematicbidcos did not fix it, same error as before.

@job any update on this?

Not sure if uninstall & re-install work better?

I have no idea. Maybe some old part of homegear is still running?

I would suggest uninstalling every homegear part and reinstalling again.

Hi mhaack, did you fix it in the meanwhile? I am having now the exact same issue. Any hint is appreciated :slight_smile:

It works now also for my environment. Unfortunately not totally show how this was fixed. I updated/upgraded openhab and reinstalled homegear in random orders with some reboots of the raspberry. Finally it worked. Not very professional but maybe this will also help others.


Exactly the same problem here on Raspbian stock image.

So just to be sure, did the uninstall and reinstall kill any of your homematic configuration? Or was it just as simple as apt-get remove homegear / install?

EDIT: I did an apt-get install --reinstall homegear

Which fixed the issue. I have the feeling that during the last upgrade I did not get asked alle the questions about keeping the configuration. The reinstall did this and now it works all fine.