Homegear (in Docker Container) funktioniert nicht mit Homematic-Manager

Hallo,

ich versuche meine Homematic Geräte in einem ansonsten wunderbar laufenden Homegear (Docker Container homegear:stable) mittels des Homematic-Managers zu konfigurieren (https://github.com/hobbyquaker/homematic-manager) zu verwalten.

Ich bin mir nichtmal sicher, ob das Problem durch Homegear oder den Homematic-Manager verursacht wird und poste daher mal vorsichtig hier - vielleicht kennt das Thema ja jemand.

Also, nochmal zum eigentlichen Problem:
Wenn ich versuche den Homematic-Manager mit meinem Homegear zu verbinden, dann sehe ich im Homegear zunächst vielversprechende Logs:

05/10/20 13:12:12.794 RPC Server (Port 2001): Info: Connection from ::ffff:192.168.100.158:52533 accepted. Client number: 26
05/10/20 13:12:12.794 RPC Server (Port 2001): Info: RPC server client id for client number 26 is: 3
05/10/20 13:12:14.851 RPC Server (Port 2001): Info: Connection from ::ffff:192.168.100.158:52539 accepted. Client number: 27
05/10/20 13:12:14.851 RPC Server (Port 2001): Info: RPC server client id for client number 27 is: 4
05/10/20 13:12:14.853 RPC Server (Port 2001): Info: Client number 27 is calling RPC method: init (1) Parameters:
(String) http://192.168.100.158:2000
(String) hmm_BidCos-RF
05/10/20 13:12:14.853 Info: Client with IP ::ffff:192.168.100.158 is calling "init".
05/10/20 13:12:14.854 Info: Removing server "http://192.168.100.158".
05/10/20 13:12:14.855 Info: Adding server "http://192.168.100.158".
05/10/20 13:12:14.856 Info: Calling init methods on server "http://192.168.100.158".
05/10/20 13:12:16.447 Debug: Adding method system.multicall
05/10/20 13:12:16.447 Debug: Adding method event
05/10/20 13:12:16.447 Debug: Adding method newDevices
05/10/20 13:12:16.447 Debug: Adding method deleteDevices
05/10/20 13:12:16.447 Debug: Adding method replaceDevice
05/10/20 13:12:16.447 Debug: Adding method listDevices
05/10/20 13:12:16.447 Debug: Adding method system.listMethods

Im Homematic-Manager sieht es eigentlich aus gut aus:

aber es passiert dann schlichtweg gar nichts mehr…keine Fehlermeldungen, keine Warnungen, nix.

Hab es von mehreren PCs aus probiert und auch testweise die Windows Firewall deaktiviert - keine Besserung.

Homegear läuft ansonsten wie gesagt problemlos - Kommunikation mit z.B. homeassistant funktioniert ohne jegliche Probleme.

Ich bin mittlerweile recht ratlos, was ich noch testen oder probieren könnte.
Vielleicht kennt ja jemand dieses Verhalten oder hat sonst noch eine Idee?

Hm. Bin unsicher. Aber war da nicht mal was, dass der Homematic-Manager nicht mit deutschen Umlauten in Namen von Geräten an homegear klar kommt?

hm‚Ķok - kann ich mal √ľberpr√ľfen.
Was ich nicht erwähnt hatte: ich hatte das Setup Homegear <-> Homematic Manager schon problemlos am laufen. Dann habe ich vor einigen Monaten Homegear auf einen anderen Host und nach Docker umgezogen und wollte jetzt mal wieder den Homematic Manager benutzen.

Beim Umzug von Homegear habe ich soweit die komplette Config und auch alle bereits angelegten Ger√§te mitgenommen‚Ķwann genau der Homematic Manager ‚Äúkaputt‚ÄĚ gegangen ist, kann ich gar nicht sagen.

hab jetzt nochmal nachgesehen - die Homematic Komponenten sind alle ohne Umlaute geschrieben.
Es gibt dann auch noch ein paar Max! Heizk√∂rper Thermostate und hier gibt es schon Umlaute in den Namen. W√ľrde die ja umbenennen, bin mir aber grad nicht sicher welchen Rattenschwanz das ggf. nach sich zieht.

Das die Adressierung komplett √ľber die ID l√§uft, sollte das keinen Unterschied machen.

Mal ne andere Frage: Was kann der Homematic-Manager, was die admin-ui nicht auch schon kann?
In der aktuellen nightly hat @Micha nochmal einiges an Funktionen eingebaut.

Ich glaube aber √ľbrigens, dass ich hier grade zwei Sachen verwechsel. Ich dachte es ging um die alte Windows-App, die seit Jahren nicht mehr weiterentwickelt wird.

Mache grade mal einen Test.

//edit:
Ok, kann die aktuelle stable noch nicht mal am Mac ausf√ľhren‚Ķ

Unter Windows läuft er…
Ok, gleiches Problem mit der aktuellen nightly… ohne Umlaute in irgendwelchen Namen.

05/12/20 12:58:30.529 RPC Server (Port 2001): Info: Connection from ::ffff:192.168.40.142:50026 accepted. Client number: 25
05/12/20 12:58:30.529 RPC Server (Port 2001): Info: RPC server client id for client number 25 is: 4
05/12/20 12:58:32.552 RPC Server (Port 2001): Info: Connection from ::ffff:192.168.40.142:50031 accepted. Client number: 26
05/12/20 12:58:32.552 RPC Server (Port 2001): Info: RPC server client id for client number 26 is: 5
05/12/20 12:58:32.557 RPC Server (Port 2001): Info: Client number 26 is calling RPC method: init (1) Parameters:
(String) http://192.168.40.142:2000
(String) hmm_BidCos-RF
05/12/20 12:58:32.557 Info: Client with IP ::ffff:192.168.40.142 is calling "init".
05/12/20 12:58:32.558 Info: Adding server "http://192.168.40.142".
05/12/20 12:58:32.559 Info: Calling init methods on server "http://192.168.40.142".
05/12/20 12:58:36.227 Debug: Adding method system.multicall
05/12/20 12:58:36.228 Debug: Adding method event
05/12/20 12:58:36.228 Debug: Adding method newDevices
05/12/20 12:58:36.228 Debug: Adding method deleteDevices
05/12/20 12:58:36.228 Debug: Adding method replaceDevice
05/12/20 12:58:36.228 Debug: Adding method listDevices
05/12/20 12:58:36.228 Debug: Adding method system.listMethods
05/12/20 12:58:48.069 IPC Server: Info: IPC client 2 removed.
05/12/20 12:58:48.890 IPC Server: Info: Client number 0 is calling RPC method: lifetick Paramete

hm, auch ne gute frage. ich kann dir zumindest sagen was mein plan war - ob das auch ohne homematic manager geht hab ich (noch) nicht probiert.
Was ich tun wollte ist einen homematic Windmesser mit einem Markisenaktor zu pairen, damit bei √ľberschreiten ein gewissen Windgeschwindigkeit automatisch meine Markise einf√§hrt‚Ķdas funktioniert normalerweise tadellos aber wegen hw tausch der markise muss ich das neu pairen.

‚Äúnightly‚ÄĚ schreckt mich offen gesagt ein klein wenig ab, da sich mein setup sozusagen im ‚Äúproduktiv betrieb‚ÄĚ befindet :slight_smile:

ich hab grad ebenfalls die stable auf nem mac probiert - startet auch bei mir nicht. wie es scheint blockt apple die ausf√ľhrung‚Ķ

Hmm, das kann man mit rechte Maustaste -> √Ėffnen normalerweise umgehen. Ist ja nur wenn es kein g√ľltiges Entwicklerzewrtifkat gibt.
Bei mit st√ľrzt es sofort ab mit der Option zum Fehlerbericht senden.

Also, Direktverknuepfungen gehen in der AdminUI nicht :wink:
Alternative waere der Weg ueber Node-BLUE …

‚Äď Micha

ok, ich habe jetzt auf dem mac mit der vorletzten 2.6.1er Version herumgespielt und damit scheint es zu klappen.
unter windows dachte ich eigentlich ich hätte die ältere homematic manager version bereits getestet - mach ich nachher nochmal.

in summe scheint mir das problem dann jetzt aber ein thema im homematic manager und NICHT in homegear zu sein…

Ich habe dein beschriebenes Konstrukt ohne Probleme am Laufen. Nutze allerdings die Linux Version vom Homematic Manager in der Version von letzter Woche. Nur die Namen der Devices werden √ľberhaupt nicht angezeigt. Hat mich auch nicht sonderlich interessiert. Habe dar√ľber nur fix das Pairing der Ger√§te untereinander gemacht.

Port 2001 ist aber exposed, oder? Das entf√§llt nat√ľrlich wenn du den Container im Host Netzwerk hast.

Das Pairing kannst du ansonsten auch √ľber den Cli von Homegear machen.

2 Likes

Das Ganze wird ohnehin irrelevant, sobald in der Admin-UI Direktverkn√ľpfungen unterst√ľtzt werden.

Ja, die Ports 2001 - 2003 sind exposed. Mit einem älteren Mac Client hat es dann ja auch funktioniert. Scheint mir daher ein Problem im Homematic Manager zu sein.
Meine konkrete Anforderung einer Direktverkn√ľpfung zweier Homematic Devices konnte ich so jetzt durchf√ľhren und damit ist mein akutes Problem gel√∂st.

Wenn ohnehin bald auch die Admin-UI Direktverkn√ľpfungen unterst√ľtzen wird, entf√§llt mein UseCase f√ľr den Homematic Manager ohnehin ganz.