CC1101 Homematic Pairing funktioniert nicht


#1

Hi, um mein Haus um Automatisierungsfunktionen zu erweitern habe ich mich für Homematic mit openHAB und somit auch Homegear auf einem Raspberry PI (3) entschieden, nachdem ich viele gute Sachen darüber gelesen habe.

Um den Funkkontakt mit den Geräten herzustellen habe ich auf den CC1101 SPI Adapter von pmayer ( https://allgeek.de/2017/09/23/cc1101-spi-adapter-mit-u-fl-antennenbuchse/ ) entschieden. Mit Hilfe des zugehörigen u.FL-SMA Antennenadapter habe ich ihn an eine 868MHz 3.0dBi Antenne angeschlossen und am PI befestigt:

Die Einrichtung von openHABian lief reibungslos, SPI habe ich mit raspi-conf aktiviert und homegear über openhab installiert. Die Einstellungen in der homematicbidcos.conf habe ich mehrfach überprüft und auch die Pins auf dem PI nachgezählt, um auszuschließen, dass ich das Modul falsch aufgesteckt habe.

Leider kann ich keine Homematic-Geräte anlernen. In Homegear kann ich den Pairing-Modus starten, es erscheinen aber keine neuen Geräte, wenn ich dann meine Homematic-Geräte in den Pairing-Modus versetze. Probiert habe ich es mit einem Temperatur/Feuchtigkeitssensor und einem Schaltaktor (Zwischenstecker).

Nun bin ich etwas ratlos, was die weitere Fehlersuche angeht und hoffe, dass mir jemand helfen kann.

Zur besseren Eingrenzung kann ich noch folgende Infos beitragen.

Letzte Zeilen der homegear.log nach Hochfahren des PI:

06/29/18 07:44:01.697 Starting CLI server...
06/29/18 07:44:01.697 Initializing event handler...
06/29/18 07:44:01.697 Loading events...
06/29/18 07:44:01.698 Start listening for packets...
06/29/18 07:44:01.702 Starting Node-BLUE server...
06/29/18 07:44:01.711 Starting IPC server...
06/29/18 07:44:01.715 Startup complete. Waiting for physical interfaces to connect.
06/29/18 07:44:01.715 Info: Waiting for physical interfaces to connect (0 of 180s).
06/29/18 07:44:01.715 All physical interfaces are connected now.
06/29/18 07:44:01.715 Starting UPnP server...
06/29/18 07:44:01.716 UPnP Server: Error in file UPnP/UPnP.cpp line 189 in function void UPnP::getAddress(): No IP address could be found.
06/29/18 07:44:01.716 UPnP Server: Error: Could not get IP address.
06/29/18 07:44:01.716 Warning: Not starting server, because no suitable RPC server for serving the XML description is available (Necessary settings: No SSL, no auth, webserver enabled).
06/29/18 07:47:16.664 HomeMatic BidCoS packet received (My-CC1101-Module, RSSI: -92 dBm): 0E0582021F4FFD1F59690101008034
06/29/18 07:47:54.058 HomeMatic BidCoS packet received (My-CC1101-Module, RSSI: -89 dBm): 0C8386701F4C8300000000FE31
06/29/18 07:50:56.064 HomeMatic BidCoS packet received (My-CC1101-Module, RSSI: -90 dBm): 0C8486701F4C8300000000FE31

Sieht soweit doch gut aus… nach einem ergebnislosen Pairingversuch in Homegear erhalte ich folgende neue Zeilen:

06/29/18 07:53:43.570 HomeMatic BidCoS packet received (My-CC1101-Module, RSSI: -89 dBm): 0C8586701F4C8300000000FE31
06/29/18 07:55:21.782 Info: CLI connection accepted. Client number: 11
06/29/18 07:55:32.677 HomeMatic BidCoS packet received (My-CC1101-Module, RSSI: -92 dBm): 0E0882021F4FFD1F59690101008034
06/29/18 07:55:36.179 HomeMatic BidCoS packet received (My-CC1101-Module, RSSI: -34 dBm): 0D0184105EE32F00000006010000
06/29/18 07:55:38.185 HomeMatic BidCoS packet received (My-CC1101-Module, RSSI: -36 dBm): 1402845F5EE32F00000080000000000000000914FE
06/29/18 07:55:53.710 HomeMatic BidCoS packet received (My-CC1101-Module, RSSI: -38 dBm): 1A0384005EE32F0000001600AC4F455130373637343637513F0100
06/29/18 07:55:53.726 Module HomeMatic BidCoS: Info: Pushing pending queues.
06/29/18 07:55:53.810 Module HomeMatic BidCoS: TI CC110X "My-CC1101-Module": Info: Sending (My-CC1101-Module): 1091A001FD2807FF5EE32F00050000000000 Planned sending time: 06/29/18 07:55:53.809
06/29/18 07:55:53.953 HomeMatic BidCoS packet received (My-CC1101-Module, RSSI: -38 dBm): 0A9180025EE32F2807FF00
06/29/18 07:56:15.847 Info: Connection to CLI client number 11 closed.
06/29/18 07:56:16.575 HomeMatic BidCoS packet received (My-CC1101-Module, RSSI: -90 dBm): 0C8686701F4C8300000000FE31

In der homegear.err sehe ich eigentlich nur RPC-Meldungen, sollte also nichts mit diesem Problem zu tun haben.

Würde mich sehr freuen, wenn mich jemand auf die richtige Fährte bringen kann!
Vielen Dank im Voraus!


#2

Hi Björn,

das ist sehr komisch, wärst der Erste wo es nicht funktioniert :wink:

Hast du einen rfKey und eine centralAddress vergeben? Diese sollten angepasst werden und nicht auf default gelassen werden… siehe Grundlagen Homegear / Starter-Guide -> Homematic AES.

Und waren die Geräte, die du anlernen möchtest vorher ordentlich “werksresettet”? Also abgelernt und dann in den Werkszustand versetzt worden? Siehe dazu: https://wiki.fhem.de/wiki/AES_Encryption#Hinweise - sofern AES aktiv war. Wenn nicht tut es ein simpler Werksreset des Gerätes.
Waren die vorher an einer CCU mit dem default key angelernt, nutzt homegear den automatisch beim Anlernen und ersetzt diesen dann durch den von dir vergebenen.

Hier mal ein Beispiel für eine komplette homematicbidcos.conf für das SPI-Modul von mir:

[General]
centralAddress = 0xFD0001
rfKey = 00112233445566778899AABBCCDDEEFF
currentRFKeyIndex = 1

[TI CC1101 Module]
id = My-CC1101
deviceType = cc1100
device = /dev/spidev0.0
responseDelay = 100
interruptPin = 0
gpio1 = 25

PS: Man kann dein Bild leider nicht sehen…

Gruß,
Patrik


#3

So, Bild sollte nun zu sehen sein.

Die Homematic-Geräte waren neu und originalverpackt (bei elv bestellt), der Aktor sogar ein Bausatz, also eher noch nicht vorher irgendwo angelernt.

centralAddress und rfKey habe ich neu vergeben und sollten eigentlich ok sein. Ich werd nachher aber nochmal nachprüfen (bin gerade unterwegs). Oder ich kopiere einfach mal komplett deine conf-Datei rein…

Der currentRFKeyIndex kann ja auf 1 bleiben wenn man die initiale Änderung vornimmt, richtig?

Interpretiere ich die Log-Meldungen eigentlich richtig, dass der Funkverkehr prinzipiell funktioniert? Oder kann es trotzdem noch daran liegen?


#4

Dann sollte das in keinem Fall das Problem sein.

Richtig.

Ja, tust du. Beim Anlernen sollten die Geräte nache am Pi sein (1-2m). RSSI von -92 und -90 ist halt sehr wenig, vor allem zum Anlernen. Zwischendrin hast du ja auch -38, was ok ist.

Welches Geräte (HM-…) vesucht du denn anzulernen?


#5

Erfolg! Vielen Dank. Ich hab jetzt ganz blöd einfach mal deine Konfiguration bei mir reinkopiert und es funktioniert einwandfrei! Der genaue Vergleich zeigt, dass ich aus irgendeinem Grund für den Parameter centralAddress eine 8-stellige Hexzahl verwendet habe statt 6 Stellen. Richtig blöder Fehler.

Genau so blöd war allerdings, dass bei dem originalverpackten HM-WDS40-TH-I-2 die mitgelieferten Batterien anscheinend leer waren :wink: Nach Austausch klappt alles.

Also vielen Dank für die Bemühungen und sorry für meine Blödheit. Nun muss ich “nur” noch openHAB für meine Zwecke konfigurieren :wink:


#6

hallo, schüchterne Frage: wäre es nicht sinnvoll am Fusspunkt der Antenne eine Groundplane vorzusehen? So 3 x Viertelwellen - Drahtstücke (ca 85 mm, je nach Drahtdicke) an der Buchse anlöten oder unterklemmen reicht. Ich verwende in solchen Fällen selbstklebende Kupferstreifen mit ca. 5 mm Breite, wie sie beim Basteln von Tiffany-Lampen verwendet werden.
Gruss /starfish


#7

Hey @starfish,

ich versteh leider nicht ganz was du meinst. Auf der Adapterplatine oder an der Antenne selbst? Also an dem SMA-Adapter?


#8

Kannst auch node-red mit node-red-dashboard nehmen. Hatte vor Längerem mal was dazu geschrieben - damals noch ohne den Adapter. Dort habe ich MQTT als Transport zwischen Homegear und node-red genutzt, für mich immer noch der präferierte Weg.

Es gibt aber mittlerweile auch einen node-red-contrib-ccu node von Sebastian Raff der für eine CCU gedacht ist. Da Homegear aber in den Schnittstellen kompatibel ist, könnte man also auch diesen nehmen.


#9

@starfish Ich versteh auch nicht ganz, was du meinst. Vermutlich ist dein Anliegen, mögliche Störungen des Antennensignals zu mindern, indem ich es stärker gegen die Platine des PIs abschirme? Bin in der Hinsicht leider ziemlicher Laie, mein einziger Gedanke war, dass ich die Antenne nicht dorthin packe, wo der Stromanschluss des PIs ist. Die Biegung des Antennenkabels fand ich gerade noch so akzeptabel.

@pmayer Prinzipiell ist mir irgendwas Node.js-basiertes auch viel lieber, da ich in JS gut zu Hause bin (PHP ist etwas her), mir scheint aber die openHAB-Welt derzeit noch “belebter” zu sein. Aber das schöne ist ja, dass man nicht unbedingt eingleisig fahren muss! Aktuell bin ich noch etwas mit Grafana beschäftigt, das klappt jetzt aber auch schon ganz gut.


#10

Da bietet sich node-red an. Auch wenn ich zugeben muss, mit homegear-influx noch nichts gemacht zu haben.

Hier mal als Beispiel der aktuelle Traffic der FritzBox in node-red-dashboard und gleichzeitig in eine InfluxDB zur Auswertung in Grafana:

02
26


#11

hallo bjoernbg, an der SMA-Buchse. schau mal hier: https://www.stall.biz/project/externe-ccu-antenne-mehr-reichweiteweniger-fehlermeldungen oder https://www.stall.biz/project/externe-flachantenne-fuer-die-homematic-und-vergleich-mit-anderen-loesungen … mir ist nur auf Deinem Foto aufgefallen, dass bei der Antenne das Gegengewicht fehlt. Vielleicht gehts einfacher mit einem Blechstreifen 170 mm lang und einem Loch für die Buchse in der Mitte bei 85 mm - den Streifen legst Du aufs Gehäuse, steckst die SMA- Buchse durch dann die die 3.0 dbi Antenne wieder drauf und gut is - sieht zwar etwas blöd aus aber erfüllt den Zweck. (oder eben mit den Drahtstücken, viele Wege führen nach Rom).
Sieht übrigens super aus mit dem Adapter-Print von pmayer.


#12

Hallo @starfish,

danke für die Links und den Vorschlag. Wirklich einfach nur einen Blechstreifen? Dicke/Breite egal? In den Links von dir wird ja eher von diagonal (45° bzw. 135°) abgehenden Elementen gesprochen, mit deinem Vorschlag hätte ich dann aber 90°…
Mal schauen, was ich so an Blechteilen finde, dann probier ich das aber sicher mal aus. Gibt es eine schlauere Möglichkeit, die Empfangsstärke zu messen als in der homegear.log zu schauen, was für db-Werte so kommen?

@pmayer Danke für den Hinweis mit node-red. Da ich blind mit openHAB und Grafana losgerannt bin hab ich das auch erstmal ausprobiert und es funktioniert eigentlich sehr gut. Man kann für die Persistierung gut Strategien wählen, um nicht zu viel Datenmüll zu erzeugen. Persistierung im 15-Sekunden-Takt würde mir meine SD-Karte wahrscheinlich nicht verzeihen :slight_smile:


#13

MQTT wäre eine Möglichkeit und dann per mqtt-spy (o.ä) auf den Broker schauen.
Gleiches Gilt aber auch für dein openHab, du müsstest den Wert nur visualisieren. RSSI solltest du im Thing finden.

Ansonsten:

sudo homegear -r
fs 0
ps <device-id>
config print

Dann musst du allerdings noch von HEX umrechnen.


#14

@bjoernbg, Dieser Blechstreifen ist bei Deiner Kiste wohl die einfachste Lösung. Ich würde den so ca. 15mm breit machen und dann an der Gehäusekante 45° nach unten biegen - das ist ein guter Kompromiss und auf jeden Fall besser als gar nichts. Der Streifen kann sehr dünn sein (Weissblech z.B.) oder eine grosse U-Scheibe, an der Du dann 3 Drahtstücke von 85 mm anlötest. Der Phantasie sind (fast) keine Grenzen gesetzt. Einfach was die Bastelkiste so hergibt :rofl:


#15

@pmayer Danke, lasse mir den RSSI-Wert von mehreren Geräten schonmal in influxdb mitloggen, dann kann ich später vergleichen.

@starfish Meinst du es spielt bei der Blechstreifen-Lösung eine Rolle, dass meine Antenne nicht mittig auf dem RasPi drauf sitzt und somit die angewinkelten Teile asymmetrisch gewinkelt wären? Ich brauch aber auch nicht unbedingt eine platzsparende Lösung, kann da auch noch herumexperimentieren und das Teil dann irgendwo platzieren, wo es mich nicht stört.


#16

denke nicht, dass das gross eine Rolle spielt, wenn der Blechstreifen nicht ganz symmetrisch auf dem Raspi sitzt. Wichtig ist, dass das Loch in der Mitte ist und vom Stecker aus beide Seiten gleich lang sind. Ich würde das mal so probieren, und erst dann, wenn die Reichweite immer noch ungenügend ist, die Antenne abgesetzt vom Raspi betreiben, so wie in der verlinkten Anleitung beschrieben.