ROAMING Feedback


#1

Hi Sathya,

a few minutes ago I could finally install the new build which supports the ROAMING feature. (It takes a long time (almost 1,5 days after your last checkin to this build) before the raspian 8 package gets available for apt-get to find it).

My first impression looks really good. Like I have said before, I have 2 HM-CFG-LAN devices and 1 COC. When I now press a remote button while being in my office on the top floor, the peer gets changed to the HM-CFG-LAN sitting under my desk. When I do the same while being in the basement it gets “switched” to the HM-CFG-LAN in the basement.

After this initial test I have changed the ROAMING variable on all of my devices to true, because I wanted Homegear to figure out the best peer for my devices. This seems to work, but due to some small ups and downs on the RSSI values, some of the devices switch back and forth between one peer and another. Those are the devices that sit in the middle of two peers.

Is it possible to add some sort of threshold to the “reception is better” value? I haven’t checked the code yet, but for example: only switch peers if the RSSI of the new one is more then x% better or something like this.

Thanks in advance,
Chris


#2

Hey Chris,

I’m really happy, it works :smiley:. In version 0.5.19 I fixed some small issues causing “CENTRAL_ADDRESS_SPOOFED” service messages. The packet building indeed takes a lot of time. That is, because I currently don’t use a cross compiler but qemu as ARM emulator. I need to change that at some point. Additionally the build server is slow and there are quite some packages to build :wink:.

The difference now needs to be at least 10 dBm (I could make it configurable, too, but I’m not sure yet, where to put that setting logically) and should be in the next nightly (which of course needs some time to build).

Cheers,

Sathya


#3

I have found one problem with ROAMING and the LGW:

01/06/15 08:23:18.022 Info: Changing interface of peer 43 to HMD, because the reception is better.
01/06/15 08:23:18.034 Module HomeMatic BidCoS: HM-LGW “LGW”: Error: Could not remove peer with address 0x2CB0A9

So it seems like the LGW does not want to remove the peer which should be moved to another interface (here the one named HMD).

One question: If I switch on ROAMING for all devices so they can find their best interface and after a few days switch roaming off for all devices which will probably not move. Will the last configured interface stay put in NON ROAMING mode?

Another question: Is there a way to read out the current interface in ROAMING mode for each device?


#4

Hey Wirrkopf,

I have the same issue sometimes. I just changed the source code a little, so Homegear will try to remove the peer more often from the LAN gateway, when the gateway is busy. That might fix it.

Yes.

Yes, with “getDeviceInfo” [1].

Regards,

Sathya

[1] https://www.homegear.eu/index.php/GetDeviceInfo