MAX! mit HM-CFG-LAN


#21

Hallo Miki!

Zu 1: Nicht gleichtzeitig, weil unterschiedliche Funkeinstellungen benötigt werden. Du kannst aber zwei CULs gleichzeitig verwenden, einen für HomeMatic und einen für MAX!.
Zu 2: Die Verknüpfung kannst du als Direktverknüpfung in Homegear erstellen (z. B. Mit dem HomeMatic-Konfigurator). Die “+”-Geräte halte ich für rausgeschmissenes Geld.
Zu 3: In dem Post ist leider kein 64-Bit-Archiv. Das kann ich dir aber Ende der Woche schnell erstellen, dann wird Homegear sehr sicher auf auf deiner NAS arbeiten. Homegear und openHAB parallel sollte keine Probleme machen.

Liebe Grüße

Sathya


#22

Hallo Sathya,

das klingt doch super! :slight_smile:

Konntest du schon was machen an dem x64 Paket?

Gruß Miki


#23

Hey Miki,

hab’s noch nicht geschafft, morgen sollte es aber was werden :wink:.

Liebe Grüße

Sathya


#24

Ist fertig :wink:: https://forum.homegear.eu/viewtopic.php?f=6&t=45&start=30#p793


#25

Hallo Sathya,

mein CUL ist da und schone erfolgreich mit der V3.hex geslasht.

Im Internet lese ich das MAX! in dem MORITZ Mode nur läuft. Wo in Homegear wird dieser Modus gesetzt?

Gruß


#26

Das macht Homegear automatisch für dich. Du musst in der physicalinterfaces.conf nur den CUL für MAX! aktivieren (und den CUL für HomeMatic BidCoS auskommentieren).

Liebe Grüße

Sathya


#27

Ok.

Habe versucht jetzt ein BC-RT-TRX-CyG-2 zu pairen. Hat leider nicht geklappt.

Im Log taucht folgender Fehler auf:

Module MAX: Warning: Device type 0x02FF with firmware version 0x0010 not supported. Sender address 0x0EB2A5.
Laut Device Support List sollte er doch eigentlich funktionieren, oder?

Hast du eine Idee?

Gruß

Miki


#28

Hey Miki,

der wird auch unterstützt. Dein BC-RT-TRX-CyG-2 hat als Typ nur 0x02FF, in der XML-Datei steht nur der Typ 0x0200. Ersetze folgenden Block in der Datei “/etc/homegear/devices/4/BC-RT-TRX-CyG-2.xml”:

	<types>
		<type name="MAX! Radiator Thermostat" id="BC-RT-TRX-CyG-2">
			<type_id>0x0200</type_id>
			<firmware cond_op="GE">0x10</firmware>
		</type>
	</types>

durch

	<types>
		<type name="MAX! Radiator Thermostat" id="BC-RT-TRX-CyG-2">
			<type_id>0x0200</type_id>
			<firmware cond_op="GE">0x10</firmware>
		</type>
		<type name="MAX! Radiator Thermostat" id="BC-RT-TRX-CyG-2">
			<type_id>0x02FF</type_id>
			<firmware cond_op="GE">0x10</firmware>
		</type>
	</types>

Dann wird’s gehen. Die GitHub-Version habe ich ebenfalls angepasst.

Liebe Grüße

Sathya


#29

Das hat geklappt! :slight_smile:

Zum Verständnis…

Homegear hat meine HKT nicht erkannt weil er eine Firmware hatte? Durch die Änderung in der Device.xml haben wir quasi homegear dazu gebracht Devices mit einer anderen Firmware zu pairen, richtig?

Wie verbinde ich jetzt Wandthermostat mit Heizkörperthermostat in Homegear?

Gruß


#30

Genau. Es scheint entsprechend unterschiedliche Versionen des BC-RT-TRX-CyG-2 zu geben. Solange die Einstellungen aber die gleichen sind (davon gehe ich aus), können die einfach in die gleiche XML-Datei hinzugefügt werden.

Am einfachsten über den HomeMatic-Konfigurator (dafür muss allerdings die Gerätefamilie HomeMatic aktiv sein, z. B. indem du ein Dummy-HM-CFG-LAN in der physicalinterfaces.conf hinzufügst, falls du keine HomeMatic-Geräte hast). Dort kannst du eine Direktverknüpfung erstellen.

Alternativ kannst du die RPC-Funktion “addLink” [1] verwenden (z. B. indem du die Datei /var/lib/homegear/scripts/Test.php anpasst). Senderkanal ist “1”. Empfängerkanal ist “3”. Also zum Beispiel:

Liebe Grüße

Sathya

[1] https://www.homegear.eu/index.php/AddLink


#31

Hallo Sathya,

Habe auch ein Wandthermostat gepaired. Einen BC-TC-C-WM-2 den kannte Homematic nicht. Habe die BC-TC-C-WM-4.xml kopiert, umbenannt und angepasst.

einen HM-CFG-LAN habe ich sogar. HomeMatic-Konfigurator Software zeigt mir auch die MAX! Geräte an.

Kann aber keine neue Direkt Verknüpfung erstellen.





BC-TC-C-WM-2.xml (64.9 KB)


#32

Hey Miki,

komisch, dass bei dir der BC-TC-C-WM-2 nicht bekannt war. Eigentlich sollte die XML-Datei mit installiert werden [1].

Warum die Verknüpfungen im Konfigurator nicht angezeigt werden, muss ich mal schauen. Über “addLink” geht’s auf jeden Fall. Ich vermute mal, dass dem Konfigurator die über RPC übermittelten Informationen nicht reichen und die MAX!-Geräte noch irgendwo in den Konfigurator eingebaut werden müssen.

Ich schaue gerade, ob’s mit dem HomeMatic-Manager funktioniert.

Liebe Grüße

Sathya

[1] https://github.com/Homegear/Homegear/blob/master/Miscellaneous/Device%20Description%20Files/MAX/BC-TC-C-WM-2.xml


#33

Mit dem HomeMatic-Manager klappt es :wink:.

LG Sathya


#34

Hallo Sathya,

das hat funktioniert! :slight_smile:

2 Fragen noch:

  1. Wie stelle ich das Wandthermostat auf Ist Temperatur anzeige?
    Das müsste der Befehl SHOW_SET_TEMPERATURE sein. Wie setzte ich den Befehl ab?

  2. Wie sieht jetzt die Syntax im OpenHAB aus?

{homematic="address="LEQ1152000:type=SET_TEMPERATURE ", autoupdate=“false”} ?

Steuer ich nun das Wandthermostat an oder den HKT?

Danke und Gruß


#35

Hallo Miki,

Mit dem HomeMatic-Konfigurator ist es am einfachsten (“Anzeige im Display”). Ansonsten liegst du mit “SHOW_SET_TEMPERATURE” richtig (Ist-Temperatur ist eigentlich standard?). Als RPC-Funktion kannst du für das Setzen “putParamset” verwenden.

Ich steuer bei mir immer beide parallel an. Ich bin mir gerade aber gar nicht ganz sicher, ob das ein Vorteil ist. Probier bei dir am besten einfach die Reaktionszeiten aus. Wenn der Stellantrieb deutlich später die neue Temperatur erkennt, als der Wandthermostat, dann lohnt sich die parallele Ansteuerung. Bei mir habe ich auch “Wake on Radio” ausgeschaltet (BURST_RX), da ich nicht möchte, dass beim Setzen der Temperatur immer alle Wake-on-Radio-Geräte aufwachen.

Liebe Grüße

Sathya


#36

OK.

Im Log bekomme ich den Error:

Can’t find DatapointConfig[address=LEQ005400,channel=2,parameter=SET_TEMPERATURE], value is not published to Homematic server!

in der openhab.cfg ist dieses mal aber kein Blank vor der IP. :slight_smile:


#37

Stimmt die Seriennummer? 9 Zeichen sind zu kurz :wink:.


#38

Japp,

sie stimmt. Habe oben nur beim copy & paste was vergessen.


#39

Hmm. “Can’t find DatapointConfig” heißt, dass OpenHAB den entsprechenden Datenpunkt nicht kennt, heißt die Variable gibt es nicht. Schick mir mal als Private Nachricht die Ausgabe der Homegear CLI (“homegear -r”) von:

fs 0
ds c
ls

(Eigentlich wäre das Posten der Seriennummern datenschutz- und sicherheitstechnisch auch unbedenklich :wink:. Nur die AES-Schlüssel sollten hier nicht auftauchen.)

Pack dazu auch noch einmal deine exakte Items-Zeile. Dann teste ich sie mal bei mir.

Kontrollier auch noch einmal, ob du nicht HM-CC-IT-WM-W-EU und HM-CC-RT-DN vertauscht hast. Bei letzterem liegt “SET_TEMPERATURE” nämlich auf Kanal 4.

Liebe Grüße

Sathya


#40

Hi,

mache ich sobald ich zu hause bin.

Aber warum fs 0? und HM-CC-IT-WM-W-EU und HM-CC-RT-DN?

Ich habe MAX! Geräte.

Sieht die Items Zeile dann anders aus bei MAX!? :question:

Gruß