MAX! mit HM-CFG-LAN


#1

Hallo,

wenn ich das richtig verstanden habe funktionieren MAX! Komponenten nicht mit dem HM-CFG-LAN, richtig?

Max geht nur mit cul, coc, oder?
Wie geht dann das Pairing von statten??

Danke und Gruß


#2

Hey,

genau, mit HM-CFG-LAN lässt sich MAX! leider nicht ansprechen. Prinzipiell könnte das Gerät MAX!, aber dafür müssten die Registereinstellungen des Funkmoduls irgendwie setzbar sein. Diese Unterscheiden sich nämlich von den Einstellungen für HomeMatic-Geräte. Ein entsprechendes LAN-Paket ist aber nicht dokumentiert. Theoretisch könnte man eine eigene Firmware für den HM-CFG-LAN schreiben, dann wäre es möglich.

Genau, mit der gesamten CUL-Familie oder mit einem Texas-Instruments-CC1101-Modul.

Genauso, wie mit HomeMatic-Geräten: Siehe [1].

Kurzanleitung:

[*] Linux-Shell öffnen. Und dann:

sudo homegear -r
families select 4
devices select central
pairing on

Das aktiviert den Anlernmodus für 60 Sekunden. Oder kurz:

sudo homegear -r
fs 4
ds c
pon

Ob das Gerät erfolgreich angelernt wurde, siehst du mit:

ls

Wichtig: Vor dem Anlernen sollten die Geräte in den Werkszustand zurückgesetzt werden.

Alternativ kannst du auch den HomeMatic Manager [2] oder das LAN-Konfigurationstool von eQ-3 [3] verwenden. Letzteres funktioniert leider nur, wenn mindestens eine HomeMatic-Schnittstelle in Homegear definiert ist.

Auf dem Rapsberry Pi lässt sich auch die CCU2-Oberfläche installieren. Siehe Script im Anhang.

Liebe Grüße

Sathya

[1] https://www.homegear.eu/index.php/Pairing_HomeMatic_BidCoS_Devices
[2] https://github.com/hobbyquaker/homematic-manager
[3] http://www.eq-3.de/Downloads/Software/Konfigurationsadapter/Konfigurationsadapter_LAN/HM-CFG-LAN_Usersoftware_V1_515_eQ-3_140812.zip
InstallReGaHss.txt (31.9 KB)


#3

Hallo,

versuche gerade meine MAX! Devices (Wandthermostat und/oder Heizungsthermostat) mit homegear (cul usb) zu pairen, leider ohne Erfolg.
Die Pairing Anfrage scheint er zu bekommen aber irgendwie akzeptiert er sie nicht
Hier die Logs von Homegear:

Versucht habe ich das ganze Mehrfach über die Homegear Console (wie von sathya beschrieben / pon).
Homegear läuft auf einem Raspi mit version 0.5.12.

Habt ihr eine Idee was ich da falsch mache?

Vielen Dank und Gruß


#4

Hey,

sagen wir mal so: Die Länge des Anlernpakets stimmt schonmal, der Rest ist Kauderwelsch :question:. Das Paket sollte etwa so aussehen [1]:

Die Nachricht wird erkannt anhand des Nachrichtentyps im dritten Byte, also “0x04” im Falle des Anlernpakets. In deinem Paket steht da “0xD8”, daher passiert gar nichts. Für Homegear ist das ein unbekanntes Paket.

Jetzt ist die große Frage, warum wird bei dir so ein Schwachsinn empfangen? Welche Version der culfw verwendest du? Haben die Geräte vorher mit dem MAX!-Cube funktioniert? Hast du selbst irgendwelche Quelltextanpassungen gemacht?

Liebe Grüße

Sathya

[1] https://www.homegear.eu/index.php/MAX!Packet-_0x00


#5

Mein Culfw ist die “V 1.57 CUL868”. Hatte das ganze vorher mit FHEM in Betrieb ohne MAX!Cube. Hatte aber alles funktioniert.
Wollte auch schon ein Update auf die 1.6.1 machen, bekomme aber immer die Meldung “no device present”. Habe schon 100x versucht (als root), auch mit gedrücktem smart-switch beim anstöpseln. Immer das gleiche Ergebnis.

lsusb zeigt:

[quote]ID 03eb:204b Atmel Corp. LUFA USB to Serial Adapter Project
[/quote]

Am Quelltext habe ich nichts geändert. Hier nochmal ein Versuch zu pairen:

[quote]11/14/14 15:10:02.003 MAX packet received (My-MAX-CUL, RSSI: 0x3F): 178CD2E0DB72982CE45429CCEFDF9762701D3C3A233924E1
11/14/14 15:10:06.919 MAX packet received (My-MAX-CUL, RSSI: 0x40): 178CD2E0DB72982CE45429CCEFDF9762701D3C3A233924E1
11/14/14 15:10:11.919 MAX packet received (My-MAX-CUL, RSSI: 0x40): 178CD2E0DB72982CE45429CCEFDF9762701D3C3A233924E1
11/14/14 15:10:16.919 MAX packet received (My-MAX-CUL, RSSI: 0x3D): 178CD2E0DB72982CE45429CCEFDF9762701D3C3A233924E1
11/14/14 15:10:21.919 MAX packet received (My-MAX-CUL, RSSI: 0x3E): 178CD2E0DB72982CE45429CCEFDF9762701D3C3A233924E1
11/14/14 15:10:26.918 MAX packet received (My-MAX-CUL, RSSI: 0x3E): 178CD2E0DB72982CE45429CCEFDF9762701D3C3A233924E1
11/14/14 15:10:31.919 MAX packet received (My-MAX-CUL, RSSI: 0x3D): 178CD2E0DB72982CE45429CCEFDF9762701D3C3A233924E1
11/14/14 15:10:44.910 MAX packet received (My-MAX-CUL, RSSI: 0x3E): 0C4117A2197298D1DCDCDCFEBB
[/quote]

Vielen Dank schon mal.

Gruß


#6

Hallo,

hmm, dass es mit FHEM geklappt hat ist komisch, denn die Ausgabe, die du im Log siehst, ist quasi unverändert das, was roh ankommt. Schau mal, ob die Ausgabe in “screen” genauso aussieht:

sudo apt-get install screen
sudo screen /dev/ttyACM0 9600
#In screen (Input ist nicht sichtbar):
Zr[Return]

Bring dann deine Geräte in den Anlernmodus. Sehen die Pakete da genauso aus? Falls ja, wird es jetzt auch nicht mehr mit FHEM funktionieren und ich bin ehrlich gesagt etwas ratlos, was dann los sein soll - sehr merkwürdig. Das Update auf Version 1.6.1 ist aber eine gute Idee. Falls die Pakete in screen korrekt aussehen, liegt das Problem irgendwo an der Kommunikation zwischen CUL und Homegear. Du hast nicht zufällig einen zweiten CUL zum Testen?

Das heißt, dass der Schalter nicht beim Einstecken gedrückt gehalten wurde bzw. der CUL reagiert nicht auf den Schalterdruck (defekt?). Da müsste stehen:

Liebe Grüße

Sathya


#7

Also CUL funktioniert noch mit FHEM. Über die Fhem-Schnittstelle ist auch der einzigste Weg bei dem ich noch Informationen über den CUL bekomme.
Screen zeigt mir gar nichts an. Somit habe ich nun über fhem das update durchgeführt (CULflash CUL_0 CUL_V3) und hat auch funktioniert. Neue Version ist jetzt 1.61. Juhuu :smiley:
Danach habe ich einen reset der Heizungsthermostate (BC-RT-TRX-CyG) gemacht und siehe da…Pairing funktioniert jetzt!!!

Bei dem versuch den Wandthermostat (BC-TC-C-WM-2) zu pairen kommt jetzt leider noch die Fehlermeldung:

[quote]11/14/14 17:06:47.336 MAX packet received (My-MAX-CUL, RSSI: 0x3D): 172904000791F5FD3D4D001003004B455130303631343433
11/14/14 17:06:47.343 Module MAX: Warning: Device type 0x0300 with firmware version 0x0010 not supported. Sender address 0x0791F5.[/quote]

Scheinbar wird der Thermostat nicht unterstützt (erst ab BC-TC-C-WM-4). Mal schauen ob man das auch noch zum laufen bekommt!

Vielen Dank nochmal für die schnelle Hilfe!!!

Gruß


#8

Puh, was auch immer da los war, gut, dass es jetzt funktioniert :wink:.

Unter der Annahme, dass der “BC-TC-C-WM-3” die gleichen Parameter hat wie der “BC-TC-C-WM-4” mach folgendes:

sudo cp /etc/homegear/devices/4/BC-TC-C-WM-4.xml /etc/homegear/devices/4/BC-TC-C-WM-3.xml
sudo nano /etc/homegear/devices/4/BC-TC-C-WM-3.xml

Dann bearbeite die ersten Zeilen, so dass sie so aussehen:

<?xml version="1.0"?>
<device version="1" rx_modes="BURST" cyclic_timeout="600" needs_time="true">
        <types>
                <type name="MAX! Thermostat" id="BC-TC-C-WM-3">
                        <type_id>0x0300</type_id>
                        <firmware cond_op="GE">0x10</firmware>
                </type>
        </types>

Das wars. Bin gespannt auf dein Feedback. Wenn alles funktioniert, gibt’s die XML-Datei im nächsten Release von Homegear.

Liebe Grüße

Sathya


#9

Und wie das funktioniert hat! :smiley: :smiley: :smiley:
Freue mich riesig!!! Jetzt kann mein Projekt weitergehen!!!

Vielen Dank
BC-TC-C-WM-2.xml (63.7 KB)


#10

Hallo Sathya,

vielen Dank für deine ausführliche Anleitung.

Ich habe jetzt einen Homematic HM-LC-Sw1PBU-FM LEQ0042XXXX erfolgreich an homegear anbinden können.

Habe in OpenHAB das homematic Binding so konfiguriert:

[code]############################### Homematic Binding #####################################

Hostname / IP address of the Homematic CCU

homematic:host=192.168.0.35

The communication with the CCU. xml for xmlrpc or bin for the lightweight binrpc, (optional, default is bin).

homematic:rpc=bin

Hostname / IP address for the callback server (optional, default is auto-discovery)

This is normally the IP / hostname of the local host (but not “localhost” or “127.0.0.1”).

homematic:callback.host=192.168.0.35

Port number for the callback server. (optional, default is 9123)

homematic:callback.port=9123

The interval in seconds to check if the communication with the CCU is still alive.

If no message receives from the CCU, the binding restarts. (optional, default is 300)

homematic:alive.interval=300
[/code]

192.168.0.35 ist der homegearpi

Wenn ich jetzt den Befehl in OpenHAB

absetze tut sich nichts und im log taucht folgender Fehler auf:

[quote]org.openhab.model.item.binding.BindingConfigParseException: Invalid binding: address=LEQ0042XXXX
at org.openhab.binding.homematic.internal.bus.BindingConfigParser.parse(BindingConfigParser.java:101)
at org.openhab.binding.homematic.internal.bus.HomematicGenericBindingProvider.processBindingConfiguration(HomematicGenericBindingProvider.java:62)
at org.openhab.model.item.internal.GenericItemProvider.internalDispatchBindings(GenericItemProvider.java:341)
at org.openhab.model.item.internal.GenericItemProvider.internalDispatchBindings(GenericItemProvider.java:317)
at org.openhab.model.item.internal.GenericItemProvider.processBindingConfigsFromModel(GenericItemProvider.java:171)[/quote]

Was mache ich falsch?

Gruß


#11

Hey,

die Config ist nicht ganz richtig. Probier mal:

Switch HomeM "Licht" { homematic="address=LEQ0042804, channel=1, parameter=STATE" }

Liebe Grüße

Sathya


#12

ok, habe ich geändert.

Jetzt kommt aber diese Meldung:


#13

Geh mal in Homegear mit:

sudo homegear -r

Und schick mir die Ausgabe von:

fs 0
ds c
ls

Liebe Grüße

Sathya


#14

Alles klar.

Hier:

code> ls
ID │ Name │ Address │ Serial Number │ Type │ Type String │ Firmware │ Config Pending │ Unreach
────────────┼───────────────────────────┼──────────┼───────────────┼──────┼───────────────────────────┼──────────┼────────────────┼────────
│ │ │ │ │ │ │ │
1 │ HM-LC-Sw1PBU-FM LEQ004… │ 25E306 │ LEQ0042804 │ 0069 │ HM-LC-Sw1PBU-FM │ 2.3 │ No │ No
────────────┴───────────────────────────┴──────────┴───────────────┴──────┴───────────────────────────┴──────────┴────────────────┴────────
[/code]


#15

Hmm, für mich sieht soweit alles korrekt aus. Der einzige Unterschied zwischen deiner Konfig und meiner ist, dass ich eine Gruppe definiert habe:

Switch TestSchalter (gEG) { homematic="address=JEQ0095676, channel=1, parameter=STATE" }

Ich hab gerade mal Gerhard (den Entwickler des openHAB-Bindings) angeschrieben :wink:.

Liebe Grüße

Sathya


#16

Super, vielen Dank.

Kann ich irgendwie aus homegear direkt den Switch ansteuern? Um zu testen ob das geht?


#17

Klar,

öffne die Datei “/var/lib/homegear/scripts/Test.php” und schreib da rein:

print_r($Client->send("setValue", array(1, 1, "STATE", true)));
sleep(2);
print_r($Client->send("setValue", array(1, 1, "STATE", false)));

Anschließend mit

/var/lib/homegear/scripts/Tests.php

in der Shell ausführen.

LG Sathya


#18

Hi!

Du hast in der openhab.cfg bei jedem config Eintrag ein blank davor. Somit wird das Binding überhaupt nicht von openHab initialisiert. Da das schon öfter der Fall war, habe ich das vor einer Weile im Wiki dokumentiert: github.com/openhab/openhab/wiki … ointconfig

Geh das mal durch.

LG
Gerhard


#19

Hi,

in der Tat, es war ein blank davor. :blush:

Schande über mein Haupt.

Vielen, Vielen Dank für die Hilfe gerrieg und sathya. :slight_smile:


#20

Hallo sathya,

ich hätte da noch 2-3 Fragen zu den MAX! Geräten.

Ich habe mit jetzt einen CUL bestellt da mir das mit dem Cube ein wenig auf die Nerven geht…

  1. Kann ich mit einem CUL, MAX! Geräte und Homematic Geräte steuern?
  2. Ich verwende neben den HKTs auch Wandthermostate. Wie werden die HKTs mit den Wandthermostaten “verknüpft” bzw. “gepaired”?
    Läuft das über homegear oder brauche ich die “+” Variante von MAX!? Bei den “+” Geräte kann ich die Kopplung ja direkt unter den Geräten machen.
  3. Ich habe eine Synology x64 NAS. Kann ich die Version hier aus dem Forum dafür nehmen? Gibts Probleme wenn openHAB und homegear zusammen auf einer NAS laufen?

Vielen Dank und Gruß

Miki