HM-MOD-RPI-PCB - Firmware-Update notwendig? *** GELÖST ***


#1

Hallo,

Ich habe mir vor kurzen einen Raspberry 3 und dazu das Funkmodul HM-MOD-RPI-PCB zugelegt.
Ich habe zunächst Rapimatic verwendet - und hier hat das Funkmodul tadellos funktioniert. DIe Hardware scheint also in Ordnung zu sein.

Aber da ich eigentlich Homegear verwenden möchte , habe ich zunächst das openhabian-Image verwendet und dort von openhabian-config Homegear installiert.

Ich habe dabei versucht mich an alle Anleitungen zu halten und habe die entsprechenden Dateien (config.txt, homematicbidcos.conf, …) entsprechend ediert.

Wie schon bei ein paar anderen Usern hat auch bei mir das pairing mit Homematic-Geräten nie funktioniert - die Datei homegear.err zeigt immer die folgenden Fehler:

02/25/17 21:25:41.046 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Error: No response received to packet: FD0003000003180A
02/25/17 21:25:41.046 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Error: Unknown packet received in response to init packet. Reconnecting...
02/25/17 21:25:42.618 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Warning: Connection closed (1). Trying to reconnect...
02/25/17 21:25:55.756 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Error: No response received to packet: FD0003000003180A
02/25/17 21:25:55.757 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Error: Unknown packet received in response to init packet. Reconnecting...
02/25/17 21:25:57.326 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Warning: Connection closed (1). Trying to reconnect...
02/25/17 21:26:10.464 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Error: No response received to packet: FD0003000003180A
02/25/17 21:26:10.465 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Error: Unknown packet received in response to init packet. Reconnecting...
02/25/17 21:26:13.325 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Warning: Connection closed (1). Trying to reconnect...
02/25/17 21:26:26.463 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Error: No response received to packet: FD0003000003180A
02/25/17 21:26:26.463 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Error: Unknown packet received in response to init packet. Reconnecting...
02/25/17 21:26:28.035 Module HomeMatic BidCoS: HM-MOD-RPI-PCB "My-HM-MOD-RPI-PCB": Warning: Connection closed (1). Trying to reconnect...

Ich habe nun 1 oder 2 mal gelesen, dass der Grund für diesen Fehler eine falsche (zu alte) FIrmware bei HM-MOD-RPI-PCB sein könnte.
(siehe: Kein Empfang nach "no answer to packet"-Meldung)

der User Max konnte das Problem lösen indem er die FIrmware das Funkmoduls geupdatet hatte.
Ich habe daher unzählige Mal versucht und entsprechend der Anleitung von Max ein Update durchzuführen.
Allerdings hatte ich das selbe Problem wie Max: Die Quell-Datei wird gelesen, aber nicht geflasht.
Ich habe mich zwar an die Tipps von Max gehalten - leider hatte das Update nie funktioniert.

Ich habe daher 2 Fragen an euch und würde mich über Tipps sehr freuen:

  • Haltet ihr es für notwendig, ein FIrmware-Update durchzuführen um HM-MOD-RPI-PCB mit Homegear zum Laufen zu bringen , bzw. habt ihr auch ein FIrmware-Update durchgeführt?

  • Und sollte ein Firmware-Update nicht notwendig sein - habt ihr einen Tipp wie man den oben beschriebenen Fehler beheben kann?

Ich danke euch herzlich für eure Unterstützung.

Update *** Problem gelöst ****
Ich konnte mittlerweile das Problem selber lösen - und ja - es war die FIrmware.

Was habe ich gemacht?
Nachdem das Firmware-Update nie funktioniert hat., habe ich FHEM installiert und die FIrmware nach der dortigen Anleitung geupdated.
(https://wiki.fhem.de/wiki/HM-MOD-RPI-PCB_HomeMatic_Funkmodul_für_Raspberry_Pi)

Das FIrmware - Update hatte dort problemlos funktioniert.

Anschließend habe ich mit dem Openhabian-Image Homegear installiert, die notwendigen Änderungen an den erwähnten Dateien vorgenommen -> und homegear und das Homematic-Binding in OpenHab hat tadellos funktionert.

cu


Pairing Probleme bei Pi3 mit Jessie und Funkmodul HM-MOD-RPI-PCB
Inbetriebnahme HM-MOD-RPI-PCB
HM-MOD-RPI-PCB und Raspberry2 Konfigurationsprobleme
[Gelöst] HM-MOD-RPI-PCB Homegear verbindet sich mit keinem Thermostat
#2

Kannst du die Änderungen die man an openhabian machen muss irgendwie kurz dokumentieren? Bzw. kurz sagen welchen Teil der homegear-Doku man noch braucht?

Dann kann ich das in meinen Starter-Guide übernehmen…


#3

Gerne, ich habe mich dabei hauptsächlich einen einen Beitrag von space4u gehalten:
(https://community.openhab.org/t/openhabian-hassle-free-rpi-image/13379/490)

(mini)Howto install the eq3 “HM-MOD-RPI-PCB” module on Raspberry 2 with openHABian,
All steps was run after a clean OpenHABian installation…

01 | update the system
sudo apt-get update
sudi apt-get upgrade
sudo rpi-update

02 | edit file and add the line
sudo vim /boot/config.txt
enable_uart=1

03 | edit file and remove the following entrys
sudo vim /boot/cmdline.txt
console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1

04 | edit file and remove the following line
sudo vim /etc/inittab
T0:23:respawn:/sbin/getty -L ttyAMA0 115200 vt100

05 | disable getty service
sudo systemctl disable getty@.service

06 | reboot the system
sudo reboot

07 | check whether service is really no longer running, it is important that we do not receive any output
ps -A | grep getty
output: nothing

08 | check the ttyAMA0 rights
ls -l /dev/ttyAMA0
output: crw-rw---- 1 root dialout 204, 64 Jan 15 00:02 /dev/ttyAMA0

09 | run openhabian-config and execute entrys:
sudo openhabian-config
01 | Update
02 | Basic Setup
03 | Java 8
04 | openHAB 2
11 | Optional: Homegear
20 | Serial Port

  • uncheck [ ] 1 Disable serial console

10 | reboot the system
sudo reboot

11 | edit file and remove the # symbole in the following lines
sudo vim /etc/homegear/families/homematicbidcos.conf

[HomeMatic Wireless Module for Raspberry Pi]
id = My-HM-MOD-RPI-PCB
deviceType = hm-mod-rpi-pcb
device = /dev/ttyAMA0
responseDelay = 95
gpio1 = 18

12 | restart homegear service
sudo /etc/init.d/homegear restart

13 | now you can pair homematic devices with homegear
14 |now you can install the homematic binding in openHAB

Noch eine weitere - fast (es gibt einen kleinen Unterschied in der cmdline.txt) identische - Anleitung, die mir sehr geholfen hat:

https://doc.homegear.eu/data/homegear-homematicbidcos/configuration.html#communication-modules

HM-MOD-RPI-PCB scheint übrigens etwas sensibel zu sein; ich wollte meinen Pi3 über WLAN verbinden - und schon hatte ich wieder den alten Fehler - also seid vorsichtig was ihr macht. :wink:

cu